summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-09-15 06:45:15 +0000
committerPeter Volkov <pva@gentoo.org>2010-09-15 06:45:15 +0000
commitd7b63ccb2644a5c6167ce63479fe73a21c440a74 (patch)
treec48c4e3dbd3b0f7d38981a68872a85c3bc3a055a /www-apps
parentStable for SPARC (bug #323385). (diff)
downloadgentoo-2-d7b63ccb2644a5c6167ce63479fe73a21c440a74.tar.gz
gentoo-2-d7b63ccb2644a5c6167ce63479fe73a21c440a74.tar.bz2
gentoo-2-d7b63ccb2644a5c6167ce63479fe73a21c440a74.zip
Version bump, fixes security bug #335850, thank Tim Sammut fr report and David Hicks for keeping bug up to date.
(Portage version: 2.2_rc81/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mantisbt/ChangeLog8
-rw-r--r--www-apps/mantisbt/mantisbt-1.2.3.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 9e6a60d414eb..ecf3b299ef37 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.93 2010/08/11 22:41:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.94 2010/09/15 06:45:15 pva Exp $
+
+*mantisbt-1.2.3 (15 Sep 2010)
+
+ 15 Sep 2010; Peter Volkov <pva@gentoo.org> +mantisbt-1.2.3.ebuild:
+ Version bump, fixes security bug #335850, thank Tim Sammut fr report and
+ David Hicks for keeping bug up to date.
11 Aug 2010; Joseph Jezak <josejx@gentoo.org> mantisbt-1.2.2.ebuild:
Marked ppc stable for bug #330481.
diff --git a/www-apps/mantisbt/mantisbt-1.2.3.ebuild b/www-apps/mantisbt/mantisbt-1.2.3.ebuild
new file mode 100644
index 000000000000..5abb5e93fac7
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.2.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.2.3.ebuild,v 1.1 2010/09/15 06:45:15 pva Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php5/ezc-Base-1.8
+ >=dev-php5/ezc-Graph-1.5
+ >=dev-php/adodb-5.10"
+
+src_prepare() {
+ # Drop external libraries
+ rm -r "${S}/library/adodb/"
+ rm -r "${S}/library/ezc/"{Base,Graph}
+ sed -e 's:ezc/Base/src/base.php:ezc/Base/base.php:' \
+ -i "${S}"/plugins/MantisGraph/{core/graph_api.php,pages/summary_graph_cumulative_bydate2.php} \
+ || die
+ # Fix incorrect filename
+ sed -e 's:config_default_inc.php:config_defaults_inc.php:' \
+ -i "${S}/lang/strings_russian.txt" || die
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/{CREDITS,CUSTOMIZATION,RELEASE} doc/en/*
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}/config_inc.php"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt"
+ webapp_src_install
+}