summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-16 22:02:57 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-16 22:02:57 +0000
commita47f611c5c21921893cef3336c69fbd5905f1c20 (patch)
treed3671d0da7fac4e360615cfc1f7096b5ca399549 /www-apps
parentMove kde-misc/kbstateapplet from SLOT 0 to 4. (diff)
downloadgentoo-2-a47f611c5c21921893cef3336c69fbd5905f1c20.tar.gz
gentoo-2-a47f611c5c21921893cef3336c69fbd5905f1c20.tar.bz2
gentoo-2-a47f611c5c21921893cef3336c69fbd5905f1c20.zip
Host of updates to make the installation process a lot smoother for first time users.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/files/0.25-postinstall-en.txt9
-rw-r--r--www-apps/mythweb/files/mythweb.conf.nginx16
-rw-r--r--www-apps/mythweb/files/reconfig18
-rw-r--r--www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild6
5 files changed, 38 insertions, 19 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index 7486508f8f16..05d32c97a650 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.93 2012/07/16 16:51:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.94 2012/07/16 22:02:57 cardoe Exp $
+
+ 16 Jul 2012; Doug Goldstein <cardoe@gentoo.org>
+ +files/0.25-postinstall-en.txt, mythweb-0.25.1_p20120715.ebuild,
+ files/mythweb.conf.nginx, files/reconfig:
+ Host of updates to make the installation process a lot smoother for first
+ time users.
16 Jul 2012; Doug Goldstein <cardoe@gentoo.org>
mythweb-0.25.1_p20120715.ebuild, files/reconfig:
diff --git a/www-apps/mythweb/files/0.25-postinstall-en.txt b/www-apps/mythweb/files/0.25-postinstall-en.txt
new file mode 100644
index 000000000000..0848d60cfa0f
--- /dev/null
+++ b/www-apps/mythweb/files/0.25-postinstall-en.txt
@@ -0,0 +1,9 @@
+You probably want to modify
+${VHOST_CONFDIR}/mythweb.include
+to fit your needs and load it into your web server
+configuration.
+
+In order to prevent unauthorized access to your MythTV
+installation, MythWeb can be configured to require
+authentication using htdigest or htpasswd. See
+${VHOST_CONFDIR}/mythweb.include for more info.
diff --git a/www-apps/mythweb/files/mythweb.conf.nginx b/www-apps/mythweb/files/mythweb.conf.nginx
index 727f68ea8a71..2737de91c931 100644
--- a/www-apps/mythweb/files/mythweb.conf.nginx
+++ b/www-apps/mythweb/files/mythweb.conf.nginx
@@ -1,13 +1,13 @@
location /mythweb/ {
- root /var/www/localhost/htdocs;
+ root VHOST_HTDOCS;
auth_basic "MythWeb";
auth_basic_user_file /var/www/htpasswd;
- index /mythweb/mythweb.php;
+ index VHOST_APPDIR/mythweb.php;
try_files $uri @handler;
}
location ~ /mythweb/.+\.php {
- root /var/www/localhost/htdocs;
+ root VHOST_HTDOCS;
include fastcgi_params;
fastcgi_index mythweb.php;
fastcgi_split_path_info ^(.+\.php)(/?.+)$;
@@ -22,9 +22,9 @@ location ~ /mythweb/.+\.php {
}
location @handler {
- root /var/www/localhost/htdocs;
- rewrite /mythweb/(.+\.(php|pl))/.* /mythweb/$1 last;
- rewrite /mythweb/(pl(/.*)?)$ /mythweb/mythweb.pl/$1 last;
- rewrite /mythweb/(.+)$ /mythweb/mythweb.php/$1 last;
- rewrite /mythweb/(.*)$ /mythweb/mythweb.php last;
+ root VHOST_HTDOCS;
+ rewrite VHOST_APPDIR/(.+\.(php|pl))/.* VHOST_APPDIR/$1 last;
+ rewrite VHOST_APPDIR/(pl(/.*)?)$ VHOST_APPDIR/mythweb.pl/$1 last;
+ rewrite VHOST_APPDIR/(.+)$ VHOST_APPDIR/mythweb.php/$1 last;
+ rewrite VHOST_APPDIR/(.*)$ VHOST_APPDIR/mythweb.php last;
}
diff --git a/www-apps/mythweb/files/reconfig b/www-apps/mythweb/files/reconfig
index 662cfb0c195a..01ab9aacff7a 100644
--- a/www-apps/mythweb/files/reconfig
+++ b/www-apps/mythweb/files/reconfig
@@ -8,19 +8,23 @@ die() {
}
if [[ $1 = "install" ]]; then
+
if [[ "${VHOST_SERVER}" = "apache" ]]; then
sed -e "s|/var/www/html/data|${MY_INSTALLDIR}/data|g" \
- -e "s|/var/www/html|${VHOST_ROOT}/${PN}|g" \
- -i ${MY_SERVERCONFIGDIR}/mythweb.conf || \
+ -e "s|/var/www/html|${MY_INSTALLDIR}|g" \
+ ${MY_SERVERCONFIGDIR}/${VHOST_SERVER}-mythweb.conf > \
+ ${VHOST_CONFDIR}/mythweb.include || \
die "apache sed failed"
elif [[ "${VHOST_SERVER}" = "lighttpd" ]]; then
- sed -e "s|/var/www/html/data|${MY_INSTALLDIR}/data|g" \
- -e "s|/var/www/html|${VHOST_ROOT}/${PN}|g" \
- -i ${MY_SERVERCONFIGDIR}/mythweb.conf || \
+ sed -e "s|/var/www/localhost/htdocs/mythweb|${MY_INSTALLDIR}|g" \
+ ${MY_SERVERCONFIGDIR}/${VHOST_SERVER}-mythweb.conf > \
+ ${VHOST_CONFDIR}/mythweb.include || \
die "lighttpd sed failed"
elif [[ "${VHOST_SERVER}" = "nginx" ]]; then
- sed -e "s|/var/www/localhost/htdocs|${MY_INSTALLDIR}/htdocs|g" \
- -i ${MY_SERVERCONFIGDIR}/mythweb.include || \
+ sed -e "s|VHOST_HTDOCS|${VHOST_HTDOCSDIR}|g" \
+ -e "s|VHOST_APPDIR|${VHOST_APPDIR}|g" \
+ ${MY_SERVERCONFIGDIR}/${VHOST_SERVER}-mythweb.include > \
+ ${VHOST_CONFDIR}/mythweb.include || \
die "nginx sed failed"
fi
diff --git a/www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild b/www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild
index dde5a3fbd908..a1b56bf9b2a1 100644
--- a/www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild
+++ b/www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild,v 1.2 2012/07/16 16:51:14 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.25.1_p20120715.ebuild,v 1.3 2012/07/16 22:02:57 cardoe Exp $
EAPI=4
-inherit webapp
+inherit eutils webapp
BACKPORTS="4f6ac2a60b"
# Release version
@@ -81,7 +81,7 @@ src_install() {
webapp_serverowned -R "${MY_HTDOCSDIR}"/data
# Message to display after install
- #webapp_postinst_txt en "${FILESDIR}"/0.24-postinstall-en.txt
+ webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
# Script to set the correct defaults on install
webapp_hook_script "${FILESDIR}"/reconfig