summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-11-26 14:00:48 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-11-26 14:00:48 +0000
commit90ca69f4eb13a7c9eb13c160eac1f1d657d70dd0 (patch)
tree24ecf39e9d6bf412ca63c120e367a90fd0f98426 /www-apps
parentFix from James Le Cuirot for handling of $ROOT in ldscript cleanup #156118. (diff)
downloadgentoo-2-90ca69f4eb13a7c9eb13c160eac1f1d657d70dd0.tar.gz
gentoo-2-90ca69f4eb13a7c9eb13c160eac1f1d657d70dd0.tar.bz2
gentoo-2-90ca69f4eb13a7c9eb13c160eac1f1d657d70dd0.zip
New upstream version.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gitweb/ChangeLog7
-rw-r--r--www-apps/gitweb/files/digest-gitweb-1.4.4.13
-rw-r--r--www-apps/gitweb/gitweb-1.4.4.1.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/www-apps/gitweb/ChangeLog b/www-apps/gitweb/ChangeLog
index 4050b5b4aa71..b00ec98e3549 100644
--- a/www-apps/gitweb/ChangeLog
+++ b/www-apps/gitweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gitweb
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.16 2006/11/16 12:37:10 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/ChangeLog,v 1.17 2006/11/26 14:00:48 ferdy Exp $
+
+*gitweb-1.4.4.1 (26 Nov 2006)
+
+ 26 Nov 2006; Fernando J. Pereda <ferdy@gentoo.org> +gitweb-1.4.4.1.ebuild:
+ New upstream version.
*gitweb-1.4.4 (16 Nov 2006)
diff --git a/www-apps/gitweb/files/digest-gitweb-1.4.4.1 b/www-apps/gitweb/files/digest-gitweb-1.4.4.1
new file mode 100644
index 000000000000..ff3799a8c8f4
--- /dev/null
+++ b/www-apps/gitweb/files/digest-gitweb-1.4.4.1
@@ -0,0 +1,3 @@
+MD5 504521167df43146e1f5d69aa5c5e023 git-1.4.4.1.tar.bz2 887843
+RMD160 0968b31537a9f4a57929cec0f1b6093f91650d9b git-1.4.4.1.tar.bz2 887843
+SHA256 007742a1eab7ef0aed78af4e701c5b877e6b0fe31aa56f2811d3e2fa74549a24 git-1.4.4.1.tar.bz2 887843
diff --git a/www-apps/gitweb/gitweb-1.4.4.1.ebuild b/www-apps/gitweb/gitweb-1.4.4.1.ebuild
new file mode 100644
index 000000000000..b6aef5f4dedc
--- /dev/null
+++ b/www-apps/gitweb/gitweb-1.4.4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gitweb/gitweb-1.4.4.1.ebuild,v 1.1 2006/11/26 14:00:48 ferdy Exp $
+
+inherit webapp
+
+GIT_VERSION="${PV}"
+
+DESCRIPTION="Web interface to GIT repositories"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/git-${GIT_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+>=dev-util/git-${PV}"
+
+S="${WORKDIR}"/git-${GIT_VERSION}/gitweb
+
+src_compile() {
+ sed -i \
+ -e 's~^\(GITWEB_PROJECTROOT =\).*$~\1 /var/git~g' \
+ -e 's~^\(GITWEB_SITE_HEADER =\).*$~\1 header.html~g' \
+ -e 's~^\(GITWEB_SITE_FOOTER =\).*$~\1 footer.html~g' \
+ ../Makefile || die "failed to sed Makefile"
+ emake -C .. prefix=/usr gitweb/gitweb.cgi || die "emake failed"
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc README "${FILESDIR}"/README.gentoo
+ rm -f README
+
+ cp gitweb.{cgi,css} git-{favicon,logo}.png "${D}/${MY_HTDOCSDIR}"
+ cp "${FILESDIR}"/apache.htaccess "${D}/${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}