summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Schuerch <nativemad@gentoo.org>2013-11-26 12:53:33 +0000
committerAndreas Schuerch <nativemad@gentoo.org>2013-11-26 12:53:33 +0000
commit7bf54a2a19b073353ac619447cb4a0e4d35869a9 (patch)
treebeae1c5977da96f7c52ceeaea32584133d4a940f /www-apps
parentinitial ebuild. This is the guacd+libs replacement, used for guacamole. (diff)
downloadgentoo-2-7bf54a2a19b073353ac619447cb4a0e4d35869a9.tar.gz
gentoo-2-7bf54a2a19b073353ac619447cb4a0e4d35869a9.tar.bz2
gentoo-2-7bf54a2a19b073353ac619447cb4a0e4d35869a9.zip
version bump. Added ldap backend and depend on the new guacamole-server instead of guacd and its libs. Also quoted some variables on 0.6.2 to make repoman happy.
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key C1DE54B2)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/guacamole/ChangeLog10
-rw-r--r--www-apps/guacamole/guacamole-0.6.2.ebuild20
-rw-r--r--www-apps/guacamole/guacamole-0.8.3.ebuild93
3 files changed, 112 insertions, 11 deletions
diff --git a/www-apps/guacamole/ChangeLog b/www-apps/guacamole/ChangeLog
index 5b184050cafd..b8040598a737 100644
--- a/www-apps/guacamole/ChangeLog
+++ b/www-apps/guacamole/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/guacamole
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/ChangeLog,v 1.7 2013/08/14 11:31:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/ChangeLog,v 1.8 2013/11/26 12:53:33 nativemad Exp $
+
+*guacamole-0.8.3 (26 Nov 2013)
+
+ 26 Nov 2013; Andreas Schuerch <nativemad@gentoo.org> guacamole-0.6.2.ebuild,
+ +guacamole-0.8.3.ebuild:
+ version bump. Added ldap backend and depend on the new guacamole-server
+ instead of guacd and its libs. Also quoted so variables on 0.6.2 to make
+ repoman happy.
14 Aug 2013; Patrick Lauer <patrick@gentoo.org> guacamole-0.6.2.ebuild:
Whitespace
diff --git a/www-apps/guacamole/guacamole-0.6.2.ebuild b/www-apps/guacamole/guacamole-0.6.2.ebuild
index 09d4b07ca0f6..49af284a8ef1 100644
--- a/www-apps/guacamole/guacamole-0.6.2.ebuild
+++ b/www-apps/guacamole/guacamole-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/guacamole-0.6.2.ebuild,v 1.5 2013/08/14 11:31:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/guacamole-0.6.2.ebuild,v 1.6 2013/11/26 12:53:33 nativemad Exp $
EAPI=4
@@ -26,19 +26,19 @@ RDEPEND="${DEPEND}
rdesktop? ( net-libs/libguac-client-rdp )"
src_compile() {
- mkdir ${HOME}/.m2
+ mkdir "${HOME}/.m2"
cat /usr/share/`readlink /usr/bin/mvn | sed 's:mvn:maven-bin:'`/conf/settings.xml | \
- sed -e 's:/path/to/local/repo:'${HOME}/.m2':g' -e 's:<!-- localRepo::' >${S}/settings.xml
- mvn-2.2 -s ${S}/settings.xml compile war:war
+ sed -e 's:/path/to/local/repo:'${HOME}/.m2':g' -e 's:<!-- localRepo::' >"${S}/settings.xml"
+ mvn-2.2 -s "${S}/settings.xml" compile war:war
}
src_install() {
- sed -e 's:/path/to:/etc/guacamole:g' -i ${S}/doc/example/guacamole.properties || die "properties sed failed"
- insinto /etc/${PN}
- doins ${S}/doc/example/guacamole.properties
- doins ${S}/doc/example/user-mapping.xml
- insinto /var/lib/${PN}
- newins ${S}/target/${P}.war ${PN}.war
+ sed -e 's:/path/to:/etc/guacamole:g' -i "${S}/doc/example/guacamole.properties" || die "properties sed failed"
+ insinto "/etc/${PN}"
+ doins "${S}/doc/example/guacamole.properties"
+ doins "${S}/doc/example/user-mapping.xml"
+ insinto "/var/lib/${PN}"
+ newins "${S}/target/${P}.war" "${PN}.war"
elog "Please unpack /var/lib/${PN}/${PN}.war in to your servlet container!"
elog "Please also link /etc/guacamole in to the lib directory of your servlet container."
elog "like this:"
diff --git a/www-apps/guacamole/guacamole-0.8.3.ebuild b/www-apps/guacamole/guacamole-0.8.3.ebuild
new file mode 100644
index 000000000000..723fb15a0d00
--- /dev/null
+++ b/www-apps/guacamole/guacamole-0.8.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/guacamole/guacamole-0.8.3.ebuild,v 1.1 2013/11/26 12:53:33 nativemad Exp $
+
+EAPI=4
+
+inherit eutils
+DESCRIPTION="Guacamole is a html5 vnc client as servlet"
+HOMEPAGE="http://guacamole.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-client-${PV}.tar.gz
+ mysql? ( http://sourceforge.net/projects/${PN}/files/current/extensions/${PN}-auth-mysql-0.8.2.tar.gz )
+ ldap? ( http://sourceforge.net/projects/guacamole/files/current/extensions/guacamole-auth-ldap-0.8.0.tar.gz )"
+S="${WORKDIR}/${PN}-client-${PV}"
+
+LICENSE="AGPL-3"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="ldap mysql"
+
+DEPEND="dev-java/maven-bin"
+
+RDEPEND="${DEPEND}
+ www-servers/tomcat
+ >virtual/jre-1.6
+ net-misc/guacamole-server
+ mysql? ( virtual/mysql )
+ ldap? ( net-nds/openldap )"
+
+src_compile() {
+ mkdir "${HOME}"/.m2
+ cat /usr/share/`readlink /usr/bin/mvn | sed 's:mvn:maven-bin:'`/conf/settings.xml | \
+ sed -e 's:/path/to/local/repo:'${HOME}/.m2':g' -e 's:<!-- localRepo::' >"${S}"/settings.xml
+ mvn -s "${S}"/settings.xml package
+}
+
+src_install() {
+ if use mysql; then
+ echo lib-directory: "/var/lib/${PN}/classpath" >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo auth-provider: net.sourceforge.guacamole.net.auth.mysql.MySQLAuthenticationProvider >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo mysql-hostname: localhost >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo mysql-port: 3306 >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo mysql-database: guacamole >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo mysql-username: guacamole >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo mysql-password: some_password >>"${S}/${PN}/doc/example/${PN}.properties"
+ sed -e 's:basic-user-mapping:#basic-user-mapping:' -i "${S}/${PN}/doc/example/${PN}.properties"
+ insinto "/var/lib/${PN}/classpath"
+ find "${WORKDIR}/${PN}-auth-mysql-0.8.2/lib/" -name '*.jar' -exec doins '{}' +
+ insinto "/usr/share/${PN}/schema"
+ find "${WORKDIR}/${PN}-auth-mysql-0.8.2/schema/" -name '*.sql' -exec doins '{}' +
+ insinto "/usr/share/${PN}/schema/upgrade"
+ find "${WORKDIR}/${PN}-auth-mysql-0.8.2/schema/upgrade/" -name '*.sql' -exec doins '{}' +
+ elog "Please add a mysql database and a user and load the sql files in /usr/share/guacamole/schema/ into it."
+ elog "You will also need to adjust the DB propeties in /etc/guacamole.properties!"
+ elog "The default user and it's password is \"guacadmin\"."
+ elog "You will also need to download the mysql-connector from here http://dev.mysql.com/downloads/connector/j/"
+ elog "and put the contained .jar file into /var/lib/guacamole/classpath!"
+ elog "-"
+ fi
+ if use ldap; then
+ echo lib-directory: "/var/lib/${PN}/classpath" >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo auth-provider: net.sourceforge.guacamole.net.auth.ldap.LDAPAuthenticationProvider >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo ldap-hostname: localhost >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo ldap-port: 389 >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo ldap-user-base-dn: ou=people,dc=example,dc=net >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo ldap-username-attribute: uid >>"${S}/${PN}/doc/example/${PN}.properties"
+ echo ldap-config-base-dn: ou=groups,dc=example,dc=net >>"${S}/${PN}/doc/example/${PN}.properties"
+ sed -e 's:basic-user-mapping:#basic-user-mapping:' -i "${S}/${PN}/doc/example/${PN}.properties"
+ insinto "/var/lib/${PN}/classpath"
+ find "${WORKDIR}/${PN}-auth-ldap-0.8.0/lib/" -name '*.jar' -exec doins '{}' +
+ insinto "/usr/share/${PN}/schema"
+ doins "${WORKDIR}/${PN}-auth-ldap-0.8.0/schema/guacConfigGroup.ldif" "${WORKDIR}/${PN}-auth-ldap-0.8.0/schema/guacConfigGroup.schema"
+ elog "You will need to add and load the .schema file in /usr/share/guacamole/schema/ to your ldap server."
+ elog "There is also an example .lidf file for creating the users."
+ elog "-"
+ fi
+ sed -e 's:/path/to:/etc/guacamole:g' -i "${S}/${PN}/doc/example/${PN}.properties" || die "properties sed failed"
+ insinto /etc/"${PN}"
+ doins "${S}/${PN}/doc/example/guacamole.properties"
+ doins "${S}/${PN}/doc/example/user-mapping.xml"
+ insinto "/var/lib/${PN}"
+ newins "${S}/${PN}/target/${P}.war" "${PN}.war"
+ elog "Please unpack /var/lib/"${PN}"/"${PN}".war in to your servlet container! If it is an update,"
+ elog "delete the old content first!"
+ elog "Read: if you use the command below, delete everything within /var/lib/guacamole/guacamole first!"
+ elog "Please also link /etc/guacamole in to the lib directory of your servlet container."
+ elog "like this:"
+ elog "cd /var/lib/guacamole && mkdir guacamole && cd guacamole && jar -xvf ../guacamole.war && cd .. && mv guacamole /var/lib/tomcat-7/webapps/"
+ elog "ln -sf /etc/guacamole/guacamole.properties /usr/share/tomcat-7/lib/"
+ elog "You will also need to define users and connectrions in /etc/guacamole/user-mapping.xml if mysql is not used!"
+}