summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-22 16:34:03 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-22 16:34:03 +0000
commit602fc80a1e13e04f0bda55450dbd843ab706bf63 (patch)
tree286bcdaa2aaeb1c15058539fea175e7cb592a0e8 /www-apps
parentMask KDE4 versions of ktorrent as long as KDE4 is masked. (diff)
downloadgentoo-2-602fc80a1e13e04f0bda55450dbd843ab706bf63.tar.gz
gentoo-2-602fc80a1e13e04f0bda55450dbd843ab706bf63.tar.bz2
gentoo-2-602fc80a1e13e04f0bda55450dbd843ab706bf63.zip
ebuild cleanup wrt #208584
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/tikiwiki/ChangeLog5
-rw-r--r--www-apps/tikiwiki/tikiwiki-1.9.9.ebuild56
2 files changed, 30 insertions, 31 deletions
diff --git a/www-apps/tikiwiki/ChangeLog b/www-apps/tikiwiki/ChangeLog
index 93ad0fa1e628..883079aba703 100644
--- a/www-apps/tikiwiki/ChangeLog
+++ b/www-apps/tikiwiki/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-apps/tikiwiki
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.54 2008/01/23 08:56:37 wrobel Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/ChangeLog,v 1.55 2008/02/22 16:34:03 hollow Exp $
+
+ 22 Feb 2008; Benedikt Böhm <hollow@gentoo.org> tikiwiki-1.9.9.ebuild:
+ ebuild cleanup wrt #208584
23 Jan 2008; Gunnar Wrobel <wrobel@gentoo.org> -tikiwiki-1.9.8.3.ebuild:
Removed insecure tikiwiki-1.9.8.3 (sec issue #203265).
diff --git a/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild b/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild
index 11402ddb55b9..ca5b149a4859 100644
--- a/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild
+++ b/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild,v 1.2 2008/01/18 20:25:45 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/tikiwiki/tikiwiki-1.9.9.ebuild,v 1.3 2008/02/22 16:34:03 hollow Exp $
inherit webapp depend.php
@@ -12,60 +12,56 @@ LICENSE="LGPL-2.1"
IUSE="mysql postgres graphviz"
KEYWORDS="~amd64 ppc ~sparc ~x86"
-RDEPEND="virtual/httpd-cgi
- graphviz? ( media-gfx/graphviz )
-"
+RDEPEND="graphviz? ( media-gfx/graphviz )"
+need_httpd_cgi
need_php_httpd
pkg_setup () {
webapp_pkg_setup
- use mysql && require_php_with_use mysql
- use postgres && require_php_with_use postgres
+
+ local my_flags=
+ use mysql && my_flags="${my_flags} mysql"
+ use postgres && my_flags="${my_flags} postgres"
+
+ require_php_with_use ${my_flags}
}
src_install() {
webapp_src_preinst
- local DIR
- local DIRENTRY
- local DIRS="backups db dump files img/trackers img/wiki
- img/wiki_up modules/cache temp
- templates_c templates styles maps whelp mods
- lib/Galaxia/processes"
-
- # Ensure that directories exist, some don't.
- # (part of setup.sh)
- for DIR in ${DIRS}; do
- mkdir -p ${DIR}
- done
-
# Remove the execute permission from the setup.sh script
# and rename it. Its actions have been incorporated here.
chmod a-x setup.sh
mv setup.sh setup.sh.done
- # Install the minimal doc (points to web page)
- #
- dodoc doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+ dodoc changelog.txt copyright.txt doc/readme.txt doc/htaccess doc/htaccess.readme INSTALL README
+ rm -rf changelog.txt copyright.txt doc/ INSTALL license.txt README
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
- # The bulk goes into htdocs
- # but don't copy INSTALL and README
- cp -pPR [[:lower:]]* "${D}"/"${MY_HTDOCSDIR}"
+ local DIR DIRENTRY
+ local DIRS="backups db dump files img/trackers img/wiki
+ img/wiki_up modules/cache temp
+ templates_c templates styles maps whelp mods
+ lib/Galaxia/processes"
# Recursively set server ownership to allow server to write
# This is the rough equivalent of the setup.sh script
# provided in the distribution.
# Note: Cannot use xargs or find -exec here because
# these don't work with shell functions.
- #
+
webapp_serverowned "${MY_HTDOCSDIR}"
+ webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
+
+ # ensure that directories exist, some don't.
+ # (part of original setup.sh)
for DIR in ${DIRS}; do
- find ${DIR} | while read DIRENTRY; do
- webapp_serverowned "${MY_HTDOCSDIR}"/${DIRENTRY}
- done
+ dodir "${MY_HTDOCSDIR}/${DIR}"
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${DIR}"
done
- webapp_serverowned "${MY_HTDOCSDIR}"/tiki-install.php
webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
webapp_src_install