summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Allanos <dju@gentoo.org>2006-12-14 09:08:55 +0000
committerJulien Allanos <dju@gentoo.org>2006-12-14 09:08:55 +0000
commitd4f3b3a1dd74f891cd3cdfe621693d9b8e3888f7 (patch)
tree50318110b5b8ed4df3aaca87f0756b7c664ad021 /www-apps/trac
parentVersion bump to 0.10.4, removing 0.10.2 ebuild. (diff)
downloadgentoo-2-d4f3b3a1dd74f891cd3cdfe621693d9b8e3888f7.tar.gz
gentoo-2-d4f3b3a1dd74f891cd3cdfe621693d9b8e3888f7.tar.bz2
gentoo-2-d4f3b3a1dd74f891cd3cdfe621693d9b8e3888f7.zip
Version bump to 0.10.3, closing bug #157976.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'www-apps/trac')
-rw-r--r--www-apps/trac/ChangeLog7
-rw-r--r--www-apps/trac/files/digest-trac-0.10.33
-rw-r--r--www-apps/trac/trac-0.10.3.ebuild129
3 files changed, 138 insertions, 1 deletions
diff --git a/www-apps/trac/ChangeLog b/www-apps/trac/ChangeLog
index f38697e721de..f423b3b8d85b 100644
--- a/www-apps/trac/ChangeLog
+++ b/www-apps/trac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/trac
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.47 2006/11/23 17:31:14 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/ChangeLog,v 1.48 2006/12/14 09:08:55 dju Exp $
+
+*trac-0.10.3 (14 Dec 2006)
+
+ 14 Dec 2006; <dju@gentoo.org> +trac-0.10.3.ebuild:
+ Version bump to 0.10.3, closing bug #157976.
23 Nov 2006; Francesco Riosa <vivo@gentoo.org> trac-0.10.1.ebuild,
trac-0.10.2.ebuild:
diff --git a/www-apps/trac/files/digest-trac-0.10.3 b/www-apps/trac/files/digest-trac-0.10.3
new file mode 100644
index 000000000000..2e7ded3e823e
--- /dev/null
+++ b/www-apps/trac/files/digest-trac-0.10.3
@@ -0,0 +1,3 @@
+MD5 354cca575cffc732f2fb8015b5c60b50 trac-0.10.3.tar.gz 440811
+RMD160 bfd3c16a2fb9e849ef068a0640a2c14cd2fb4423 trac-0.10.3.tar.gz 440811
+SHA256 b0d5826ff502172fec68d183088e1ac794369e848a541c031eeb53c3fe19da90 trac-0.10.3.tar.gz 440811
diff --git a/www-apps/trac/trac-0.10.3.ebuild b/www-apps/trac/trac-0.10.3.ebuild
new file mode 100644
index 000000000000..7f34cfcb6344
--- /dev/null
+++ b/www-apps/trac/trac-0.10.3.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/trac/trac-0.10.3.ebuild,v 1.1 2006/12/14 09:08:55 dju Exp $
+
+inherit distutils webapp
+
+DESCRIPTION="Trac is a minimalistic web-based project management, wiki and bug/issue tracking system."
+HOMEPAGE="http://trac.edgewall.com/"
+SRC_URI="http://ftp.edgewall.com/pub/trac/${P}.tar.gz"
+
+LICENSE="trac"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="cgi fastcgi mysql postgres sqlite enscript silvercity"
+
+# doing so because utils (such as trac-admin), manpages... overlap
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+
+# we need to depend on virtual/httpd-cgi to pull apache/lighttpd/whatever in when USE cgi
+# we need to depend on virtual/httpd-fcgi to pull mod_fastcgi/lighttpd/whatever in when USE fastcgi
+# we need to depend on virtual/httpd-python to pull mod_python/whatever in when USE python (python
+# is rather confusing here, as dev-lang/python is a required dependency, but httpd-python isn't)
+DEPEND="${DEPEND}
+ >=dev-lang/python-2.3
+ app-text/pytextile
+ >=dev-python/docutils-0.3.9
+ dev-libs/clearsilver
+ >=dev-util/subversion-1.3.2
+ mysql? (
+ >=virtual/mysql-4.1
+ >=dev-python/mysql-python-1.2.1
+ )
+ sqlite? (
+ >=dev-db/sqlite-3.3.4
+ >=dev-python/pysqlite-2.3
+ )
+ postgres? ( >=dev-python/psycopg-2 )
+ enscript? ( app-text/enscript )
+ silvercity? ( app-text/silvercity )"
+
+# The following function should be added to eutils.eclass (see bug #143572):
+
+# Generate an standard error message for missing USE flags
+# in existing packages, and die.
+#
+# Usage: built_with_use_error <category/package> <functionality> [<USE flag>]
+# ex: built_with_use_error dev-util/subversion python
+# or: built_with_use_error net-www/apache LDAP ldap
+#
+# Typical usage:
+# if ! built_with_use dev-util/subversion python ; then
+# built_with_use_error dev-util/subversion python
+# fi
+#
+# Note: when <USE flag> is not specified, <functionality> is used for the USE flag name.
+built_with_use_error_msg() {
+ local package=$1
+ local func=$2
+ local use_flag=$3
+
+ [[ -z ${use_flag} ]] && use_flag=${func}
+
+ eerror "Your ${package} package has been built without"
+ eerror "${func} support, please enable the '${use_flag}' USE flag and"
+ eerror "re-emerge ${package}."
+ einfo "You can enable this USE flag either globally in /etc/make.conf,"
+ einfo "or just for specific packages in /etc/portage/package.use."
+ die "${package} missing ${func} support"
+}
+
+pkg_setup () {
+ if ! use mysql && ! use postgres && ! use sqlite ; then
+ eerror "You must select at least one database backend, by enabling"
+ eerror "at least one of the 'mysql', 'postgres' or 'sqlite' USE flags."
+ die "no database backend selected"
+ fi
+
+ if ! built_with_use dev-util/subversion python ; then
+ built_with_use_error dev-util/subversion python
+ fi
+
+ if ! built_with_use dev-libs/clearsilver python ; then
+ built_with_use_error dev-libs/clearsilver python
+ fi
+
+ ebegin "Creating tracd group and user"
+ enewgroup tracd
+ enewuser tracd -1 -1 -1 tracd
+ eend ${?}
+
+ webapp_pkg_setup
+}
+
+src_install () {
+ # project environments might go in here
+ keepdir /var/lib/trac
+
+ webapp_src_preinst
+ distutils_src_install
+
+ dodoc AUTHORS INSTALL RELEASE THANKS UPGRADE
+ rm ${D}/usr/share/doc/${P}/MANIFEST.in.gz
+ rm ${D}/usr/share/doc/${P}/PKG-INFO.gz
+
+ docinto contrib
+ dodoc contrib/*
+
+ # if needed, install cgi/fcgi scripts for webapp-config
+ local my_dir=${D}/usr/share/trac
+ if use cgi ; then
+ mv ${my_dir}/cgi-bin/trac.cgi ${D}${MY_CGIBINDIR} || die
+ fi
+ if use fastcgi ; then
+ mv ${my_dir}/cgi-bin/trac.fcgi ${D}${MY_CGIBINDIR} || die
+ fi
+ rm -rf ${my_dir}/cgi-bin || die
+
+ for lang in en; do
+ webapp_postinst_txt ${lang} ${FILESDIR}/postinst-${lang}.txt
+ done
+
+ # copy graphics, css & js
+ cp -r htdocs/* ${D}/${MY_HTDOCSDIR}
+
+ webapp_src_install
+
+ newconfd "${FILESDIR}"/tracd.confd tracd
+ newinitd "${FILESDIR}"/tracd.initd tracd
+}