summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-05-24 21:31:52 +0000
committerPeter Volkov <pva@gentoo.org>2009-05-24 21:31:52 +0000
commit431b06d9d758720ca4e25dd7d91cb6bf0bff8c7c (patch)
tree4fee6a6de0c91c1c6fb3b29563d0f3029ac68534 /www-apps/roundup
parentCompleting package move lxsession-lite to lxsession (diff)
downloadgentoo-2-431b06d9d758720ca4e25dd7d91cb6bf0bff8c7c.tar.gz
gentoo-2-431b06d9d758720ca4e25dd7d91cb6bf0bff8c7c.tar.bz2
gentoo-2-431b06d9d758720ca4e25dd7d91cb6bf0bff8c7c.zip
Version bump. SMTP mail with TLS now working, bug #262749, thank My Th for debuging/fixing/working with upstream. Fixes privilege escalation reported by Alex Legler in bug #262100.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'www-apps/roundup')
-rw-r--r--www-apps/roundup/ChangeLog11
-rw-r--r--www-apps/roundup/roundup-1.4.8.ebuild39
2 files changed, 48 insertions, 2 deletions
diff --git a/www-apps/roundup/ChangeLog b/www-apps/roundup/ChangeLog
index b814ac9a4afc..f7c3abfea29a 100644
--- a/www-apps/roundup/ChangeLog
+++ b/www-apps/roundup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/roundup
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.25 2009/01/26 19:55:38 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/ChangeLog,v 1.26 2009/05/24 21:31:52 pva Exp $
+
+*roundup-1.4.8 (24 May 2009)
+
+ 24 May 2009; Peter Volkov <pva@gentoo.org> +roundup-1.4.8.ebuild:
+ Version bump. SMTP mail with TLS now working, bug #262749, thank My Th for
+ debuging/fixing/working with upstream. Fixes privilege escalation reported
+ by Alex Legler in bug #262100.
*roundup-1.4.6 (26 Jan 2009)
diff --git a/www-apps/roundup/roundup-1.4.8.ebuild b/www-apps/roundup/roundup-1.4.8.ebuild
new file mode 100644
index 000000000000..33198c800c40
--- /dev/null
+++ b/www-apps/roundup/roundup-1.4.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-1.4.8.ebuild,v 1.1 2009/05/24 21:31:52 pva Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+HOMEPAGE="http://roundup.sourceforge.net"
+SRC_URI="http://cheeseshop.python.org/packages/source/r/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="as-is"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3
+ >=sys-libs/db-3.2.9"
+
+src_install() {
+ distutils_src_install
+ dodoc CHANGES.txt doc/*.txt
+ dohtml doc/*.html
+ dobin "${FILESDIR}/roundup" || die
+}
+
+pkg_postnst() {
+ ewarn
+ ewarn "As a non privileged user! (not root)"
+ ewarn "Run 'roundup-admin install' to set up a roundup instance"
+ ewarn "Then edit your config.py file in the tracker home you setup"
+ ewarn "Run 'roundup-admin initialise' to setup the admin pass"
+ ewarn "run /usr/bin/roundup start port host \"your tracker name\" [your \
+tracker home], and all should work!"
+ ewarn "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ ewarn "log is in [tracker home]/roundup.log"
+ ewarn "pid file is in [tracker home]/roundup.pid"
+ ewarn
+ ewarn "See upgrading.txt for upgrading instructions."
+}