summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-08-15 15:36:30 +0000
committerStuart Herbert <stuart@gentoo.org>2004-08-15 15:36:30 +0000
commite5f89581b0920d6d4f4fcf43de1108f24cc72d3d (patch)
tree5958f05e6d1dd498ec4dfc5ebeeb93a7d2117ed8 /www-apps/roundup/roundup-0.7.6.ebuild
parentMoved from net-www/phpwebsite to www-apps/phpwebsite (diff)
downloadgentoo-2-e5f89581b0920d6d4f4fcf43de1108f24cc72d3d.tar.gz
gentoo-2-e5f89581b0920d6d4f4fcf43de1108f24cc72d3d.tar.bz2
gentoo-2-e5f89581b0920d6d4f4fcf43de1108f24cc72d3d.zip
Moved from net-www/roundup to www-apps/roundup.
Diffstat (limited to 'www-apps/roundup/roundup-0.7.6.ebuild')
-rw-r--r--www-apps/roundup/roundup-0.7.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/roundup/roundup-0.7.6.ebuild b/www-apps/roundup/roundup-0.7.6.ebuild
new file mode 100644
index 000000000000..b2ebfad6d915
--- /dev/null
+++ b/www-apps/roundup/roundup-0.7.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/roundup/roundup-0.7.6.ebuild,v 1.1 2004/08/15 15:36:30 stuart Exp $
+
+inherit eutils
+
+DESCRIPTION="Simple-to-use and -install issue-tracking system with command-line, web, and e-mail interfaces."
+SRC_URI="mirror://sourceforge/roundup/${P}.tar.gz"
+HOMEPAGE="http://roundup.sourceforge.net"
+KEYWORDS="x86 sparc ~amd64 ~ppc"
+LICENSE="as-is"
+SLOT="0"
+
+DEPEND=">=dev-lang/python-2.2
+ >=sys-libs/db-3.2.9"
+
+src_compile() {
+ python setup.py build || die
+}
+
+src_install() {
+ python setup.py install --root=${D} --prefix=/usr || die
+ dodoc CHANGES.txt PKG-INFO README.txt doc/*.txt
+ dohtml doc/*.html
+ dobin ${FILESDIR}/roundup
+}
+
+pkg_postinst() {
+ einfo
+ ewarn "As a non privileged user! (not root)"
+ einfo "Run 'roundup-admin install' to set up a roundup instance"
+ einfo "Then edit your config.py file in the tracker home you setup"
+ einfo "Run 'roundup-admin initialise' to setup the admin pass"
+ einfo "run /usr/bin/roundup start port host [your tracker home] and all should work!"
+ einfo "run /usr/bin/roundup stop [your tracker home] to stop the server"
+ einfo "log is in [tracker home]/roundup.log"
+ einfo "pid file is in [tracker home]/roundup.pid"
+ einfo
+ einfo "See upgrading.txt for upgrading instructions."
+}