summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2007-08-09 10:05:05 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2007-08-09 10:05:05 +0000
commit54e39ad81183608ea42915a28cdbcced6553b541 (patch)
tree6758fdaa6429cbfbaab3894e99eb257bd5473a9d /www-apps/phpwiki
parentstable on x86. (diff)
downloadgentoo-2-54e39ad81183608ea42915a28cdbcced6553b541.tar.gz
gentoo-2-54e39ad81183608ea42915a28cdbcced6553b541.tar.bz2
gentoo-2-54e39ad81183608ea42915a28cdbcced6553b541.zip
Added phpwiki-1.3.14 to the tree.
(Portage version: 2.1.2.11)
Diffstat (limited to 'www-apps/phpwiki')
-rw-r--r--www-apps/phpwiki/files/digest-phpwiki-1.3.143
-rw-r--r--www-apps/phpwiki/phpwiki-1.3.14.ebuild42
2 files changed, 45 insertions, 0 deletions
diff --git a/www-apps/phpwiki/files/digest-phpwiki-1.3.14 b/www-apps/phpwiki/files/digest-phpwiki-1.3.14
new file mode 100644
index 000000000000..2fcafe36ccc7
--- /dev/null
+++ b/www-apps/phpwiki/files/digest-phpwiki-1.3.14
@@ -0,0 +1,3 @@
+MD5 daaa2f064adf11a44eb7dc15be32598f phpwiki-1.3.14.tar.bz2 2683347
+RMD160 256978866f6a35150f73a6039ed07cf45b48c3a5 phpwiki-1.3.14.tar.bz2 2683347
+SHA256 0db44e87a5ba95907603f959a5b536714215a2219ee220e6d1b727faa7271e72 phpwiki-1.3.14.tar.bz2 2683347
diff --git a/www-apps/phpwiki/phpwiki-1.3.14.ebuild b/www-apps/phpwiki/phpwiki-1.3.14.ebuild
new file mode 100644
index 000000000000..43462808773f
--- /dev/null
+++ b/www-apps/phpwiki/phpwiki-1.3.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phpwiki/phpwiki-1.3.14.ebuild,v 1.1 2007/08/09 10:05:04 wrobel Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="PhpWiki is a WikiWikiWeb clone in PHP"
+HOMEPAGE="http://phpwiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~sparc ~x86 ~amd64"
+IUSE=""
+
+RDEPEND="virtual/php
+ www-servers/apache"
+
+src_unpack() {
+ require_php_with_use pcre
+
+ unpack ${A}
+ cd ${S}
+ rm -f Makefile LICENSE
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -pPR * ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/{doc,schemas,README,INSTALL,TODO,UPGRADING}
+
+ dodoc README INSTALL TODO UPGRADING doc/* schemas/*
+
+ # Create config file from distribution default, and fix up invalid defaults
+ cd ${D}/${MY_HTDOCSDIR}/config
+ sed "s:;DEBUG = 1:DEBUG = 0:" config-dist.ini > config.ini
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-1.3-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/config/config.ini
+
+ webapp_src_install
+}