summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-08-10 21:01:58 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-08-10 21:01:58 +0000
commit459a7fd17fea998e8b99bc7e50a212a4a401eb0f (patch)
tree456612c0484c56c7fbbd2211917961e11fbbf417 /www-apps/mythweb
parentStable on sparc wrt #188378 (diff)
downloadgentoo-2-459a7fd17fea998e8b99bc7e50a212a4a401eb0f.tar.gz
gentoo-2-459a7fd17fea998e8b99bc7e50a212a4a401eb0f.tar.bz2
gentoo-2-459a7fd17fea998e8b99bc7e50a212a4a401eb0f.zip
new rev bump. fix bug #184143
(Portage version: 2.1.3.3)
Diffstat (limited to 'www-apps/mythweb')
-rw-r--r--www-apps/mythweb/ChangeLog8
-rw-r--r--www-apps/mythweb/files/digest-mythweb-0.21_pre141510
-rw-r--r--www-apps/mythweb/mythweb-0.21_pre14151.ebuild50
3 files changed, 57 insertions, 1 deletions
diff --git a/www-apps/mythweb/ChangeLog b/www-apps/mythweb/ChangeLog
index eacea6e6f4cd..3c5efb10a256 100644
--- a/www-apps/mythweb/ChangeLog
+++ b/www-apps/mythweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mythweb
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.39 2007/08/10 20:00:22 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/ChangeLog,v 1.40 2007/08/10 21:01:57 cardoe Exp $
+
+*mythweb-0.21_pre14151 (10 Aug 2007)
+
+ 10 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
+ +mythweb-0.21_pre14151.ebuild:
+ new rev bump. fix bug #184143
10 Aug 2007; Doug Goldstein <cardoe@gentoo.org>
-mythweb-0.20_p11671.ebuild, mythweb-0.20.1_p14146.ebuild:
diff --git a/www-apps/mythweb/files/digest-mythweb-0.21_pre14151 b/www-apps/mythweb/files/digest-mythweb-0.21_pre14151
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/www-apps/mythweb/files/digest-mythweb-0.21_pre14151
diff --git a/www-apps/mythweb/mythweb-0.21_pre14151.ebuild b/www-apps/mythweb/mythweb-0.21_pre14151.ebuild
new file mode 100644
index 000000000000..18c35f95e257
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.21_pre14151.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.21_pre14151.ebuild,v 1.1 2007/08/10 21:01:57 cardoe Exp $
+
+inherit mythtv webapp depend.php subversion
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/httpd-php
+ dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if has_version 'dev-lang/php' ; then
+ require_php_with_use session mysql pcre posix
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_compile() {
+ echo ""
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc README TODO
+
+ dodir ${MY_HTDOCSDIR}/data
+
+ cp -R ${S}/${PN}/[[:lower:]]* ${D}${MY_HTDOCSDIR}
+ cp ${S}/mythweb.conf.apache ${MY_SERVERCONFIGDIR}/
+
+ webapp_serverowned ${MY_HTDOCSDIR}/data
+
+ webapp_configfile ${MY_SERVERCONFIGDIR}/mythweb.conf.apache
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-0.21.txt
+
+ webapp_src_install
+}