summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-07-27 07:42:02 +0000
committerPeter Volkov <pva@gentoo.org>2011-07-27 07:42:02 +0000
commit48822531bbdf3150f85751f51e84d79128a89bd7 (patch)
tree6219a3c65f9f4eb12c6ca33a385881833628454e /www-apps/mantisbt
parentTie colliding files to tools USE flag - bugs #61116 #374009 (diff)
downloadgentoo-2-48822531bbdf3150f85751f51e84d79128a89bd7.tar.gz
gentoo-2-48822531bbdf3150f85751f51e84d79128a89bd7.tar.bz2
gentoo-2-48822531bbdf3150f85751f51e84d79128a89bd7.zip
Version bump.
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/mantisbt')
-rw-r--r--www-apps/mantisbt/ChangeLog7
-rw-r--r--www-apps/mantisbt/mantisbt-1.2.6.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 58f44d7adfaf..d38898aa6397 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.102 2011/04/06 14:27:12 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.103 2011/07/27 07:42:02 pva Exp $
+
+*mantisbt-1.2.6 (27 Jul 2011)
+
+ 27 Jul 2011; Peter Volkov <pva@gentoo.org> +mantisbt-1.2.6.ebuild:
+ Version bump.
*mantisbt-1.2.5 (06 Apr 2011)
diff --git a/www-apps/mantisbt/mantisbt-1.2.6.ebuild b/www-apps/mantisbt/mantisbt-1.2.6.ebuild
new file mode 100644
index 000000000000..7f8476751080
--- /dev/null
+++ b/www-apps/mantisbt/mantisbt-1.2.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.2.6.ebuild,v 1.1 2011/07/27 07:42:02 pva Exp $
+
+EAPI="2"
+
+inherit eutils webapp depend.php
+
+DESCRIPTION="PHP/MySQL/Web based bugtracking system"
+HOMEPAGE="http://www.mantisbt.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/httpd-php
+ virtual/httpd-cgi
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ >=dev-php5/ezc-Base-1.8
+ >=dev-php5/ezc-Graph-1.5
+ >=dev-php/adodb-5.10"
+
+src_prepare() {
+ # Drop external libraries
+ rm -r "${S}/library/adodb/"
+ rm -r "${S}/library/ezc/"{Base,Graph}
+ sed -e 's:ezc/Base/src/base.php:ezc/Base/base.php:' \
+ -i "${S}"/plugins/MantisGraph/{core/graph_api.php,pages/summary_graph_cumulative_bydate2.php} \
+ || die
+ # Fix incorrect filename
+ sed -e 's:config_default_inc.php:config_defaults_inc.php:' \
+ -i "${S}/lang/strings_russian.txt" || die
+}
+
+src_install() {
+ webapp_src_preinst
+ rm doc/{LICENSE,INSTALL}
+ dodoc doc/{CREDITS,CUSTOMIZATION,RELEASE} doc/en/*
+
+ rm -rf doc packages
+ mv config_inc.php.sample config_inc.php
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+
+ webapp_configfile "${MY_HTDOCSDIR}/config_inc.php"
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt"
+ webapp_src_install
+}