summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-10-15 17:07:47 +0000
committerPeter Volkov <pva@gentoo.org>2008-10-15 17:07:47 +0000
commit3be4ec830464fc467066498db22ed768daf8c794 (patch)
tree82752240018ce9784b261c2227a7eefd018faee7 /www-apps/mantisbt
parentNew ebuild for tabler. Ebuild written by me. Fixes bug #185943. (diff)
downloadgentoo-2-3be4ec830464fc467066498db22ed768daf8c794.tar.gz
gentoo-2-3be4ec830464fc467066498db22ed768daf8c794.tar.bz2
gentoo-2-3be4ec830464fc467066498db22ed768daf8c794.zip
Fixed inability to report issues in mantis, reported in bug #241940 by Marek Królikowski.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-openvz.git-777e816 i686)
Diffstat (limited to 'www-apps/mantisbt')
-rw-r--r--www-apps/mantisbt/ChangeLog10
-rw-r--r--www-apps/mantisbt/files/mantisbt-1.1.3-up-to-r5674.patch54
-rw-r--r--www-apps/mantisbt/mantisbt-1.1.3-r1.ebuild (renamed from www-apps/mantisbt/mantisbt-1.1.3.ebuild)3
3 files changed, 65 insertions, 2 deletions
diff --git a/www-apps/mantisbt/ChangeLog b/www-apps/mantisbt/ChangeLog
index 5bafc197d173..1759fa9aa64d 100644
--- a/www-apps/mantisbt/ChangeLog
+++ b/www-apps/mantisbt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-apps/mantisbt
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.65 2008/10/14 11:55:08 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/ChangeLog,v 1.66 2008/10/15 17:07:41 pva Exp $
+
+*mantisbt-1.1.3-r1 (15 Oct 2008)
+
+ 15 Oct 2008; Peter Volkov <pva@gentoo.org>
+ +files/mantisbt-1.1.3-up-to-r5674.patch, -mantisbt-1.1.3.ebuild,
+ +mantisbt-1.1.3-r1.ebuild:
+ Fixed inability to report issues in mantis, reported in bug #241940 by
+ Marek Królikowski.
*mantisbt-1.1.3 (14 Oct 2008)
diff --git a/www-apps/mantisbt/files/mantisbt-1.1.3-up-to-r5674.patch b/www-apps/mantisbt/files/mantisbt-1.1.3-up-to-r5674.patch
new file mode 100644
index 000000000000..8323bfbc65c3
--- /dev/null
+++ b/www-apps/mantisbt/files/mantisbt-1.1.3-up-to-r5674.patch
@@ -0,0 +1,54 @@
+Index: bug_report_page.php
+===================================================================
+--- bug_report_page.php (revision 5664)
++++ bug_report_page.php (revision 5674)
+@@ -112,6 +112,7 @@
+ <br />
+ <div align="center">
+ <form name="report_bug_form" method="post" <?php if ( file_allow_bug_upload() ) { echo 'enctype="multipart/form-data"'; } ?> action="bug_report.php">
++<?php echo form_security_field( 'bug_report' ) ?>
+ <table class="width75" cellspacing="1">
+
+
+Index: bug_report_advanced_page.php
+===================================================================
+--- bug_report_advanced_page.php (revision 5664)
++++ bug_report_advanced_page.php (revision 5674)
+@@ -131,6 +131,7 @@
+ <br />
+ <div align="center">
+ <form name="report_bug_form" method="post" <?php if ( file_allow_bug_upload() ) { echo 'enctype="multipart/form-data"'; } ?> action="bug_report.php">
++<?php echo form_security_field( 'bug_report' ) ?>
+ <table class="width75" cellspacing="1">
+
+
+Index: config_defaults_inc.php
+===================================================================
+--- config_defaults_inc.php (revision 5664)
++++ config_defaults_inc.php (revision 5674)
+@@ -85,7 +85,8 @@
+ }
+
+ if ( isset( $_SERVER['HTTP_X_FORWARDED_HOST'] ) ) { // Support ProxyPass
+- $t_host = $_SERVER['HTTP_X_FORWARDED_HOST'];
++ $t_hosts = split( ',', $_SERVER['HTTP_X_FORWARDED_HOST'] );
++ $t_host = $t_hosts[0];
+ } else if ( isset( $_SERVER['HTTP_HOST'] ) ) {
+ $t_host = $_SERVER['HTTP_HOST'];
+ } else if ( isset( $_SERVER['SERVER_NAME'] ) ) {
+Index: core/session_api.php
+===================================================================
+--- core/session_api.php (revision 5664)
++++ core/session_api.php (revision 5674)
+@@ -56,9 +56,9 @@
+
+ session_cache_limiter( 'private_no_expire' );
+ if ( isset( $_SERVER['HTTPS'] ) && ( strtolower( $_SERVER['HTTPS'] ) != 'off' ) ) {
+- session_set_cookie_params( 0, config_get( 'cookie_path' ), config_get( 'cookie_domain' ), true, true );
++ session_set_cookie_params( 0, config_get( 'cookie_path' ), config_get( 'cookie_domain' ), true );
+ } else {
+- session_set_cookie_params( 0, config_get( 'cookie_path' ), config_get( 'cookie_domain' ), false, true );
++ session_set_cookie_params( 0, config_get( 'cookie_path' ), config_get( 'cookie_domain' ), false );
+ }
+ session_start();
+ $this->id = session_id();
diff --git a/www-apps/mantisbt/mantisbt-1.1.3.ebuild b/www-apps/mantisbt/mantisbt-1.1.3-r1.ebuild
index 58a264af308f..37db2cb2ad55 100644
--- a/www-apps/mantisbt/mantisbt-1.1.3.ebuild
+++ b/www-apps/mantisbt/mantisbt-1.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.3.ebuild,v 1.1 2008/10/14 11:55:08 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.1.3-r1.ebuild,v 1.1 2008/10/15 17:07:41 pva Exp $
inherit eutils webapp depend.php
@@ -30,6 +30,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-up-to-r5674.patch"
rm -r "${S}"/core/adodb/ # We use external adodb
}