summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-04-29 22:19:32 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-04-29 22:19:32 +0000
commit0c699c966b750dc2dea004f54f437ac28c15ecab (patch)
treee19b764f03d0b74302c9894b1313bcce3132099d /www-apps/mambo
parentRemoved pkg_config per bug #129558. (diff)
downloadgentoo-2-0c699c966b750dc2dea004f54f437ac28c15ecab.tar.gz
gentoo-2-0c699c966b750dc2dea004f54f437ac28c15ecab.tar.bz2
gentoo-2-0c699c966b750dc2dea004f54f437ac28c15ecab.zip
Version bump; removed pkg_config per bug #129558.
(Portage version: 2.1_pre9-r5)
Diffstat (limited to 'www-apps/mambo')
-rw-r--r--www-apps/mambo/ChangeLog8
-rw-r--r--www-apps/mambo/files/digest-mambo-4.5.3h_p16
-rw-r--r--www-apps/mambo/mambo-4.5.3h_p1.ebuild47
3 files changed, 60 insertions, 1 deletions
diff --git a/www-apps/mambo/ChangeLog b/www-apps/mambo/ChangeLog
index 00159dbb4315..9a85186f693d 100644
--- a/www-apps/mambo/ChangeLog
+++ b/www-apps/mambo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/mambo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.21 2006/01/03 15:47:01 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/ChangeLog,v 1.22 2006/04/29 22:19:32 rl03 Exp $
+
+*mambo-4.5.3h_p1 (29 Apr 2006)
+
+ 29 Apr 2006; Renat Lumpau <rl03@gentoo.org> -mambo-4.5.3h.ebuild,
+ +mambo-4.5.3h_p1.ebuild:
+ Version bump; removed pkg_config per bug #129558.
*mambo-4.5.3h (03 Jan 2006)
diff --git a/www-apps/mambo/files/digest-mambo-4.5.3h_p1 b/www-apps/mambo/files/digest-mambo-4.5.3h_p1
new file mode 100644
index 000000000000..8696275ce1ea
--- /dev/null
+++ b/www-apps/mambo/files/digest-mambo-4.5.3h_p1
@@ -0,0 +1,6 @@
+MD5 44979a7e09e941b396d6b89974f6d878 MamboV4.5.3h_SecurityPatch1.tar.gz 38966
+RMD160 7cc3026e0a71892835ea811f1d4bbb7593eba188 MamboV4.5.3h_SecurityPatch1.tar.gz 38966
+SHA256 0605ba291b1147076b6afca007aac1ef8d945ab785c3ef001b2e4d13c2a7e0b1 MamboV4.5.3h_SecurityPatch1.tar.gz 38966
+MD5 69c27a55792741fd1307f0e5941480db mambov4.5.3h.tar.gz 3896181
+RMD160 822c0a55be9e578a2da82e7c07ef061143bd0895 mambov4.5.3h.tar.gz 3896181
+SHA256 409dec2e5ced11bef69226b2e1820713ec1f5abfd4a4ea6ea46e5befaef25a1f mambov4.5.3h.tar.gz 3896181
diff --git a/www-apps/mambo/mambo-4.5.3h_p1.ebuild b/www-apps/mambo/mambo-4.5.3h_p1.ebuild
new file mode 100644
index 000000000000..337c123f7ab4
--- /dev/null
+++ b/www-apps/mambo/mambo-4.5.3h_p1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mambo/mambo-4.5.3h_p1.ebuild,v 1.1 2006/04/29 22:19:32 rl03 Exp $
+
+inherit webapp depend.php
+
+MY_PV="4.5.3h"
+MY_PN="${PN/m/M}"
+DESCRIPTION="Mambo is yet another CMS"
+HOMEPAGE="http://www.mamboserver.com/"
+SRC_URI="http://mamboxchange.com/frs/download.php/7368/${PN}v${MY_PV}.tar.gz
+http://mamboxchange.com/frs/download.php/7370/${MY_PN}V${MY_PV}_SecurityPatch1.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+S=${WORKDIR}
+
+IUSE="mysql"
+
+RDEPEND="mysql? ( dev-db/mysql )
+ virtual/httpd-php
+ net-www/apache"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib
+}
+
+src_install () {
+ webapp_src_preinst
+ local files="administrator/backups administrator/components components
+ images images/banners images/stories mambots mambots/content mambots/search
+ media language administrator/modules administrator/templates cache modules
+ templates"
+
+ dodoc CHANGELOG.php INSTALL.php README
+
+ cp -R [^d]* ${D}/${MY_HTDOCSDIR}
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}/${file}"
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}