summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2007-03-17 21:25:25 +0000
committerRenat Lumpau <rl03@gentoo.org>2007-03-17 21:25:25 +0000
commit7703e01056600b13b88cc65ee267d959b6e10943 (patch)
tree9abcbc8d651ab64c31bfe42ef827603f3034eafa /www-apps/gallery
parentarm/ia64/s390/sh stable (diff)
downloadgentoo-2-7703e01056600b13b88cc65ee267d959b6e10943.tar.gz
gentoo-2-7703e01056600b13b88cc65ee267d959b6e10943.tar.bz2
gentoo-2-7703e01056600b13b88cc65ee267d959b6e10943.zip
Version bump
(Portage version: 2.1.2-r10)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog7
-rw-r--r--www-apps/gallery/files/digest-gallery-2.23
-rw-r--r--www-apps/gallery/gallery-2.2.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index d99f5e2bb417..f045ca7e3e6f 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gallery
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.109 2007/01/02 22:26:29 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.110 2007/03/17 21:25:25 rl03 Exp $
+
+*gallery-2.2 (17 Mar 2007)
+
+ 17 Mar 2007; Renat Lumpau <rl03@gentoo.org> +gallery-2.2.ebuild:
+ Version bump
02 Jan 2007; Renat Lumpau <rl03@gentoo.org> gallery-2.1.2.ebuild:
Remove db deps wrt bug #159781
diff --git a/www-apps/gallery/files/digest-gallery-2.2 b/www-apps/gallery/files/digest-gallery-2.2
new file mode 100644
index 000000000000..9d6d7abae427
--- /dev/null
+++ b/www-apps/gallery/files/digest-gallery-2.2
@@ -0,0 +1,3 @@
+MD5 68742ba80acb25710702ea5e52251dfe gallery-2.2-full.tar.gz 11850649
+RMD160 fc4fab48639df67e08fe11e3fe36cf59821a40cd gallery-2.2-full.tar.gz 11850649
+SHA256 8a71000dad587a2d8fc0afa6edb11ee3c1860a2854c9db2b4859c13882ccc7c0 gallery-2.2-full.tar.gz 11850649
diff --git a/www-apps/gallery/gallery-2.2.ebuild b/www-apps/gallery/gallery-2.2.ebuild
new file mode 100644
index 000000000000..c5acfae66cbd
--- /dev/null
+++ b/www-apps/gallery/gallery-2.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.2.ebuild,v 1.1 2007/03/17 21:25:25 rl03 Exp $
+
+inherit webapp eutils depend.php
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dcraw ffmpeg gd imagemagick mysql netpbm postgres unzip zip"
+
+RDEPEND="
+ media-libs/jpeg
+ dcraw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ gd? ( >=media-libs/gd-2 )
+ imagemagick? ( >=media-gfx/imagemagick-5.4.9.1-r1 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )
+"
+
+S=${WORKDIR}/${PN}2
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ local php_flags="session"
+ local DIE=
+
+ use mysql && php_flags="${php_flags} mysql"
+ use postgres && php_flags="${php_flags} postgres"
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${php_flags}; then
+ DIE="yes"
+ fi
+ if use gd; then
+ if ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ DIE="yes"
+ fi
+ fi
+
+ if [[ ${DIE} == "yes" ]]; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "${php_flags}"
+ eerror
+ if use gd; then
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "gd gd-external"
+ eerror
+ fi
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp -R * ${D}/${MY_HTDOCSDIR}
+ dohtml README.html
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en2.txt
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}