summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-07-03 13:56:58 +0000
committerMatti Bickel <mabi@gentoo.org>2010-07-03 13:56:58 +0000
commit077df39071570754af199257c06b29e58723d2f8 (patch)
tree0eeac2be05846f2c864fd2074ed56f8e89aeead7 /www-apps/gallery
parentupdate RDEPEND for php-5.3 (bug #298205) (diff)
downloadgentoo-2-077df39071570754af199257c06b29e58723d2f8.tar.gz
gentoo-2-077df39071570754af199257c06b29e58723d2f8.tar.bz2
gentoo-2-077df39071570754af199257c06b29e58723d2f8.zip
eapi bump for php-5.3 (bug #298205)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'www-apps/gallery')
-rw-r--r--www-apps/gallery/ChangeLog9
-rw-r--r--www-apps/gallery/gallery-2.3-r2.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/www-apps/gallery/ChangeLog b/www-apps/gallery/ChangeLog
index 27081c8f7a4a..35c131da35c1 100644
--- a/www-apps/gallery/ChangeLog
+++ b/www-apps/gallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apps/gallery
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.174 2009/01/27 12:01:41 pva Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/ChangeLog,v 1.175 2010/07/03 13:56:58 mabi Exp $
+
+*gallery-2.3-r2 (03 Jul 2010)
+
+ 03 Jul 2010; Matti Bickel <mabi@gentoo.org> +gallery-2.3-r2.ebuild:
+ eapi bump for php-5.3 (bug #298205)
*gallery-2.3-r1 (27 Jan 2009)
diff --git a/www-apps/gallery/gallery-2.3-r2.ebuild b/www-apps/gallery/gallery-2.3-r2.ebuild
new file mode 100644
index 000000000000..35df753dcba9
--- /dev/null
+++ b/www-apps/gallery/gallery-2.3-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.3-r2.ebuild,v 1.1 2010/07/03 13:56:58 mabi Exp $
+
+EAPI="2"
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://gallery.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ffmpeg gd imagemagick mysql netpbm postgres raw sqlite unzip zip"
+
+RDEPEND="raw? ( >=media-gfx/dcraw-8.03 )
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051216 )
+ imagemagick? ( >media-gfx/imagemagick-6.2.4 )
+ netpbm? ( >=media-libs/netpbm-9.12 >=media-gfx/jhead-2.2 )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )
+ sqlite? ( dev-lang/php[pdo] )
+ gd? ( || ( dev-lang/php[gd] dev-lang/php[gd-external] ) )
+ dev-lang/php[mysql=,session,postgres=]
+ || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )"
+
+S=${WORKDIR}/${PN}2
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres sqlite
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE
+ sed -i -e "/^LICENSE\>/d" -e "/^README\.html\>/d" MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en2.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading to 2.2 will make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}