summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2006-09-14 13:25:40 +0000
committerLance Albertson <ramereth@gentoo.org>2006-09-14 13:25:40 +0000
commitcffd60dd176e50f0a468b119b9471fcbf2992d52 (patch)
tree61f8a06154eeb5b7ea1e82a2b929db0890cf7461 /www-apps/dokuwiki
parentStable on ppc64; bug #144091 (diff)
downloadgentoo-2-cffd60dd176e50f0a468b119b9471fcbf2992d52.tar.gz
gentoo-2-cffd60dd176e50f0a468b119b9471fcbf2992d52.tar.bz2
gentoo-2-cffd60dd176e50f0a468b119b9471fcbf2992d52.zip
version bump, moved scripts in bin dir to safer location to resolve bug #146800
(Portage version: 2.1-r2)
Diffstat (limited to 'www-apps/dokuwiki')
-rw-r--r--www-apps/dokuwiki/ChangeLog9
-rw-r--r--www-apps/dokuwiki/dokuwiki-20060309d.ebuild73
-rw-r--r--www-apps/dokuwiki/files/digest-dokuwiki-20060309d3
3 files changed, 84 insertions, 1 deletions
diff --git a/www-apps/dokuwiki/ChangeLog b/www-apps/dokuwiki/ChangeLog
index b27f6acf1cc0..acdb1c009785 100644
--- a/www-apps/dokuwiki/ChangeLog
+++ b/www-apps/dokuwiki/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apps/dokuwiki
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.12 2006/09/12 09:18:44 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/ChangeLog,v 1.13 2006/09/14 13:25:40 ramereth Exp $
+
+*dokuwiki-20060309d (14 Sep 2006)
+
+ 14 Sep 2006; Lance Albertson <ramereth@gentoo.org>
+ +dokuwiki-20060309d.ebuild:
+ * Version bump
+ * Moved bin/ directory to /usr/share doc area to fix security bug #146800
12 Sep 2006; <ticho@gentoo.org> dokuwiki-20060309c.ebuild:
Stable on x86, security bug 146800.
diff --git a/www-apps/dokuwiki/dokuwiki-20060309d.ebuild b/www-apps/dokuwiki/dokuwiki-20060309d.ebuild
new file mode 100644
index 000000000000..e48c46d90038
--- /dev/null
+++ b/www-apps/dokuwiki/dokuwiki-20060309d.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dokuwiki/dokuwiki-20060309d.ebuild,v 1.1 2006/09/14 13:25:40 ramereth Exp $
+
+inherit webapp
+
+# Upstream uses dashes in the datestamp
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small companies
+documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://www.splitbrain.org/_media/projects/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/php"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${PN}-${MY_PV}.tgz
+ mv ${PN}-${MY_PV} ${P}
+}
+
+src_compile() {
+ # Default compile hangs
+ echo "Nothing to compile"
+}
+
+src_install() {
+ local docs="README"
+ webapp_src_preinst
+
+ # NOTE: doc files should go into /usr/share/doc, and NOT installed in the vhost
+ einfo "Installing docs"
+ dodoc ${docs}
+ for doc in ${docs} COPYING; do
+ rm -f ${doc}
+ done
+
+ # Move bin directory to safe location (outside of docroot)
+ # To resolve security bug #146800
+ docinto scripts
+ dodoc bin/*
+ rm -rf bin
+
+ einfo "Copying main files"
+ cp -r . ${D}/${MY_HTDOCSDIR}
+
+ # Install the htaccess file for pretty urls
+ cp .htaccess ${D}/${MY_HTDOCSDIR}
+
+ # Create initial changes file
+ touch ${D}/${MY_HTDOCSDIR}/data/changes.log data/changes.log
+
+ # The data dir needs to be owned by the server
+ for x in `find . -print | grep "data/*" | grep -v .htaccess` ; do
+ webapp_serverowned ${MY_HTDOCSDIR}/$x
+ done
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_configfile ${MY_HTDOCSDIR}/.htaccess
+
+ webapp_configfile ${MY_HTDOCSDIR}/conf
+ for x in $( cd ${D}/${MY_HTDOCSDIR}/conf && echo * ) ; do
+ webapp_configfile ${MY_HTDOCSDIR}/conf/$x
+ done
+
+ webapp_src_install
+}
diff --git a/www-apps/dokuwiki/files/digest-dokuwiki-20060309d b/www-apps/dokuwiki/files/digest-dokuwiki-20060309d
new file mode 100644
index 000000000000..f00beada98a5
--- /dev/null
+++ b/www-apps/dokuwiki/files/digest-dokuwiki-20060309d
@@ -0,0 +1,3 @@
+MD5 e061b6f02943e9b0e47866c6d14a1df2 dokuwiki-2006-03-09d.tgz 835964
+RMD160 13769beb4a62fea3dbed33c00d1e1bfc77b44ea9 dokuwiki-2006-03-09d.tgz 835964
+SHA256 9693382dcf7922d83658fd6fe8c690b5ae785422bcac84ae5cb88fb0903b9b4d dokuwiki-2006-03-09d.tgz 835964