summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-30 06:24:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-30 06:24:39 +0000
commitd4363ee4aa3e7779635d49528c8943a82d6c2172 (patch)
tree07970cfaeee285f637cfb6492f12fa3e6f4ff1c4 /www-apache
parentFixing init script for #382947 (diff)
downloadgentoo-2-d4363ee4aa3e7779635d49528c8943a82d6c2172.tar.gz
gentoo-2-d4363ee4aa3e7779635d49528c8943a82d6c2172.tar.bz2
gentoo-2-d4363ee4aa3e7779635d49528c8943a82d6c2172.zip
Bump for #400895
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_auth_openid/ChangeLog9
-rw-r--r--www-apache/mod_auth_openid/mod_auth_openid-0.6.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/www-apache/mod_auth_openid/ChangeLog b/www-apache/mod_auth_openid/ChangeLog
index 912345d6168e..dd50362704e3 100644
--- a/www-apache/mod_auth_openid/ChangeLog
+++ b/www-apache/mod_auth_openid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/mod_auth_openid
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.3 2009/09/17 08:20:05 hollow Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/ChangeLog,v 1.4 2012/03/30 06:24:39 patrick Exp $
+
+*mod_auth_openid-0.6 (30 Mar 2012)
+
+ 30 Mar 2012; Patrick Lauer <patrick@gentoo.org> +mod_auth_openid-0.6.ebuild:
+ Bump for #400895
*mod_auth_openid-0.4 (17 Sep 2009)
diff --git a/www-apache/mod_auth_openid/mod_auth_openid-0.6.ebuild b/www-apache/mod_auth_openid/mod_auth_openid-0.6.ebuild
new file mode 100644
index 000000000000..26263556e5a0
--- /dev/null
+++ b/www-apache/mod_auth_openid/mod_auth_openid-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_openid/mod_auth_openid-0.6.ebuild,v 1.1 2012/03/30 06:24:39 patrick Exp $
+
+EAPI="4"
+
+inherit apache-module
+
+DESCRIPTION="An OpenID authentication module for the apache webserver"
+HOMEPAGE="http://trac.butterfat.net/public/mod_auth_openid"
+SRC_URI="http://butterfat.net/releases/mod_auth_openid/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-db/sqlite-3
+ dev-libs/libpcre
+ >=net-libs/libopkele-2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTH_OPENID"
+
+need_apache2
+
+src_configure() {
+ econf --with-apxs="${APXS}" \
+ --with-sqlite3=/usr \
+ --with-apr-config=/usr/bin/apr-1-config
+}
+
+src_compile() {
+ # default src_compile fails
+ emake
+}