summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-06-19 06:17:27 +0000
committerHans de Graaff <graaff@gentoo.org>2009-06-19 06:17:27 +0000
commita071c8416a7322968c8c67290194fd4a8bff1230 (patch)
tree75bc77d06d1bfbf72ac6e4b348d1396efb949e26 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-a071c8416a7322968c8c67290194fd4a8bff1230.tar.gz
gentoo-2-a071c8416a7322968c8c67290194fd4a8bff1230.tar.bz2
gentoo-2-a071c8416a7322968c8c67290194fd4a8bff1230.zip
Remove old versions.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/passenger/ChangeLog7
-rw-r--r--www-apache/passenger/passenger-1.0.5.ebuild67
-rw-r--r--www-apache/passenger/passenger-2.0.1.ebuild52
-rw-r--r--www-apache/passenger/passenger-2.0.3.ebuild59
-rw-r--r--www-apache/passenger/passenger-2.0.6.ebuild59
-rw-r--r--www-apache/passenger/passenger-2.1.2.ebuild59
6 files changed, 6 insertions, 297 deletions
diff --git a/www-apache/passenger/ChangeLog b/www-apache/passenger/ChangeLog
index f5021a3343a7..d65664333177 100644
--- a/www-apache/passenger/ChangeLog
+++ b/www-apache/passenger/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-apache/passenger
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.9 2009/05/19 21:23:27 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/ChangeLog,v 1.10 2009/06/19 06:17:27 graaff Exp $
+
+ 19 Jun 2009; Hans de Graaff <graaff@gentoo.org> -passenger-1.0.5.ebuild,
+ -passenger-2.0.1.ebuild, -passenger-2.0.3.ebuild, -passenger-2.0.6.ebuild,
+ -passenger-2.1.2.ebuild:
+ Remove old versions.
19 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
passenger-2.2.2.ebuild:
diff --git a/www-apache/passenger/passenger-1.0.5.ebuild b/www-apache/passenger/passenger-1.0.5.ebuild
deleted file mode 100644
index 75911f13ff72..000000000000
--- a/www-apache/passenger/passenger-1.0.5.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-1.0.5.ebuild,v 1.2 2008/06/01 11:06:22 hollow Exp $
-
-inherit apache-module flag-o-matic ruby
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND=">=dev-lang/ruby-1.8.5
- >=dev-ruby/rubygems-0.9.0
- >=dev-ruby/rake-0.8.1
- >=dev-ruby/fastthread-1.0.1
- >=dev-ruby/rspec-1.1.2
- >=dev-ruby/rails-1.2.0"
-RDEPEND="${DEPEND}"
-
-APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
-APACHE2_MOD_CONF="30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PV}-gentoo.patch
-
- # set version here to prevent Rakefile parsing
- sed -i -e "s/\(PASSENGER_VERSION\) = .*/\1 = '${PV}'/" \
- lib/passenger/request_handler.rb
-}
-
-src_compile() {
- cd "${S}"/ext/passenger
- ruby_src_compile
-
- cd "${S}"
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- rake apache2 || die "rake apache2 failed"
-}
-
-src_install() {
- ( # dont want to pollute calling env
- insinto $(${RUBY} -r rbconfig -e 'print Config::CONFIG["sitedir"]')
- doins -r lib/passenger
- ) || die "failed to install passenger lib"
-
- dobin bin/passenger-spawn-server
-
- cd "${S}"/ext/passenger
- ruby_einstall
-
- apache-module_src_install
-}
diff --git a/www-apache/passenger/passenger-2.0.1.ebuild b/www-apache/passenger/passenger-2.0.1.ebuild
deleted file mode 100644
index 1916a307b85b..000000000000
--- a/www-apache/passenger/passenger-2.0.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-2.0.1.ebuild,v 1.1 2008/07/01 19:36:16 hollow Exp $
-
-inherit apache-module flag-o-matic ruby
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-DEPEND=">=dev-lang/ruby-1.8.5
- >=dev-ruby/rubygems-0.9.0
- >=dev-ruby/rake-0.8.1
- >=dev-ruby/fastthread-1.0.1
- >=dev-ruby/rspec-1.1.2
- >=dev-ruby/rails-1.2.0"
-RDEPEND="${DEPEND}"
-
-APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PV}-gentoo.patch
- rm -f bin/passenger-install-apache2-module
-}
-
-src_compile() {
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- rake apache2 native_support doc || die "rake failed"
-}
-
-src_install() {
- DISTDIR="${D}" \
- rake fakeroot || die "rake failed"
-
- apache-module_src_install
-}
diff --git a/www-apache/passenger/passenger-2.0.3.ebuild b/www-apache/passenger/passenger-2.0.3.ebuild
deleted file mode 100644
index 44c967d5775e..000000000000
--- a/www-apache/passenger/passenger-2.0.3.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-2.0.3.ebuild,v 1.1 2008/08/29 12:47:44 hollow Exp $
-
-inherit apache-module flag-o-matic ruby
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-CDEPEND=">=dev-lang/ruby-1.8.5
- >=dev-ruby/rubygems-0.9.0
- >=dev-ruby/rake-0.8.1
- >=dev-ruby/fastthread-1.0.1
- >=dev-ruby/rspec-1.1.2
- >=dev-ruby/rails-1.2.0"
-DEPEND="${CDEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${CDEPEND}"
-
-APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/2.0.1-gentoo.patch
- rm -f bin/passenger-install-apache2-module
- sed -i -e '473s/, :doc//' Rakefile
-}
-
-src_compile() {
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- rake apache2 native_support || die "rake failed"
-
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-src_install() {
- DISTDIR="${D}" \
- rake fakeroot || die "rake failed"
-
- apache-module_src_install
-}
diff --git a/www-apache/passenger/passenger-2.0.6.ebuild b/www-apache/passenger/passenger-2.0.6.ebuild
deleted file mode 100644
index 3e5a2b6a2cec..000000000000
--- a/www-apache/passenger/passenger-2.0.6.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-2.0.6.ebuild,v 1.1 2008/12/27 21:39:21 caleb Exp $
-
-inherit apache-module flag-o-matic ruby
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-CDEPEND=">=dev-lang/ruby-1.8.5
- >=dev-ruby/rubygems-0.9.0
- >=dev-ruby/rake-0.8.1
- >=dev-ruby/fastthread-1.0.1
- >=dev-ruby/rspec-1.1.2
- >=dev-ruby/rails-1.2.0"
-DEPEND="${CDEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${CDEPEND}"
-
-APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/2.0.1-gentoo.patch
- rm -f bin/passenger-install-apache2-module
- sed -i -e '473s/, :doc//' Rakefile
-}
-
-src_compile() {
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- rake apache2 native_support || die "rake failed"
-
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-src_install() {
- DISTDIR="${D}" \
- rake fakeroot || die "rake failed"
-
- apache-module_src_install
-}
diff --git a/www-apache/passenger/passenger-2.1.2.ebuild b/www-apache/passenger/passenger-2.1.2.ebuild
deleted file mode 100644
index 86be0398a339..000000000000
--- a/www-apache/passenger/passenger-2.1.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/passenger/passenger-2.1.2.ebuild,v 1.1 2009/03/15 14:36:08 a3li Exp $
-
-inherit apache-module flag-o-matic ruby
-
-DESCRIPTION="Passenger (a.k.a. mod_rails) makes deployment of Ruby on Rails applications a breeze"
-HOMEPAGE="http://modrails.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-CDEPEND=">=dev-lang/ruby-1.8.5
- >=dev-ruby/rubygems-0.9.0
- >=dev-ruby/rake-0.8.1
- >=dev-ruby/fastthread-1.0.1
- >=dev-ruby/rspec-1.1.2
- >=dev-ruby/rails-1.2.0"
-DEPEND="${CDEPEND}
- doc? ( app-doc/doxygen )"
-RDEPEND="${CDEPEND}"
-
-APACHE2_MOD_FILE="${S}/ext/apache2/mod_${PN}.so"
-APACHE2_MOD_CONF="30_mod_${PN}-2.0.1 30_mod_${PN}"
-APACHE2_MOD_DEFINE="PASSENGER"
-
-need_apache2_2
-
-pkg_setup() {
- use debug && append-flags -DPASSENGER_DEBUG
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/2.1.2-gentoo.patch
- rm -f bin/passenger-install-apache2-module
- sed -i -e '473s/, :doc//' Rakefile
-}
-
-src_compile() {
- APXS2="${APXS}" \
- HTTPD="${APACHE_BIN}" \
- rake apache2 native_support || die "rake failed"
-
- if use doc; then
- rake doc || die "rake doc failed"
- fi
-}
-
-src_install() {
- DISTDIR="${D}" \
- rake fakeroot || die "rake failed"
-
- apache-module_src_install
-}