summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-23 23:26:32 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-03-23 23:26:32 +0000
commit87eac31ff8263d8d20fbe16bfb072f7cacbc2c59 (patch)
treef37b1b51d2f2b23509611b35ab0aba75eb0d6178 /www-apache
parentVersion bump. (diff)
downloadgentoo-2-87eac31ff8263d8d20fbe16bfb072f7cacbc2c59.tar.gz
gentoo-2-87eac31ff8263d8d20fbe16bfb072f7cacbc2c59.tar.bz2
gentoo-2-87eac31ff8263d8d20fbe16bfb072f7cacbc2c59.zip
Version bump and use the new layout for rules.
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/modsecurity-crs/ChangeLog8
-rw-r--r--www-apache/modsecurity-crs/modsecurity-crs-2.1.2.ebuild79
2 files changed, 86 insertions, 1 deletions
diff --git a/www-apache/modsecurity-crs/ChangeLog b/www-apache/modsecurity-crs/ChangeLog
index 26a04e9f2caa..d0724d70dbc1 100644
--- a/www-apache/modsecurity-crs/ChangeLog
+++ b/www-apache/modsecurity-crs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/modsecurity-crs
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/modsecurity-crs/ChangeLog,v 1.7 2011/02/26 14:44:55 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/modsecurity-crs/ChangeLog,v 1.8 2011/03/23 23:26:32 flameeyes Exp $
+
+*modsecurity-crs-2.1.2 (23 Mar 2011)
+
+ 23 Mar 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +modsecurity-crs-2.1.2.ebuild:
+ Version bump and use the new layout for rules.
26 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
modsecurity-crs-2.1.1.ebuild:
diff --git a/www-apache/modsecurity-crs/modsecurity-crs-2.1.2.ebuild b/www-apache/modsecurity-crs/modsecurity-crs-2.1.2.ebuild
new file mode 100644
index 000000000000..926c9eaf7d35
--- /dev/null
+++ b/www-apache/modsecurity-crs/modsecurity-crs-2.1.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/modsecurity-crs/modsecurity-crs-2.1.2.ebuild,v 1.1 2011/03/23 23:26:32 flameeyes Exp $
+
+EAPI=2
+
+DESCRIPTION="Core Rule Set for ModSecurity"
+HOMEPAGE="http://www.owasp.org/index.php/Category:OWASP_ModSecurity_Core_Rule_Set_Project"
+SRC_URI="mirror://sourceforge/mod-security/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=www-apache/mod_security-2.5.13-r1"
+DEPEND=""
+
+S="${WORKDIR}/${PN}_${PV}"
+
+RULESDIR=/etc/modsecurity
+
+src_install() {
+ insinto "${RULESDIR}"/base_rules || die
+ doins base_rules/* || die
+
+ insinto "${RULESDIR}"/optional_rules
+ doins optional_rules/* || die
+
+ insinto "${RULESDIR}"/experimental_rules
+ doins experimental_rules/* || die
+
+ dodoc CHANGELOG README || die
+
+ (
+ cat - <<EOF
+<IfDefine SECURITY>
+EOF
+
+ cat modsecurity_crs_10_config.conf.example
+
+ cat - <<EOF
+
+
+Include /etc/modsecurity/base_rules/*.conf
+
+# Optionally use the other rules as well
+# Include /etc/modsecurity/optional_rules/*.conf
+# Include /etc/modsecurity/experimental_rules/*.conf
+</IfDefine>
+
+# -*- apache -*-
+# vim: ts=4 filetype=apache
+
+EOF
+ ) > "${T}"/"80_${PN}.conf"
+
+ insinto /etc/apache2/modules.d/
+ doins "${T}"/"80_${PN}.conf" || die
+}
+
+pkg_postinst() {
+ elog
+ elog "If you want to enable further rules, check the following directories:"
+ elog " ${RULESDIR}/optional_rules"
+ elog " ${RULESDIR}/experimental_rules"
+ elog ""
+ elog "Starting from version 2.0.9, the default for the Core Rule Set is again to block"
+ elog "when rules hit. If you wish to go back to the 2.0.8 method of anomaly scoring, you"
+ elog "should change 80_${PN}.conf so that you have these settings enabled:"
+ elog ""
+ elog " #SecDefaultAction \"phase:2,deny,log\""
+ elog " SecAction \"phase:1,t:none,nolog,pass,setvar:tx.anomaly_score_blocking=on\""
+ elog ""
+ elog "Starting from version 2.1.2 rules are installed, for consistency, under"
+ elog "/etc/modsecurity, and can be configured with the following file:"
+ elog " /etc/apache2/modules.d/80_${PN}.conf"
+ elog ""
+}