summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-05-30 15:21:10 +0000
committerUlrich Müller <ulm@gentoo.org>2013-05-30 15:21:10 +0000
commit935b74e6f75a0323e08a0a707c5db0e3f56db953 (patch)
treec3fd95470201382dbf81662b57be11c46cecdcec /www-apache/mod_watch/files
parentAdd a missing PYTHON_REQUIRED_USE for the conversion to python-r1 eclass. (diff)
downloadgentoo-2-935b74e6f75a0323e08a0a707c5db0e3f56db953.tar.gz
gentoo-2-935b74e6f75a0323e08a0a707c5db0e3f56db953.tar.bz2
gentoo-2-935b74e6f75a0323e08a0a707c5db0e3f56db953.zip
Remove www-apache/mod_watch, bug 464934.
Diffstat (limited to 'www-apache/mod_watch/files')
-rw-r--r--www-apache/mod_watch/files/77_mod_watch.conf32
-rw-r--r--www-apache/mod_watch/files/mod_watch-4.03-apache22.patch54
2 files changed, 0 insertions, 86 deletions
diff --git a/www-apache/mod_watch/files/77_mod_watch.conf b/www-apache/mod_watch/files/77_mod_watch.conf
deleted file mode 100644
index b35f5b86f726..000000000000
--- a/www-apache/mod_watch/files/77_mod_watch.conf
+++ /dev/null
@@ -1,32 +0,0 @@
-<IfDefine WATCH>
-LoadModule watch_module modules/mod_watch.so
-
-# Allows the URL used to query virtual host data:
-#
-# http://www.snert.com/watch-info
-#
-<Location /watch-info>
- SetHandler watch-info
-</Location>
-
-# Allows the URL used to query file owner and web
-# server data:
-#
-# http://www.snert.com/~achowe/watch-info
-# http://www.snert.com/~SERVER/watch-info
-#
-<Location /~*/watch-info>
- SetHandler watch-info
-</Location>
-
-# Intended for debugging and analysis of shared memory
-# hash table and weenie files:
-#
-# http://www.snert.com/watch-table
-#
-<Location /watch-table>
- SetHandler watch-table
-</Location>
-</IfDefine>
-
-# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_watch/files/mod_watch-4.03-apache22.patch b/www-apache/mod_watch/files/mod_watch-4.03-apache22.patch
deleted file mode 100644
index a0498cbe7995..000000000000
--- a/www-apache/mod_watch/files/mod_watch-4.03-apache22.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Common subdirectories: mod_watch-4.3/Contrib and mod_watch-4.3_apache22_mod/Contrib
-Common subdirectories: mod_watch-4.3/Img and mod_watch-4.3_apache22_mod/Img
-diff -u mod_watch-4.3/Makefile.dso mod_watch-4.3_apache22_mod/Makefile.dso
---- mod_watch-4.3/Makefile.dso 2003-03-14 10:50:15.000000000 +0100
-+++ mod_watch-4.3_apache22_mod/Makefile.dso 2007-04-19 13:49:22.000000000 +0200
-@@ -13,7 +13,8 @@
- #
- # The location of apxs utility.
- #
--APXS=/home/apache2/bin/apxs
-+#APXS=/home/apache2/bin/apxs
-+APXS=/usr/local/sbin/apxs
-
- #
- # The location of apachectl utility to stop/start/restart targets.
-diff -u mod_watch-4.3/mod_watch.c mod_watch-4.3_apache22_mod/mod_watch.c
---- mod_watch-4.3/mod_watch.c 2003-03-13 22:44:27.000000000 +0100
-+++ mod_watch-4.3_apache22_mod/mod_watch.c 2007-11-25 16:12:05.785948411 +0100
-@@ -258,7 +258,7 @@
- {
- char *username;
-
-- if (apr_get_username(&username, uid, p) == APR_SUCCESS)
-+ if (apr_uid_name_get(&username, uid, p) == APR_SUCCESS)
- return username;
-
- return "unknown-user";
-@@ -278,7 +278,7 @@
- {
- char *groupname;
-
-- if (apr_get_groupname(&groupname, gid, p) == APR_SUCCESS)
-+ if (apr_gid_name_get(&groupname, gid, p) == APR_SUCCESS)
- return groupname;
-
- return "unknown-group";
-@@ -355,7 +355,7 @@
-
- nbytes = sizeof word;
- rc = fileReadWord(fp, word, &nbytes);
-- if (!APR_STATUS_IS_SUCCESS(rc))
-+ if (rc != APR_SUCCESS)
- return rc;
-
- return sscanf(word, format, number) == 1 ? APR_SUCCESS : APR_EGENERAL;
-@@ -370,7 +370,7 @@
-
- nbytes = sizeof word;
- rc = fileReadWord(fp, word, &nbytes);
-- if (!APR_STATUS_IS_SUCCESS(rc))
-+ if (rc != APR_SUCCESS )
- return rc;
-
- return sscanf(word, "%lf", number) == 1 ? APR_SUCCESS : APR_EGENERAL;