summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-19 20:24:42 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-19 20:24:42 +0000
commita968dad2131dd47a7a535d9d8b9ef86d646c4a3c (patch)
treee91b90cbfdb851d2b5baec5b5175bcb37335517d /www-apache/mod_security
parentStable on amd64 wrt bug #367825 (diff)
downloadgentoo-2-a968dad2131dd47a7a535d9d8b9ef86d646c4a3c.tar.gz
gentoo-2-a968dad2131dd47a7a535d9d8b9ef86d646c4a3c.tar.bz2
gentoo-2-a968dad2131dd47a7a535d9d8b9ef86d646c4a3c.zip
Bump to final 2.6.0 version.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'www-apache/mod_security')
-rw-r--r--www-apache/mod_security/ChangeLog9
-rw-r--r--www-apache/mod_security/mod_security-2.6.0.ebuild (renamed from www-apache/mod_security/mod_security-2.6.0_rc2.ebuild)2
-rw-r--r--www-apache/mod_security/mod_security-2.6.0_rc1.ebuild94
3 files changed, 9 insertions, 96 deletions
diff --git a/www-apache/mod_security/ChangeLog b/www-apache/mod_security/ChangeLog
index 92e1a12a7af1..11b20139be6a 100644
--- a/www-apache/mod_security/ChangeLog
+++ b/www-apache/mod_security/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-apache/mod_security
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.54 2011/05/02 17:12:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/ChangeLog,v 1.55 2011/05/19 20:24:42 flameeyes Exp $
+
+*mod_security-2.6.0 (19 May 2011)
+
+ 19 May 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -mod_security-2.6.0_rc1.ebuild, -mod_security-2.6.0_rc2.ebuild,
+ +mod_security-2.6.0.ebuild:
+ Bump to final 2.6.0 version.
*mod_security-2.6.0_rc2 (02 May 2011)
diff --git a/www-apache/mod_security/mod_security-2.6.0_rc2.ebuild b/www-apache/mod_security/mod_security-2.6.0.ebuild
index 9d731694a336..ab9d952aece5 100644
--- a/www-apache/mod_security/mod_security-2.6.0_rc2.ebuild
+++ b/www-apache/mod_security/mod_security-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.0_rc2.ebuild,v 1.1 2011/05/02 17:12:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.0.ebuild,v 1.1 2011/05/19 20:24:42 flameeyes Exp $
EAPI=4
diff --git a/www-apache/mod_security/mod_security-2.6.0_rc1.ebuild b/www-apache/mod_security/mod_security-2.6.0_rc1.ebuild
deleted file mode 100644
index 1b52feda5a5d..000000000000
--- a/www-apache/mod_security/mod_security-2.6.0_rc1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_security/mod_security-2.6.0_rc1.ebuild,v 1.2 2011/04/19 08:10:34 flameeyes Exp $
-
-EAPI=3
-
-inherit apache-module
-
-MY_P=modsecurity-apache_${PV/_rc/-rc}
-
-DESCRIPTION="Web application firewall and Intrusion Detection System for Apache."
-HOMEPAGE="http://www.modsecurity.org/"
-SRC_URI="http://www.modsecurity.org/download/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="geoip curl"
-
-DEPEND=">=dev-libs/libxml2-2.7.8
- dev-libs/libpcre
- >=dev-lang/lua-5.1
- curl? ( >=net-misc/curl-7.15.1 )
- www-servers/apache[apache2_modules_unique_id]"
-RDEPEND="${DEPEND}
- geoip? ( dev-libs/geoip )"
-PDEPEND="www-apache/modsecurity-crs"
-
-S="${WORKDIR}/${PV/_rc/-rc}"
-
-APACHE2_MOD_FILE="apache2/.libs/${PN}2.so"
-APACHE2_MOD_DEFINE="SECURITY"
-
-# Tests require symbols only defined within the Apache binary.
-RESTRICT=test
-
-need_apache2
-
-src_prepare() {
- cp "${FILESDIR}"/modsecurity.conf "${T}"/79_modsecurity.conf || die
-}
-
-src_configure() {
- econf \
- --enable-shared --disable-static \
- --with-apxs="${APXS}" \
- $(use_enable curl mlogc) \
- || die "econf failed"
-}
-
-src_compile() {
- if ! use geoip; then
- sed -i -e '/SecGeoLookupDb/s:^:#:' \
- "${T}"/79_modsecurity.conf || die
- fi
-
- emake || die
-}
-
-src_test() {
- emake check || die
-}
-
-src_install() {
- apache-module_src_install
-
- # install manually rather than by using the APACHE2_MOD_CONF
- # variable since we have to edit it to set things up properly.
- insinto "${APACHE_MODULES_CONFDIR}"
- doins "${T}"/79_modsecurity.conf
-
- # install documentation; don't install index.html as it references
- # the PDF and split-pages versions of the same documentation.
- dodoc CHANGES
- dohtml "${S}"/doc/*.{css,gif,jpg} "${S}"/doc/modsecurity2*.html
-
- keepdir /var/cache/modsecurity || die
- fowners apache:apache /var/cache/modsecurity || die
- fperms 0770 /var/cache/modsecurity || die
-}
-
-pkg_postinst() {
- if [[ -f "${ROOT}"/etc/apache/modules.d/99_mod_security.conf ]]; then
- ewarn "You still have the configuration file 99_mod_security.conf."
- ewarn "Please make sure to remove that and keep only 79_modsecurity.conf."
- ewarn ""
- fi
- elog "The base configuration file has been renamed 79_modsecurity.conf"
- elog "so that you can put your own configuration as 90_modsecurity_local.conf or"
- elog "equivalent."
- elog ""
- elog "That would be the correct place for site-global security rules."
- elog "Note: 80_modsecurity_crs.conf is used by www-apache/modsecurity-crs"
-}