summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-24 02:45:01 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-24 02:45:01 +0000
commitb884bea938382e203923dd4b1a61bb39b610005a (patch)
treee9f6562025c6acc6b4c4a2151e4066565bf82e3b /www-apache/mod_perl
parentConvert mod_perl.conf to apache-2.4 #550246. (diff)
downloadgentoo-2-b884bea938382e203923dd4b1a61bb39b610005a.tar.gz
gentoo-2-b884bea938382e203923dd4b1a61bb39b610005a.tar.bz2
gentoo-2-b884bea938382e203923dd4b1a61bb39b610005a.zip
Use inline patch from Fedora to fix build w/gcc-5 #550244.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'www-apache/mod_perl')
-rw-r--r--www-apache/mod_perl/ChangeLog8
-rw-r--r--www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch22
-rw-r--r--www-apache/mod_perl/mod_perl-2.0.8-r2.ebuild162
3 files changed, 191 insertions, 1 deletions
diff --git a/www-apache/mod_perl/ChangeLog b/www-apache/mod_perl/ChangeLog
index 7931ea6eee58..d1c9b80e16c6 100644
--- a/www-apache/mod_perl/ChangeLog
+++ b/www-apache/mod_perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_perl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.121 2015/05/24 02:44:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/ChangeLog,v 1.122 2015/05/24 02:45:01 vapier Exp $
+
+*mod_perl-2.0.8-r2 (24 May 2015)
+
+ 24 May 2015; Mike Frysinger <vapier@gentoo.org>
+ +files/mod_perl-2.0.4-inline.patch, +mod_perl-2.0.8-r2.ebuild:
+ Use inline patch from Fedora to fix build w/gcc-5 #550244.
24 May 2015; Mike Frysinger <vapier@gentoo.org> mod_perl-2.0.8.ebuild,
files/2.0.3/75_mod_perl.conf, +files/2.0.3/75_mod_perl.conf.2.2:
diff --git a/www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch b/www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch
new file mode 100644
index 000000000000..5c51a803b816
--- /dev/null
+++ b/www-apache/mod_perl/files/mod_perl-2.0.4-inline.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/550244
+
+taken from Fedora:
+http://pkgs.fedoraproject.org/cgit/mod_perl.git/tree/mod_perl-2.0.4-inline.patch?h=f22
+
+fixes building with gcc-5:
+apache2: Syntax error on line 148 of /etc/apache2/httpd.conf:
+Syntax error on line 2 of /etc/apache2/modules.d/75_mod_perl.conf:
+Cannot load modules/mod_perl.so into server:
+/usr/lib64/apache2/modules/mod_perl.so: undefined symbol: modperl_handler_name
+
+--- mod_perl-2.0.4/src/modules/perl/modperl_common_util.h.inline
++++ mod_perl-2.0.4/src/modules/perl/modperl_common_util.h
+@@ -22,7 +22,7 @@
+ #ifdef MP_DEBUG
+ #define MP_INLINE
+ #else
+-#define MP_INLINE APR_INLINE
++#define MP_INLINE
+ #endif
+
+ #ifdef CYGWIN
diff --git a/www-apache/mod_perl/mod_perl-2.0.8-r2.ebuild b/www-apache/mod_perl/mod_perl-2.0.8-r2.ebuild
new file mode 100644
index 000000000000..dbd5ba41c091
--- /dev/null
+++ b/www-apache/mod_perl/mod_perl-2.0.8-r2.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_perl/mod_perl-2.0.8-r2.ebuild,v 1.1 2015/05/24 02:45:01 vapier Exp $
+
+EAPI="5"
+
+inherit depend.apache apache-module perl-module eutils
+
+DESCRIPTION="An embedded Perl interpreter for Apache2"
+HOMEPAGE="https://projects.apache.org/projects/mod_perl.html"
+SRC_URI="mirror://apache/perl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+# Make sure we always use the latest Apache-Test version or even check the
+# version of the bundled Apache-Test!
+#
+# We need both, apache and perl but either apache without threads or perl with
+# ithreads, bug 373943
+DEPEND="
+ >=dev-perl/Apache-Test-1.360
+ >=virtual/perl-CGI-3.08
+ dev-lang/perl[ithreads]
+ www-servers/apache
+"
+RDEPEND="${DEPEND}"
+PDEPEND=">=dev-perl/Apache-Reload-0.11
+ >=dev-perl/Apache-SizeLimit-0.95"
+
+APACHE2_MOD_FILE="${S}/src/modules/perl/mod_perl.so"
+APACHE2_MOD_CONF="2.0.3/75_${PN}"
+APACHE2_MOD_DEFINE="PERL"
+
+SRC_TEST="do"
+
+DOCFILES="Changes INSTALL README STATUS"
+
+need_apache2_4
+
+src_prepare() {
+ perl-module_src_prepare
+
+ # I am not entirely happy with this solution, but here's what's
+ # going on here if someone wants to take a stab at another
+ # approach. When userpriv compilation is off, then the make
+ # process drops to user "nobody" to run the test servers. This
+ # server is closed, and then the socket is rebound using
+ # SO_REUSEADDR. If the same user does this, there is no problem,
+ # and the socket may be rebound immediately. If a different user
+ # (yes, in my testing, even root) attempts to rebind, it fails.
+ # Since the "is the socket available yet" code and the
+ # second-batch bind call both run as root, this will fail.
+
+ # The upstream settings on my test machine cause the second batch
+ # of tests to fail, believing the socket to still be in use. I
+ # tried patching various parts to make them run as the user
+ # specified in $config->{vars}{user} using getpwnam, but found
+ # this patch to be fairly intrusive, because the userid must be
+ # restored and the patch must be applied to multiple places.
+
+ # For now, we will simply extend the timeout in hopes that in the
+ # non-userpriv case, the socket will clear from the kernel tables
+ # normally, and the tests will proceed.
+
+ # If anybody is still having problems, then commenting out "make
+ # test" below should allow the software to build properly.
+
+ # Robert Coie <rac@gentoo.org> 2003.05.06
+# sed -i -e "s/sleep \$_/sleep \$_ << 2/" \
+# "${S}"/Apache-Test/lib/Apache/TestServer.pm \
+# || die "problem editing TestServer.pm"
+
+ # rendhalver - this got redone for 2.0.1 and seems to fix the make test problems
+ epatch "${FILESDIR}"/${PN}-2.0.1-sneak-tmpdir.patch
+ epatch "${FILESDIR}"/${PN}-2.0.4-inline.patch #550244
+
+ # bug 352724
+ epatch "${FILESDIR}/${P}-bundled-Apache-Test.patch"
+ rm -rf Apache-{Test,Reload,SizeLimit}/ lib/Bundle/
+ sed -i \
+ -e 's:^Apache-\(Reload\|SizeLimit\|Test\).*::' \
+ -e 's:^lib/Bundle/Apache2.pm::' \
+ MANIFEST || die
+
+ # 410453
+ epatch "${FILESDIR}/use-client_ip-client_add-instead-of-remote_ip-remote.patch"
+ epatch "${FILESDIR}/use-log.level-instead-of-loglevel.patch"
+}
+
+src_configure() {
+ local debug=$(usex debug 1 0)
+ perl Makefile.PL \
+ PREFIX="${EPREFIX}"/usr \
+ INSTALLDIRS=vendor \
+ MP_USE_DSO=1 \
+ MP_APXS=${APXS} \
+ MP_APR_CONFIG=/usr/bin/apr-1-config \
+ MP_TRACE=${debug} \
+ MP_DEBUG=${debug} \
+ || die
+}
+
+src_test() {
+ # make test notes whether it is running as root, and drops
+ # privileges all the way to "nobody" if so, so we must adjust
+ # write permissions accordingly in this case.
+
+ # IF YOU SUDO TO EMERGE AND HAVE !env_reset set testing will fail!
+ if [[ "$(id -u)" == "0" ]]; then
+ chown nobody:nobody "${WORKDIR}" "${T}"
+ fi
+
+ # this does not || die because of bug 21325. kudos to smark for
+ # the idea of setting HOME.
+ TMPDIR="${T}" HOME="${T}/" perl-module_src_test
+}
+
+src_install() {
+ apache-module_src_install
+
+ default
+#emake DESTDIR="${D}" install || die
+
+ # TODO: add some stuff from docs/ back?
+
+ # rendhalver - fix the perllocal.pod that gets installed
+ # it seems to me that this has been getting installed for ages
+ perl_delete_localpod
+ # Remove empty .bs files as well
+ perl_delete_packlist
+
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/2.0.3/apache2-mod_perl-startup.pl
+
+ # this is an attempt to get @INC in line with /usr/bin/perl.
+ # there is blib garbage in the mainstream one that can only be
+ # useful during internal testing, so we wait until here and then
+ # just go with a clean slate. should be much easier to see what's
+ # happening and revert if problematic.
+
+ # Sorry for this evil hack...
+ perl_set_version # just to be sure...
+ sed -i \
+ -e "s,-I${S}/[^[:space:]\"\']\+[[:space:]]\?,,g" \
+ -e "s,-typemap[[:space:]]${S}/[^[:space:]\"\']\+[[:space:]]\?,,g" \
+ -e "s,${S}\(/[^[:space:]\"\']\+\)\?,/,g" \
+ "${D}/${VENDOR_ARCH}/Apache2/BuildConfig.pm" || die
+
+ for fname in $(find "${D}" -type f -not -name '*.so'); do
+ grep -q "\(${D}\|${S}\)" "${fname}" && ewarn "QA: File contains a temporary path ${fname}"
+ sed -i -e "s:\(${D}\|${S}\):/:g" ${fname}
+ done
+ # All the rest
+ perl_remove_temppath
+}
+
+pkg_postinst() {
+ apache-module_pkg_postinst
+}