summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2009-03-24 10:52:48 +0000
committerBenedikt Boehm <hollow@gentoo.org>2009-03-24 10:52:48 +0000
commit62fd6d6ab09e9fa70f32a988c2417cf7eb67fbde (patch)
treed440b3e7432981334a1187293204ec8a25560813 /www-apache/mod_macro
parentdev-cpp/gtkmm: drop the accessibility USE flag, always build atkmm instead (f... (diff)
downloadgentoo-2-62fd6d6ab09e9fa70f32a988c2417cf7eb67fbde.tar.gz
gentoo-2-62fd6d6ab09e9fa70f32a988c2417cf7eb67fbde.tar.bz2
gentoo-2-62fd6d6ab09e9fa70f32a988c2417cf7eb67fbde.zip
add support for macros.d/
(Portage version: 2.2_rc25/cvs/Linux i686)
Diffstat (limited to 'www-apache/mod_macro')
-rw-r--r--www-apache/mod_macro/ChangeLog8
-rw-r--r--www-apache/mod_macro/files/00_example.conf26
-rw-r--r--www-apache/mod_macro/files/27_mod_macro.conf26
-rw-r--r--www-apache/mod_macro/mod_macro-1.1.10.ebuild11
4 files changed, 42 insertions, 29 deletions
diff --git a/www-apache/mod_macro/ChangeLog b/www-apache/mod_macro/ChangeLog
index b3ef81233d21..34afeb57738a 100644
--- a/www-apache/mod_macro/ChangeLog
+++ b/www-apache/mod_macro/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_macro
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_macro/ChangeLog,v 1.17 2008/03/22 17:11:40 hollow Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_macro/ChangeLog,v 1.18 2009/03/24 10:52:47 hollow Exp $
+
+ 24 Mar 2009; Benedikt Böhm <hollow@gentoo.org> +files/00_example.conf,
+ files/27_mod_macro.conf, mod_macro-1.1.10.ebuild:
+ add support for macros.d/
22 Mar 2008; Benedikt Böhm <hollow@gentoo.org> mod_macro-1.1.10.ebuild:
amd64 stable wrt #208556
diff --git a/www-apache/mod_macro/files/00_example.conf b/www-apache/mod_macro/files/00_example.conf
new file mode 100644
index 000000000000..5b60e92ca830
--- /dev/null
+++ b/www-apache/mod_macro/files/00_example.conf
@@ -0,0 +1,26 @@
+# Definition of a MyVirtualHost Macro.
+<Macro MyVirtualHost $host $port $dir>
+ Listen $port
+
+ <VirtualHost $host:$port>
+ DocumentRoot $dir
+
+ <Directory $dir>
+ # do something here...
+ </Directory>
+
+ # limit access to intranet subdir.
+ <Directory $dir/intranet>
+ order deny,allow
+ deny from all
+ allow from 10.0.0.0/8
+ </Directory>
+ </VirtualHost>
+</Macro>
+
+# Use of MyVirtualHost with different arguments.
+#Use MyVirtualHost www.apache.org 80 /projects/apache/web
+#Use MyVirtualHost www.perl.com 8080 /projects/perl/web
+#Use MyVirtualHost www.ensmp.fr 1234 /projects/mines/web
+
+# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_macro/files/27_mod_macro.conf b/www-apache/mod_macro/files/27_mod_macro.conf
index 3f84f985e4bb..67ce8e4d2688 100644
--- a/www-apache/mod_macro/files/27_mod_macro.conf
+++ b/www-apache/mod_macro/files/27_mod_macro.conf
@@ -1,30 +1,6 @@
<IfDefine MACRO>
LoadModule macro_module modules/mod_macro.so
-
-# Definition of a MyVirtualHost Macro.
-<Macro MyVirtualHost $host $port $dir>
- Listen $port
-
- <VirtualHost $host:$port>
- DocumentRoot $dir
-
- <Directory $dir>
- # do something here...
- </Directory>
-
- # limit access to intranet subdir.
- <Directory $dir/intranet>
- order deny,allow
- deny from all
- allow from 10.0.0.0/8
- </Directory>
- </VirtualHost>
-</Macro>
-
-# Use of MyVirtualHost with different arguments.
-#Use MyVirtualHost www.apache.org 80 /projects/apache/web
-#Use MyVirtualHost www.perl.com 8080 /projects/perl/web
-#Use MyVirtualHost www.ensmp.fr 1234 /projects/mines/web
+Include /etc/apache2/macros.d/*.conf
</IfDefine>
# vim: ts=4 filetype=apache
diff --git a/www-apache/mod_macro/mod_macro-1.1.10.ebuild b/www-apache/mod_macro/mod_macro-1.1.10.ebuild
index 008fed8d49ee..411cede4b513 100644
--- a/www-apache/mod_macro/mod_macro-1.1.10.ebuild
+++ b/www-apache/mod_macro/mod_macro-1.1.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_macro/mod_macro-1.1.10.ebuild,v 1.3 2008/03/22 17:11:40 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_macro/mod_macro-1.1.10.ebuild,v 1.4 2009/03/24 10:52:47 hollow Exp $
inherit apache-module
@@ -22,3 +22,10 @@ APACHE2_MOD_DEFINE="MACRO"
DOCFILES="CHANGES INSTALL README mod_macro.html"
need_apache2_2
+
+src_install() {
+ apache-module_src_install
+ keepdir "${APACHE_CONFDIR}"/macros.d/
+ insinto "${APACHE_CONFDIR}"/macros.d/
+ doins "${FILESDIR}"/00_example.conf
+}