summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-04-13 14:45:38 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-04-13 14:45:38 +0000
commit34b7a55d92f4da5aedf4625bb2e4d5d938697102 (patch)
treebc2ed82a1124d5ed1308a71087f9fbbc244fafa4 /www-apache/mod_caucho
parentStable on sparc wrt security #174206 (diff)
downloadgentoo-2-34b7a55d92f4da5aedf4625bb2e4d5d938697102.tar.gz
gentoo-2-34b7a55d92f4da5aedf4625bb2e4d5d938697102.tar.bz2
gentoo-2-34b7a55d92f4da5aedf4625bb2e4d5d938697102.zip
Add patch for SSL connections.
(Portage version: 2.1.2.3)
Diffstat (limited to 'www-apache/mod_caucho')
-rw-r--r--www-apache/mod_caucho/ChangeLog6
-rw-r--r--www-apache/mod_caucho/files/mod_caucho-3.0.22-ssl.patch20
-rw-r--r--www-apache/mod_caucho/mod_caucho-3.0.22.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/www-apache/mod_caucho/ChangeLog b/www-apache/mod_caucho/ChangeLog
index 1b96a52a3fb1..aaebf235de3e 100644
--- a/www-apache/mod_caucho/ChangeLog
+++ b/www-apache/mod_caucho/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-apache/mod_caucho
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.12 2007/02/03 13:43:13 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/ChangeLog,v 1.13 2007/04/13 14:45:38 nelchael Exp $
+
+ 13 Apr 2007; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/mod_caucho-3.0.22-ssl.patch, mod_caucho-3.0.22.ebuild:
+ Add patch for SSL connections.
03 Feb 2007; Steve Dibb <beandog@gentoo.org> mod_caucho-3.0.22.ebuild:
amd64 stable, bug 163278
diff --git a/www-apache/mod_caucho/files/mod_caucho-3.0.22-ssl.patch b/www-apache/mod_caucho/files/mod_caucho-3.0.22-ssl.patch
new file mode 100644
index 000000000000..fc6a0b5ac878
--- /dev/null
+++ b/www-apache/mod_caucho/files/mod_caucho-3.0.22-ssl.patch
@@ -0,0 +1,20 @@
+diff -Nru resin-3.0.22.vanilla/modules/c/src/apache2/mod_caucho.c resin-3.0.22/modules/c/src/apache2/mod_caucho.c
+--- resin-3.0.22.vanilla/modules/c/src/apache2/mod_caucho.c 2007-04-13 15:41:18.000000000 +0200
++++ resin-3.0.22/modules/c/src/apache2/mod_caucho.c 2007-04-13 16:00:24.000000000 +0200
+@@ -582,6 +582,16 @@
+ }
+ }
+ #endif
++ /* Add SSL Client certificate: (requires SSLOptions +StdEnvVars) */
++ {
++ int i;
++ char **env = (char **)ap_create_environment(r->pool, r->subprocess_env);
++ for (i = 0; env[i]; ++i) {
++ char *name = strsep(&(env[i]), "=");
++ if (strncmp(name, "SSL_CLIENT_CERT", 16) == 0)
++ cse_write_string(s, CSE_CLIENT_CERT, env[i]);
++ }
++ }
+ }
+
+ /**
diff --git a/www-apache/mod_caucho/mod_caucho-3.0.22.ebuild b/www-apache/mod_caucho/mod_caucho-3.0.22.ebuild
index bdf061fe4682..071790000da8 100644
--- a/www-apache/mod_caucho/mod_caucho-3.0.22.ebuild
+++ b/www-apache/mod_caucho/mod_caucho-3.0.22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.22.ebuild,v 1.5 2007/02/03 13:43:13 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_caucho/mod_caucho-3.0.22.ebuild,v 1.6 2007/04/13 14:45:38 nelchael Exp $
inherit eutils apache-module autotools
@@ -26,6 +26,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-gentoo.patch"
+ epatch "${FILESDIR}/${P}-ssl.patch"
eautoreconf
chmod 755 ./configure
}