summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-04-02 07:31:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-04-02 07:31:59 +0000
commit4511389b14c47a69a21bb573364d93b30914e4d7 (patch)
tree68e495632190c205f4df21e2b6be8e60045eb5b1 /www-apache/mod_auth_mysql
parentBump hashtables to 1.1.0.2 (diff)
downloadgentoo-2-4511389b14c47a69a21bb573364d93b30914e4d7.tar.gz
gentoo-2-4511389b14c47a69a21bb573364d93b30914e4d7.tar.bz2
gentoo-2-4511389b14c47a69a21bb573364d93b30914e4d7.zip
Compile fix #442488
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'www-apache/mod_auth_mysql')
-rw-r--r--www-apache/mod_auth_mysql/ChangeLog10
-rw-r--r--www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r3.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/www-apache/mod_auth_mysql/ChangeLog b/www-apache/mod_auth_mysql/ChangeLog
index 573c71160d57..8b6e4589bb70 100644
--- a/www-apache/mod_auth_mysql/ChangeLog
+++ b/www-apache/mod_auth_mysql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apache/mod_auth_mysql
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/ChangeLog,v 1.12 2012/11/27 19:04:54 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/ChangeLog,v 1.13 2013/04/02 07:31:59 patrick Exp $
+
+*mod_auth_mysql-3.0.0-r3 (02 Apr 2013)
+
+ 02 Apr 2013; Patrick Lauer <patrick@gentoo.org>
+ +mod_auth_mysql-3.0.0-r3.ebuild:
+ Compile fix #442488
27 Nov 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop apache herd as discussed in http://www.gossamer-
diff --git a/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r3.ebuild b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r3.ebuild
new file mode 100644
index 000000000000..b7d3c44a6176
--- /dev/null
+++ b/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_auth_mysql/mod_auth_mysql-3.0.0-r3.ebuild,v 1.1 2013/04/02 07:31:59 patrick Exp $
+
+EAPI="2"
+
+inherit apache-module eutils multilib
+
+DESCRIPTION="Basic authentication for Apache using a MySQL database."
+HOMEPAGE="http://modauthmysql.sourceforge.net/"
+SRC_URI="mirror://sourceforge/modauthmysql/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/mysql
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ !www-apache/mod-auth-mysql"
+
+APXS2_ARGS="-c -I/usr/include/mysql -L/usr/$(get_libdir)/mysql -Wl,-R/usr/$(get_libdir)/mysql -lmysqlclient_r -lm -lz ${PN}.c"
+APACHE2_MOD_CONF="12_${PN}"
+APACHE2_MOD_DEFINE="AUTH_MYSQL"
+
+DOCFILES="README CONFIGURE"
+
+need_apache2_2
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-apache-2.2.patch"
+ epatch "${FILESDIR}/${P}-htpasswd2-auth-style.patch"
+}