summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-07-16 14:19:41 +0000
committerMike Gilbert <floppym@gentoo.org>2015-07-16 14:19:41 +0000
commit86300fd2fb918b6e172c7a915a696dcc2a8dfcb6 (patch)
treefaef922fe9b1d8254909cc8862f9a21d7fb794b2 /sys-process
parentversion bump (diff)
downloadgentoo-2-86300fd2fb918b6e172c7a915a696dcc2a8dfcb6.tar.gz
gentoo-2-86300fd2fb918b6e172c7a915a696dcc2a8dfcb6.tar.bz2
gentoo-2-86300fd2fb918b6e172c7a915a696dcc2a8dfcb6.zip
Revbump for bug 554664.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronie/ChangeLog7
-rw-r--r--sys-process/cronie/cronie-1.5.0-r1.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index 4f7c6cba0f68..b101b06db99c 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/cronie
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.71 2015/07/13 15:07:47 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.72 2015/07/16 14:19:41 floppym Exp $
+
+*cronie-1.5.0-r1 (16 Jul 2015)
+
+ 16 Jul 2015; Mike Gilbert <floppym@gentoo.org> +cronie-1.5.0-r1.ebuild:
+ Revbump for bug 554664.
13 Jul 2015; Mike Gilbert <floppym@gentoo.org> +files/cronie-systemd.patch,
cronie-1.5.0.ebuild:
diff --git a/sys-process/cronie/cronie-1.5.0-r1.ebuild b/sys-process/cronie/cronie-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..0285be36333c
--- /dev/null
+++ b/sys-process/cronie/cronie-1.5.0-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.5.0-r1.ebuild,v 1.1 2015/07/16 14:19:41 floppym Exp $
+
+EAPI=5
+
+inherit cron eutils pam systemd user
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2 GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="anacron +inotify pam selinux"
+
+DEPEND="pam? ( virtual/pam )
+ anacron? ( !sys-process/anacron )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/cronie-systemd.patch"
+}
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" \
+ ANACRON_SPOOL_DIR="/var/spool/anacron" \
+ econf \
+ $(use_with inotify) \
+ $(use_with pam) \
+ $(use_with selinux) \
+ $(use_enable anacron) \
+ --enable-syscrontab \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ insinto /etc/conf.d
+ newins "${S}"/crond.sysconfig ${PN}
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.3-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ systemd_newunit contrib/cronie.systemd cronie.service
+
+ if use anacron ; then
+ local anacrondir="/var/spool/anacron"
+ keepdir ${anacrondir}
+ fowners root:cron ${anacrondir}
+ fperms 0750 ${anacrondir}
+
+ insinto /etc
+
+ doins contrib/anacrontab
+
+ insinto /etc/cron.hourly
+ doins contrib/0anacron
+ fperms 0750 /etc/cron.hourly/0anacron
+ fi
+
+ dodoc AUTHORS README NEWS contrib/*
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}