summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2008-10-06 15:08:38 +0000
committerWolfram Schlich <wschlich@gentoo.org>2008-10-06 15:08:38 +0000
commit45c74d842d8b00a623a81dc34dee0ebfd6301c91 (patch)
treeac695b3b924050721a82aa4191046234ac98bf3b /sys-process
parentDon't use absolute path in patch file (diff)
downloadgentoo-2-45c74d842d8b00a623a81dc34dee0ebfd6301c91.tar.gz
gentoo-2-45c74d842d8b00a623a81dc34dee0ebfd6301c91.tar.bz2
gentoo-2-45c74d842d8b00a623a81dc34dee0ebfd6301c91.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r5-1 i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog7
-rw-r--r--sys-process/htop/htop-0.8.1.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index bacf920dfc96..dbe849710cfe 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.58 2008/09/18 08:43:39 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.59 2008/10/06 15:08:38 wschlich Exp $
+
+*htop-0.8.1 (06 Oct 2008)
+
+ 06 Oct 2008; Wolfram Schlich <wschlich@gentoo.org> +htop-0.8.1.ebuild:
+ version bump
18 Sep 2008; Raúl Porcel <armin76@gentoo.org> htop-0.8-r1.ebuild:
Add ~sh
diff --git a/sys-process/htop/htop-0.8.1.ebuild b/sys-process/htop/htop-0.8.1.ebuild
new file mode 100644
index 000000000000..3ff1dcfdfdff
--- /dev/null
+++ b/sys-process/htop/htop-0.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.1.ebuild,v 1.1 2008/10/06 15:08:38 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="debug unicode"
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+DEPEND="sys-libs/ncurses"
+
+pkg_setup() {
+ if use elibc_FreeBSD ; then
+ elog
+ elog "htop needs /proc mounted to work, to mount it type"
+ elog "mount -t linprocfs none /proc"
+ elog "or uncomment the example in /etc/fstab"
+ elog
+ fi
+}
+
+src_compile() {
+ if use unicode && ! built_with_use sys-libs/ncurses unicode; then
+ die "for unicode support of htop, sys-libs/ncurses must be emerged with USE=unicode"
+ fi
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf \
+ --enable-taskstats \
+ $(use_enable unicode) \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}