summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-28 23:47:22 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-28 23:47:22 +0000
commit438f9fc15d7a446d18f4f3e8b81bd59b2869cf30 (patch)
tree4f2989400914875b3ebe83f688ea383660df6bb6 /sys-process
parentProperly support the CABAL_FEATURES="nocabaldep" if user doesn't have dev-has... (diff)
downloadgentoo-2-438f9fc15d7a446d18f4f3e8b81bd59b2869cf30.tar.gz
gentoo-2-438f9fc15d7a446d18f4f3e8b81bd59b2869cf30.tar.bz2
gentoo-2-438f9fc15d7a446d18f4f3e8b81bd59b2869cf30.zip
Version bump.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/incron/ChangeLog7
-rw-r--r--sys-process/incron/incron-0.5.9.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-process/incron/ChangeLog b/sys-process/incron/ChangeLog
index c6989285415d..efee7ffab6c7 100644
--- a/sys-process/incron/ChangeLog
+++ b/sys-process/incron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/incron
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.9 2009/10/28 23:41:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/ChangeLog,v 1.10 2009/10/28 23:47:22 vapier Exp $
+
+*incron-0.5.9 (28 Oct 2009)
+
+ 28 Oct 2009; Mike Frysinger <vapier@gentoo.org> +incron-0.5.9.ebuild:
+ Version bump.
28 Oct 2009; Mike Frysinger <vapier@gentoo.org> incron-0.5.8.ebuild:
Install doc files.
diff --git a/sys-process/incron/incron-0.5.9.ebuild b/sys-process/incron/incron-0.5.9.ebuild
new file mode 100644
index 000000000000..18917d109d43
--- /dev/null
+++ b/sys-process/incron/incron-0.5.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/incron/incron-0.5.9.ebuild,v 1.1 2009/10/28 23:47:22 vapier Exp $
+
+EAPI="2"
+
+inherit eutils linux-info toolchain-funcs
+
+DESCRIPTION="inotify based cron daemon"
+HOMEPAGE="http://incron.aiken.cz/"
+SRC_URI="http://inotify.aiken.cz/download/incron/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CONFIG_CHECK="~INOTIFY"
+ERROR_INOTIFY="Recompile your kernel with inotify support - CONFIG_INOTIFY"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.8-gentoo.patch \
+ "${FILESDIR}"/${PN}-0.5.8-gcc44.patch
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX) CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGELOG README TODO
+}