summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-06-13 12:40:41 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-06-13 12:40:41 +0000
commit3eac5ef0527491f21ac05bd57018764393e19a67 (patch)
treec480a4a321cd6058b52795a965bda4b28db88c56 /sys-process
parentslotmove of app-backup/konserve to 3.5 (diff)
downloadgentoo-2-3eac5ef0527491f21ac05bd57018764393e19a67.tar.gz
gentoo-2-3eac5ef0527491f21ac05bd57018764393e19a67.tar.bz2
gentoo-2-3eac5ef0527491f21ac05bd57018764393e19a67.zip
Version bump to 0.8.2, bug 273770; Thanks to Lars Wendler (polynomial-c@gentoo.org) for the report and help on finding patches; Also fixes bug #258112; Adds lsof support; Add a patch to fix crashes when pressing keys 'a' or 'F6'; QA fix for implicit RDEPEND in 0.8.1-r1.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/htop/ChangeLog12
-rw-r--r--sys-process/htop/files/htop-0.8.2-illegaladdrcopy.patch73
-rw-r--r--sys-process/htop/htop-0.8.1-r1.ebuild4
-rw-r--r--sys-process/htop/htop-0.8.2.ebuild52
4 files changed, 139 insertions, 2 deletions
diff --git a/sys-process/htop/ChangeLog b/sys-process/htop/ChangeLog
index c6d0c3440bed..fac3cf42a64c 100644
--- a/sys-process/htop/ChangeLog
+++ b/sys-process/htop/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-process/htop
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.74 2009/03/15 20:20:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/ChangeLog,v 1.75 2009/06/13 12:40:41 gentoofan23 Exp $
+
+*htop-0.8.2 (13 Jun 2009)
+
+ 13 Jun 2009; Thomas Anderson <gentoofan23@gentoo.org>
+ +files/htop-0.8.2-illegaladdrcopy.patch, htop-0.8.1-r1.ebuild,
+ +htop-0.8.2.ebuild:
+ Version bump to 0.8.2, bug 273770; Thanks to Lars Wendler
+ (polynomial-c@gentoo.org) for the report and help on finding patches; Also
+ fixes bug #258112; Adds lsof support; Add a patch to fix crashes when
+ pressing keys 'a' or 'F6'; QA fix for implicit RDEPEND in 0.8.1-r1.
15 Mar 2009; Raúl Porcel <armin76@gentoo.org> htop-0.8.1-r1.ebuild:
alpha stable
diff --git a/sys-process/htop/files/htop-0.8.2-illegaladdrcopy.patch b/sys-process/htop/files/htop-0.8.2-illegaladdrcopy.patch
new file mode 100644
index 000000000000..6202d4ba0690
--- /dev/null
+++ b/sys-process/htop/files/htop-0.8.2-illegaladdrcopy.patch
@@ -0,0 +1,73 @@
+Found from http://sourceforge.net/tracker/?func=detail&aid=2803527&group_id=108839&atid=651633
+
+Index: FunctionBar.c
+===================================================================
+--- FunctionBar.c (revision 162)
++++ FunctionBar.c (working copy)
+@@ -52,12 +52,14 @@ FunctionBar* FunctionBar_new(char** func
+ this->functions = malloc(sizeof(char*) * 15);
+ this->keys = malloc(sizeof(char*) * 15);
+ this->events = malloc(sizeof(int) * 15);
+- int i = 0;
+- while (i < 15 && functions[i]) {
++ int i;
++ for (i = 0; i < 15; i++) {
++ if (functions[i] == NULL) /* We don't know the size of the array, */
++ break; /* so let's assume it is NULL terminated */
++ /* and break if we find that NULL */
+ this->functions[i] = String_copy(functions[i]);
+ this->keys[i] = String_copy(keys[i]);
+ this->events[i] = events[i];
+- i++;
+ }
+ this->size = i;
+ } else {
+Index: htop.c
+===================================================================
+--- htop.c (revision 162)
++++ htop.c (working copy)
+@@ -151,7 +151,7 @@ static void showHelp(ProcessList* pl) {
+ clear();
+ }
+
+-static char* CategoriesFunctions[10] = {" ", " ", " ", " ", " ", " ", " ", " ", " ", "Done "};
++static char* CategoriesFunctions[] = {" ", " ", " ", " ", " ", " ", " ", " ", " ", "Done ", NULL};
+
+ static void Setup_run(Settings* settings, int headerHeight) {
+ ScreenManager* scr = ScreenManager_new(0, headerHeight, 0, -1, HORIZONTAL, true);
+@@ -190,7 +190,7 @@ static HandlerResult pickWithEnter(Panel
+ }
+
+ static Object* pickFromVector(Panel* panel, Panel* list, int x, int y, char** keyLabels, FunctionBar* prevBar) {
+- char* fuKeys[2] = {"Enter", "Esc"};
++ char* fuKeys[] = {"Enter", "Esc", NULL};
+ int fuEvents[2] = {13, 27};
+ if (!list->eventHandler)
+ Panel_setEventHandler(list, pickWithEnter);
+@@ -326,7 +326,7 @@ int main(int argc, char** argv) {
+ Panel_setRichHeader(panel, ProcessList_printHeader(pl));
+
+ char* searchFunctions[] = {"Next ", "Exit ", " Search: ", NULL};
+- char* searchKeys[] = {"F3", "Esc", " "};
++ char* searchKeys[] = {"F3", "Esc", " ", NULL};
+ int searchEvents[] = {KEY_F(3), 27, ERR};
+ FunctionBar* searchBar = FunctionBar_new(searchFunctions, searchKeys, searchEvents);
+
+@@ -656,7 +656,7 @@ int main(int argc, char** argv) {
+
+ Panel* affinityPanel = AffinityPanel_new(pl->processorCount, curr);
+
+- char* fuFunctions[2] = {"Set ", "Cancel "};
++ char* fuFunctions[3] = {"Set ", "Cancel ", NULL};
+ void* set = pickFromVector(panel, affinityPanel, 15, headerHeight, fuFunctions, defaultBar);
+ if (set) {
+ unsigned long new = AffinityPanel_getAffinity(affinityPanel);
+@@ -695,7 +695,7 @@ int main(int argc, char** argv) {
+ {
+ Panel* sortPanel = Panel_new(0, 0, 0, 0, LISTITEM_CLASS, true, ListItem_compare);
+ Panel_setHeader(sortPanel, "Sort by");
+- char* fuFunctions[2] = {"Sort ", "Cancel "};
++ char* fuFunctions[] = {"Sort ", "Cancel ", NULL};
+ ProcessField* fields = pl->fields;
+ for (int i = 0; fields[i]; i++) {
+ char* name = String_trim(Process_fieldTitles[fields[i]]);
diff --git a/sys-process/htop/htop-0.8.1-r1.ebuild b/sys-process/htop/htop-0.8.1-r1.ebuild
index f82be85aafc8..3016a936dcf4 100644
--- a/sys-process/htop/htop-0.8.1-r1.ebuild
+++ b/sys-process/htop/htop-0.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.1-r1.ebuild,v 1.10 2009/03/15 20:20:51 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.1-r1.ebuild,v 1.11 2009/06/13 12:40:41 gentoofan23 Exp $
EAPI="2"
@@ -13,7 +13,9 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+
DEPEND="sys-libs/ncurses[unicode?]"
+RDEPEND="${DEPEND}"
pkg_setup() {
if use elibc_FreeBSD && ! [[ -f "${ROOT}"/proc/stat && -f "${ROOT}"/proc/meminfo ]] ; then
diff --git a/sys-process/htop/htop-0.8.2.ebuild b/sys-process/htop/htop-0.8.2.ebuild
new file mode 100644
index 000000000000..345987925114
--- /dev/null
+++ b/sys-process/htop/htop-0.8.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-0.8.2.ebuild,v 1.1 2009/06/13 12:40:41 gentoofan23 Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="sys-libs/ncurses[unicode]"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use elibc_FreeBSD && ! [[ -f "${ROOT}"/proc/stat && -f "${ROOT}"/proc/meminfo ]] ; then
+ eerror
+ eerror "htop needs /proc mounted to compile and work, to mount it type"
+ eerror "mount -t linprocfs none /proc"
+ eerror "or uncomment the example in /etc/fstab"
+ eerror
+ die "htop needs /proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof ; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.1-non-printable-char-filter.patch \
+ "${FILESDIR}"/${P}-illegaladdrcopy.patch
+}
+
+src_configure() {
+ useq debug && append-flags -O -ggdb -DDEBUG
+ econf \
+ --enable-taskstats \
+ --enable-unicode
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO || die "documentation installation failed."
+ rmdir "${D}"/usr/{include,$(get_libdir)} || die "Removing empty directory failed."
+}