summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-26 07:35:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-26 07:35:33 +0000
commitc95074041f3e43fc098b8b09853f0db64ac5cfb8 (patch)
tree468910245ddbb3b795a26faff133d76b625e1618 /sys-process/psmisc
parentmask newer findutils (diff)
downloadgentoo-2-c95074041f3e43fc098b8b09853f0db64ac5cfb8.tar.gz
gentoo-2-c95074041f3e43fc098b8b09853f0db64ac5cfb8.tar.bz2
gentoo-2-c95074041f3e43fc098b8b09853f0db64ac5cfb8.zip
Cheesy patch for gcc-2 compilers.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'sys-process/psmisc')
-rw-r--r--sys-process/psmisc/ChangeLog6
-rw-r--r--sys-process/psmisc/files/psmisc-22.2-gcc2.patch40
-rw-r--r--sys-process/psmisc/psmisc-22.2.ebuild10
3 files changed, 54 insertions, 2 deletions
diff --git a/sys-process/psmisc/ChangeLog b/sys-process/psmisc/ChangeLog
index 022b2b2bd3f8..f9b4798c4a1a 100644
--- a/sys-process/psmisc/ChangeLog
+++ b/sys-process/psmisc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/psmisc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.43 2006/07/09 06:49:13 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.44 2006/08/26 07:35:33 vapier Exp $
+
+ 26 Aug 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/psmisc-22.2-gcc2.patch, psmisc-22.2.ebuild:
+ Cheesy patch for gcc-2 compilers.
09 Jul 2006; Joshua Kinard <kumba@gentoo.org> psmisc-22.2.ebuild:
Marked stable on mips.
diff --git a/sys-process/psmisc/files/psmisc-22.2-gcc2.patch b/sys-process/psmisc/files/psmisc-22.2-gcc2.patch
new file mode 100644
index 000000000000..181fb78b9c98
--- /dev/null
+++ b/sys-process/psmisc/files/psmisc-22.2-gcc2.patch
@@ -0,0 +1,40 @@
+cheesy ass workaround for gcc-2:
+i686-pc-linux-gnu-gcc -Wall -DLOCALEDIR=\"/usr/share/locale\" -march=i686 -O2 -pipe -o pstree pstree.o -lncurses
+fuser.c:103: warning: preprocessing directive not recognized within macro arg
+fuser.c:103: warning: preprocessing directive not recognized within macro arg
+fuser.c:103: warning: preprocessing directive not recognized within macro arg
+fuser.c:103: warning: preprocessing directive not recognized within macro arg
+fuser.c:103: warning: preprocessing directive not recognized within macro arg
+fuser.c:103: warning: preprocessing directive not recognized within macro arg
+fuser.c: In function `usage':
+fuser.c:98: undefined or invalid # directive
+fuser.c:101: undefined or invalid # directive
+make[3]: *** [fuser.o] Error 1
+
+--- src/fuser.c
++++ src/fuser.c
+@@ -82,6 +82,11 @@ static void usage (const char *errormsg)
+ if (errormsg != NULL)
+ fprintf(stderr, "%s\n", errormsg);
+
++#ifdef WITH_IPV6
++# define _IPv6(x) x
++#else
++# define _IPv6(x)
++#endif
+ fprintf (stderr, _(
+ "Usage: fuser [ -a | -s | -c ] [ -n SPACE ] [ -SIGNAL ] [ -kimuv ] NAME...\n"
+ " [ - ] [ -n SPACE ] [ -SIGNAL ] [ -kimuv ] NAME...\n"
+@@ -101,10 +106,10 @@ static void usage (const char *errormsg)
+ " -u display user IDs\n"
+ " -v verbose output\n"
+ " -V display version information\n"
+-#ifdef WITH_IPV6
++_IPv6(
+ " -4 search IPv4 sockets only\n"
+ " -6 search IPv6 sockets only\n"
+-#endif
++)
+ " - reset options\n\n"
+ " udp/tcp names: [local_port][,[rmt_host][,[rmt_port]]]\n\n"));
+ exit (1);
diff --git a/sys-process/psmisc/psmisc-22.2.ebuild b/sys-process/psmisc/psmisc-22.2.ebuild
index 3ca741bb727f..bb242d2963fe 100644
--- a/sys-process/psmisc/psmisc-22.2.ebuild
+++ b/sys-process/psmisc/psmisc-22.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.2.ebuild,v 1.12 2006/07/09 06:49:13 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.2.ebuild,v 1.13 2006/08/26 07:35:33 vapier Exp $
+
+inherit eutils
DESCRIPTION="A set of tools that use the proc filesystem"
HOMEPAGE="http://psmisc.sourceforge.net/"
@@ -17,6 +19,12 @@ DEPEND="${RDEPEND}
sys-devel/libtool
nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc2.patch
+}
+
src_compile() {
econf \
--bindir=/bin \