summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-16 20:14:16 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-16 20:14:16 +0000
commit6698aa7a1fd62f407041e263d64966096932a161 (patch)
tree0c1083d19d8d3792ac1739c494838c8914dbad22 /sys-process/prll
parentAdd patch from upstream for libmount.h in C++ code #401057 by Michał Górny.... (diff)
downloadgentoo-2-6698aa7a1fd62f407041e263d64966096932a161.tar.gz
gentoo-2-6698aa7a1fd62f407041e263d64966096932a161.tar.bz2
gentoo-2-6698aa7a1fd62f407041e263d64966096932a161.zip
sys-process/prll: New package (copied from dev-util/git)
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-process/prll')
-rw-r--r--sys-process/prll/ChangeLog68
-rw-r--r--sys-process/prll/files/0.5-prefix.patch30
-rw-r--r--sys-process/prll/metadata.xml8
-rw-r--r--sys-process/prll/prll-0.6.2.ebuild33
4 files changed, 139 insertions, 0 deletions
diff --git a/sys-process/prll/ChangeLog b/sys-process/prll/ChangeLog
new file mode 100644
index 000000000000..fe897a7b0996
--- /dev/null
+++ b/sys-process/prll/ChangeLog
@@ -0,0 +1,68 @@
+# ChangeLog for sys-process/prll
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/prll/ChangeLog,v 1.1 2012/02/16 20:14:16 jlec Exp $
+
+ 16 Feb 2012; Justin Lecher <jlec@gentoo.org> +files/0.5-prefix.patch,
+ +prll-0.6.2.ebuild, +metadata.xml:
+ New package (copied from sys-process/prll)
+
+ 16 Feb 2012; Justin Lecher <jlec@gentoo.org> -prll-0.5.ebuild,
+ -prll-0.6.ebuild, -prll-0.6.1.ebuild:
+ Drop old
+
+ 16 Feb 2012; Justin Lecher <jlec@gentoo.org> Manifest:
+ Drop old
+
+ 16 Feb 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> prll-0.6.2.ebuild:
+ x86 stable wrt bug #401091
+
+ 28 Jan 2012; Agostino Sarubbo <ago@gentoo.org> prll-0.6.2.ebuild:
+ Stable for amd64, wrt bug #401091
+
+*prll-0.6.2 (29 Oct 2011)
+
+ 29 Oct 2011; Justin Lecher <jlec@gentoo.org> +prll-0.6.2.ebuild:
+ Version BUmp
+
+*prll-0.6.1 (19 Oct 2011)
+
+ 19 Oct 2011; Justin Lecher <jlec@gentoo.org> +prll-0.6.1.ebuild, metadata.xml:
+ Version Bump
+
+ 14 Aug 2011; Justin Lecher <jlec@gentoo.org> prll-0.6.ebuild, metadata.xml:
+ Don't test with random shells, but with bash, #378563
+
+ 22 May 2011; Justin Lecher <jlec@gentoo.org> prll-0.6.ebuild:
+ Removed unnessacerry DEP and correct DESCRIPTION, #368347
+
+*prll-0.6 (20 May 2011)
+
+ 20 May 2011; Justin Lecher <jlec@gentoo.org> +prll-0.6.ebuild:
+ Version Bump
+
+ 11 Jan 2011; Markus Meier <maekke@gentoo.org> prll-0.5.ebuild:
+ x86 stable, bug #350712
+
+ 05 Jan 2011; Markos Chandras <hwoarang@gentoo.org> prll-0.5.ebuild:
+ Stable on amd64 wrt bug #350712
+
+ 05 Jan 2011; Justin Lecher <jlec@gentoo.org> -files/0.4-ldflags.patch,
+ -files/0.4-prefix.patch, -prll-0.4.ebuild:
+ Some Clean up
+
+*prll-0.5 (18 May 2010)
+
+ 18 May 2010; Justin Lecher <jlec@gentoo.org> +files/0.5-prefix.patch,
+ +prll-0.5.ebuild:
+ Version Bump, #319833, thanks Jure Varlec for the patches
+
+ 01 Mar 2010; Justin Lecher <jlec@gentoo.org> metadata.xml:
+ Added to shell-tools herd
+
+*prll-0.4 (26 Feb 2010)
+
+ 26 Feb 2010; Justin Lecher <jlec@gentoo.org>
+ +files/0.4-ldflags.patch, +files/0.4-prefix.patch, +prll-0.4.ebuild,
+ +metadata.xml:
+ Imported from sunrise, Thanks Jure Varlec for inial ebuild, #299798.
+
diff --git a/sys-process/prll/files/0.5-prefix.patch b/sys-process/prll/files/0.5-prefix.patch
new file mode 100644
index 000000000000..dcf2314fb5d0
--- /dev/null
+++ b/sys-process/prll/files/0.5-prefix.patch
@@ -0,0 +1,30 @@
+diff --git a/prll.sh b/prll.sh
+index 45a4fa4..f3ec39f 100644
+--- a/prll.sh
++++ b/prll.sh
+@@ -41,7 +41,7 @@ function prll() {
+ EOF
+ [[ -z "$1" ]] && return 1 || return 0
+ fi
+- /usr/bin/which prll_qer > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which prll_qer > /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "PRLL: Missing prll_qer." 1>&2
+ return 1
+@@ -51,14 +51,14 @@ function prll() {
+ local prll_unbuffer=yes
+ shift
+ else
+- /usr/bin/which prll_bfr > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which prll_bfr > /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "PRLL: Missing prll_bfr." 1>&2
+ return 1
+ fi
+ fi
+ if [[ -z $PRLL_NR_CPUS ]] ; then
+- /usr/bin/which grep > /dev/null
++ @GENTOO_PORTAGE_EPREFIX@/usr/bin/which grep > /dev/null
+ if [[ $? -ne 0 || ! -a /proc/cpuinfo ]] ; then
+ echo "PRLL: Environment variable PRLL_NR_CPUS is not set" 1>&2
+ echo "PRLL: and either the grep utility is missing or" 1>&2
diff --git a/sys-process/prll/metadata.xml b/sys-process/prll/metadata.xml
new file mode 100644
index 000000000000..633095222695
--- /dev/null
+++ b/sys-process/prll/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-process/prll/prll-0.6.2.ebuild b/sys-process/prll/prll-0.6.2.ebuild
new file mode 100644
index 000000000000..43777c8f145a
--- /dev/null
+++ b/sys-process/prll/prll-0.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/prll/prll-0.6.2.ebuild,v 1.1 2012/02/16 20:14:16 jlec Exp $
+
+EAPI=4
+
+inherit eutils prefix toolchain-funcs
+
+DESCRIPTION="A utility for parallelizing execution of shell functions"
+HOMEPAGE="http://prll.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_prepare() {
+ sed \
+ -e '/then sh/d' \
+ -e '/then zsh/d' \
+ -e '/then dash/d' \
+ -i tests/Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}_{qer,bfr}
+ insinto /etc/profile.d/
+ doins ${PN}.sh
+ dodoc AUTHORS README NEWS
+ doman ${PN}.1
+}