summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-06-18 03:15:01 +0000
committerJeroen Roovers <jer@gentoo.org>2008-06-18 03:15:01 +0000
commitf77b516455dc7a58eea4725b52a1be7df7c2a5ec (patch)
treedd54b63388a56967cb5e2ba4de2ed2cdf5fa6aaf /sys-process/at
parentamd64 stable, proxy commit for gentoofan23. bug #225589 (diff)
downloadgentoo-2-f77b516455dc7a58eea4725b52a1be7df7c2a5ec.tar.gz
gentoo-2-f77b516455dc7a58eea4725b52a1be7df7c2a5ec.tar.bz2
gentoo-2-f77b516455dc7a58eea4725b52a1be7df7c2a5ec.zip
Version bump (bug #227681).
(Portage version: 2.1.5.4)
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/ChangeLog10
-rw-r--r--sys-process/at/at-3.1.10.1.ebuild51
-rw-r--r--sys-process/at/files/at-3.1.10.1-Makefile.patch47
3 files changed, 106 insertions, 2 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index 6e81b90967fd..cd21adbb2794 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/at
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.10 2007/10/28 14:01:47 phreak Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.11 2008/06/18 03:15:00 jer Exp $
+
+*at-3.1.10.1 (18 Jun 2008)
+
+ 18 Jun 2008; Jeroen Roovers <jer@gentoo.org>
+ +files/at-3.1.10.1-Makefile.patch, +at-3.1.10.1.ebuild:
+ Version bump (bug #227681).
28 Oct 2007; Christian Heim <phreak@gentoo.org> at-3.1.8-r11.ebuild,
at-3.1.8-r12.ebuild:
diff --git a/sys-process/at/at-3.1.10.1.ebuild b/sys-process/at/at-3.1.10.1.ebuild
new file mode 100644
index 000000000000..ab6fc9bf50e1
--- /dev/null
+++ b/sys-process/at/at-3.1.10.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.1.ebuild,v 1.1 2008/06/18 03:15:00 jer Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/at_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/flex-2.5.4a"
+RDEPEND="virtual/mta
+ virtual/logger"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make install IROOT="${D}" || die
+ touch "${D}"/var/spool/at/at{jobs,spool}/.SEQ
+
+ newinitd "${FILESDIR}"/atd.rc6 atd
+ prepalldocs
+}
diff --git a/sys-process/at/files/at-3.1.10.1-Makefile.patch b/sys-process/at/files/at-3.1.10.1-Makefile.patch
new file mode 100644
index 000000000000..e0656e8725ca
--- /dev/null
+++ b/sys-process/at/files/at-3.1.10.1-Makefile.patch
@@ -0,0 +1,47 @@
+- install into Gentoo/FHS doc dir
+- respect Gentoo LDFLAGS
+- at is setuid, link with bind now
+- dont allow install to strip binaries
+
+--- Makefile.in. 2005-08-29 10:08:28.000000000 +0200
++++ Makefile.in 2008-06-17 05:18:36.000000000 +0200
+@@ -14,8 +14,11 @@
+ man1dir = $(mandir)/man1
+ man5dir = $(mandir)/man5
+ man8dir = $(mandir)/man8
+-docdir = $(prefix)/doc
+-atdocdir = $(docdir)/at
++ifndef PF
++PF = at-$(VERSION)
++endif
++docdir = $(prefix)/share/doc
++atdocdir = $(docdir)/$(PF)
+ etcdir = @ETCDIR@
+
+ DAEMON_USERNAME = @DAEMON_USERNAME@
+@@ -37,7 +40,7 @@
+ -DDAEMON_USERNAME=\"$(DAEMON_USERNAME)\" \
+ -DDAEMON_GROUPNAME=\"$(DAEMON_GROUPNAME)\" \
+ -DLFILE=\"$(LFILE)\" -Wall
+-LIBS = @LIBS@
++LIBS = @LIBS@ @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+ INSTALL = @INSTALL@
+ PAMLIB = @PAMLIB@
+@@ -99,14 +102,14 @@
+ chmod 600 $(IROOT)$(LFILE)
+ chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
+ test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(IROOT)$(etcdir)/
+- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 -s at $(IROOT)$(bindir)
++ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(IROOT)$(bindir)
+ $(LN_S) -f at $(IROOT)$(bindir)/atq
+ $(LN_S) -f at $(IROOT)$(bindir)/atrm
+ $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
+ $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
+ $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
+ $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
+- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
++ $(INSTALL) -g root -o root -m 755 atd $(IROOT)$(sbindir)
+ $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
+ $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
+ cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1