summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-07-14 06:22:38 +0000
committerChristian Heim <phreak@gentoo.org>2006-07-14 06:22:38 +0000
commita8457f61ad312592127db702eb6b7218e3adc43f (patch)
tree7ce36eb9b33d57f5855efdb9919c056f9d91118f /sys-power
parentAdd 2006.1 profiles and a little cleanup. (diff)
downloadgentoo-2-a8457f61ad312592127db702eb6b7218e3adc43f.tar.gz
gentoo-2-a8457f61ad312592127db702eb6b7218e3adc43f.tar.bz2
gentoo-2-a8457f61ad312592127db702eb6b7218e3adc43f.zip
Revision bump; hibernate-scripts is trying to echo to an read-only file; metadata.xml touchup
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/hibernate-script/ChangeLog10
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.93-r13
-rw-r--r--sys-power/hibernate-script/files/hibernate-script-1.93-last_result.patch13
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.93-r1.ebuild85
-rw-r--r--sys-power/hibernate-script/metadata.xml10
5 files changed, 115 insertions, 6 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 6cf137629be2..1632256cd754 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.25 2006/07/13 17:00:51 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.26 2006/07/14 06:22:38 phreak Exp $
+
+*hibernate-script-1.93-r1 (14 Jul 2006)
+
+ 14 Jul 2006; Christian Heim <phreak@gentoo.org>
+ +files/hibernate-script-1.93-last_result.patch, metadata.xml,
+ +hibernate-script-1.93-r1.ebuild:
+ Revision bump; hibernate-scripts is trying to echo to an read-only file;
+ metadata.xml touchup
*hibernate-script-1.93 (13 Jul 2006)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r1 b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r1
new file mode 100644
index 000000000000..422838b8f2d0
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r1
@@ -0,0 +1,3 @@
+MD5 903e30d67bcdf728f245a71b9ec412e2 hibernate-script-1.93.tar.gz 68644
+RMD160 bbb59d7ac5c7a26667cb00c5dd32224ad3eb8f01 hibernate-script-1.93.tar.gz 68644
+SHA256 8020d653cc09d1724f700e2b28cf5ce83eef3ffd287304141357eef2c22db366 hibernate-script-1.93.tar.gz 68644
diff --git a/sys-power/hibernate-script/files/hibernate-script-1.93-last_result.patch b/sys-power/hibernate-script/files/hibernate-script-1.93-last_result.patch
new file mode 100644
index 000000000000..7c7ca3e5cec5
--- /dev/null
+++ b/sys-power/hibernate-script/files/hibernate-script-1.93-last_result.patch
@@ -0,0 +1,13 @@
+Index: hibernate-script-1.93/scriptlets.d/suspend2
+===================================================================
+--- hibernate-script-1.93.orig/scriptlets.d/suspend2
++++ hibernate-script-1.93/scriptlets.d/suspend2
+@@ -525,7 +525,7 @@ CleanupDmesg() {
+ # PrintErrors. We can't just return it, because error codes may be > 255
+ DoSuspend() {
+ # Some versions of Software Suspend didn't clear this in certain cases:
+- echo 0 > $SWSUSP_ROOT/last_result
++ [ -w $SWSUSP_ROOT/last_result ] && echo 0 > $SWSUSP_ROOT/last_result
+
+ if [ -f $SWSUSP_ROOT/do_suspend ] ; then
+ echo > $SWSUSP_ROOT/do_suspend
diff --git a/sys-power/hibernate-script/hibernate-script-1.93-r1.ebuild b/sys-power/hibernate-script/hibernate-script-1.93-r1.ebuild
new file mode 100644
index 000000000000..05b6582f944e
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.93-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.93-r1.ebuild,v 1.1 2006/07/14 06:22:38 phreak Exp $
+
+inherit eutils
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # remove obsolete swsusp2_15 scriptlet
+ rm -f ${S}/scriptlets.d/swsusp2_15
+
+ epatch "${FILESDIR}"/${P}-last_result.patch
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ ebegin "Applying ${P}-common.conf.patch"
+ sed -i \
+ -e "s:^# \(Distribution\).*:\1 gentoo:" \
+ "${S}"/common.conf
+ eend $?
+
+ ebegin "Applying ${P}-suspend2.conf.patch"
+ sed -i \
+ -e "s:/usr/local::" \
+ "${S}"/suspend2.conf
+ eend $?
+}
+
+src_install() {
+ BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+ "${S}"/install.sh
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd ${S}/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should run the following command to invalidate"
+ einfo "suspend images on a clean boot."
+ einfo
+ einfo " # rc-update add hibernate-cleanup boot"
+ einfo
+ einfo "See /usr/share/doc/${PF}/README.gz for further details."
+ einfo
+ einfo "Please note that you will need to manually emerge any utilities"
+ einfo "(radeontool, vbetool, ...) enabled in the configuration files,"
+ einfo "should you wish to use them."
+ einfo
+ einfo "Starting with hibernate-script-1.90 the configuration files have"
+ einfo "been reordered and split into method specific files. Make sure you"
+ einfo "update your /etc/hibernate/ configuration files accordingly."
+ einfo
+}
diff --git a/sys-power/hibernate-script/metadata.xml b/sys-power/hibernate-script/metadata.xml
index 1321b92451f6..a257f6a97993 100644
--- a/sys-power/hibernate-script/metadata.xml
+++ b/sys-power/hibernate-script/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>mobile</herd>
-<maintainer>
- <email>phreak@gentoo.org</email>
- <name>Christian Heim</name>
-</maintainer>
+ <herd>mobile</herd>
+ <maintainer>
+ <email>phreak@gentoo.org</email>
+ <name>Christian Heim</name>
+ </maintainer>
</pkgmetadata>