summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-16 17:23:39 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-16 17:23:39 +0000
commit671099147536ed2ed2146419529b89b986ae8426 (patch)
tree507b1000355612fa1fef90a442e95c9a6f56ae69 /sys-power
parentRemoving old versions (diff)
downloadgentoo-2-671099147536ed2ed2146419529b89b986ae8426.tar.gz
gentoo-2-671099147536ed2ed2146419529b89b986ae8426.tar.bz2
gentoo-2-671099147536ed2ed2146419529b89b986ae8426.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog8
-rw-r--r--sys-power/acpid/acpid-1.0.10_p3.ebuild60
-rw-r--r--sys-power/acpid/acpid-2.0.5.ebuild51
-rw-r--r--sys-power/acpid/files/acpid-1.0.6-init.d39
-rw-r--r--sys-power/acpid/files/acpid-2.0.5-fix-example.patch21
5 files changed, 79 insertions, 100 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index f3b3c99e71eb..188ba358c494 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/acpid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.51 2010/05/19 20:36:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.52 2010/06/16 17:23:38 ssuominen Exp $
+
+*acpid-2.0.5 (16 Jun 2010)
+
+ 16 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> +acpid-2.0.5.ebuild,
+ +files/acpid-2.0.5-fix-example.patch:
+ Version bump.
19 May 2010; Raúl Porcel <armin76@gentoo.org> acpid-2.0.4-r2.ebuild:
ia64 stable wrt #318211
diff --git a/sys-power/acpid/acpid-1.0.10_p3.ebuild b/sys-power/acpid/acpid-1.0.10_p3.ebuild
deleted file mode 100644
index ac2d00554c65..000000000000
--- a/sys-power/acpid/acpid-1.0.10_p3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.10_p3.ebuild,v 1.3 2009/05/07 16:20:16 armin76 Exp $
-
-inherit toolchain-funcs
-
-MY_P="${P%_p*}-netlink${PV#*_p}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
-HOMEPAGE="http://acpid.sourceforge.net"
-SRC_URI="http://tedfelix.com/linux/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ia64 -ppc x86"
-IUSE=""
-
-DEPEND="sys-apps/sed"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- sed -i -e '/^CFLAGS /{s:=:+=:;s:-Werror::;s:-O2 -g::}' "${S}"/Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" INSTPREFIX="${D}" || die "emake failed"
-}
-
-src_install() {
- emake INSTPREFIX="${D}" install || die "emake install failed"
-
- exeinto /etc/acpi
- newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh || die
- insinto /etc/acpi/events
- newins "${FILESDIR}"/${PN}-1.0.4-default default || die
-
- dodoc README Changelog TODO || die
-
- newinitd "${FILESDIR}"/${PN}-1.0.6-init.d acpid || die
- newconfd "${FILESDIR}"/${PN}-1.0.6-conf.d acpid || die
-
- docinto examples
- dodoc samples/{acpi_handler.sh,sample.conf}
-
- docinto examples/battery
- dodoc samples/battery/*
-
- docinto examples/panasonic
- dodoc samples/panasonic/*
-}
-
-pkg_postinst() {
- echo
- einfo "You may wish to read the Gentoo Linux Power Management Guide,"
- einfo "which can be found online at:"
- einfo " http://www.gentoo.org/doc/en/power-management-guide.xml"
- echo
-}
diff --git a/sys-power/acpid/acpid-2.0.5.ebuild b/sys-power/acpid/acpid-2.0.5.ebuild
new file mode 100644
index 000000000000..4bab2f02c553
--- /dev/null
+++ b/sys-power/acpid/acpid-2.0.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-2.0.5.ebuild,v 1.1 2010/06/16 17:23:38 ssuominen Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://tedfelix.com/linux/acpid-netlink.html"
+SRC_URI="http://tedfelix.com/linux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 -ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.3.patch \
+ "${FILESDIR}"/${P}-fix-example.patch
+}
+
+src_compile() {
+ tc-export CC CPP
+ emake || die
+ emake -C kacpimon || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install || die
+
+ dobin kacpimon/kacpimon || die
+ newdoc kacpimon/README README.kacpimon
+
+ exeinto /etc/acpi
+ newexe "${FILESDIR}"/${PN}-1.0.6-default.sh default.sh || die
+ insinto /etc/acpi/events
+ newins "${FILESDIR}"/${PN}-1.0.4-default default || die
+
+ newinitd "${FILESDIR}"/${PN}-2.0.3-init.d acpid || die
+ newconfd "${FILESDIR}"/${PN}-1.0.6-conf.d acpid || die
+
+ prepalldocs
+}
+
+pkg_postinst() {
+ echo
+ elog "You may wish to read the Gentoo Linux Power Management Guide,"
+ elog "which can be found online at:"
+ elog "http://www.gentoo.org/doc/en/power-management-guide.xml"
+ echo
+}
diff --git a/sys-power/acpid/files/acpid-1.0.6-init.d b/sys-power/acpid/files/acpid-1.0.6-init.d
deleted file mode 100644
index aa169802c950..000000000000
--- a/sys-power/acpid/files/acpid-1.0.6-init.d
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/files/acpid-1.0.6-init.d,v 1.3 2009/01/19 04:48:49 vapier Exp $
-
-opts="reload"
-
-depend() {
- need localmount
- use logger
- before hald
-}
-
-checkconfig() {
- if [ ! -e /proc/acpi ] ; then
- eerror "ACPI support has not been compiled into the kernel"
- return 1
- fi
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting acpid"
- start-stop-daemon --start --quiet --exec /usr/sbin/acpid -- ${ACPID_OPTIONS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping acpid"
- start-stop-daemon --stop --exec /usr/sbin/acpid
- eend $?
-}
-
-reload() {
- ebegin "Reloading acpid configuration"
- start-stop-daemon --stop --oknodo --exec /usr/sbin/acpid --signal HUP
- eend $?
-}
diff --git a/sys-power/acpid/files/acpid-2.0.5-fix-example.patch b/sys-power/acpid/files/acpid-2.0.5-fix-example.patch
new file mode 100644
index 000000000000..831053ae7aee
--- /dev/null
+++ b/sys-power/acpid/files/acpid-2.0.5-fix-example.patch
@@ -0,0 +1,21 @@
+Fix example power button script, thanks to Timo Gurr.
+http://bugs.gentoo.org/253764, Comment #11.
+
+--- samples/powerbtn/powerbtn.sh
++++ samples/powerbtn/powerbtn.sh
+@@ -24,6 +24,15 @@
+ export XUSER=$user
+ }
+
++getXconsole() {
++ console=`fgconsole`;
++ displaynum=`ps t tty$console | sed -n -re 's,.*/X .*:([0-9]+).*,\1,p'`
++ if [ x"$displaynum" != x"" ]; then
++ export DISPLAY=":$displaynum"
++ getXuser
++ fi
++}
++
+ # Skip if we are just in the middle of resuming.
+ test -f /var/lock/acpisleep && exit 0
+