summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-03-20 22:58:28 +0000
committerMichael Weber <xmw@gentoo.org>2014-03-20 22:58:28 +0000
commit0aa85306acbca05e3e3965fb662daeafb470bbbd (patch)
tree9d6d8b778bcc4cc8d12d969bc10f093bf5cdd7e5 /sys-power
parentVersion bump, remove old. (diff)
downloadgentoo-2-0aa85306acbca05e3e3965fb662daeafb470bbbd.tar.gz
gentoo-2-0aa85306acbca05e3e3965fb662daeafb470bbbd.tar.bz2
gentoo-2-0aa85306acbca05e3e3965fb662daeafb470bbbd.zip
fix patch file.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/phc-intel/ChangeLog11
-rw-r--r--sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space-r1.patch (renamed from sys-power/phc-intel/files/phc-intel-pack-rev11-trailing-space.patch)308
-rw-r--r--sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space.patch54
-rw-r--r--sys-power/phc-intel/phc-intel-0.3.2.12.11.ebuild62
-rw-r--r--sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild7
5 files changed, 40 insertions, 402 deletions
diff --git a/sys-power/phc-intel/ChangeLog b/sys-power/phc-intel/ChangeLog
index 352ce869c103..c868a474576d 100644
--- a/sys-power/phc-intel/ChangeLog
+++ b/sys-power/phc-intel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/phc-intel
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/ChangeLog,v 1.14 2013/12/02 10:21:10 xmw Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/ChangeLog,v 1.15 2014/03/20 22:58:28 xmw Exp $
+
+ 20 Mar 2014; Michael Weber <xmw@gentoo.org>
+ +files/phc-intel-pack-rev12-trailing-space-r1.patch,
+ -files/phc-intel-pack-rev11-trailing-space.patch,
+ -files/phc-intel-pack-rev12-trailing-space.patch,
+ -phc-intel-0.3.2.12.11.ebuild, phc-intel-0.3.2.12.12.ebuild:
+ fix patch file.
*phc-intel-0.3.2.12.12 (02 Dec 2013)
diff --git a/sys-power/phc-intel/files/phc-intel-pack-rev11-trailing-space.patch b/sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space-r1.patch
index 303e8f1cd723..d6b9d4a2f329 100644
--- a/sys-power/phc-intel/files/phc-intel-pack-rev11-trailing-space.patch
+++ b/sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space-r1.patch
@@ -919,108 +919,6 @@ Signed-off-by: Michael Weber <xmw@gentoo.org>
+ count += sprintf(&buf[count], "\n");
+
+ return count;
---- phc-intel-pack-rev11/inc/3.0/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.0/linux-phc-0.3.2.patch
-@@ -71,7 +71,7 @@
- }
-
- return 0;
--@@ -714,12 +726,474 @@
-+@@ -714,12 +726,479 @@
- data->resume = 1;
-
- return 0;
-@@ -152,6 +152,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -181,6 +182,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -207,6 +209,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", fid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -235,6 +238,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -266,6 +270,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
---- phc-intel-pack-rev11/inc/3.1/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.1/linux-phc-0.3.2.patch
-@@ -71,7 +71,7 @@
- }
-
- return 0;
--@@ -714,12 +726,474 @@
-+@@ -714,12 +726,479 @@
- data->resume = 1;
-
- return 0;
-@@ -152,6 +152,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -181,6 +182,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -207,6 +209,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", fid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -235,6 +238,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -266,6 +270,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
--- phc-intel-pack-rev11/inc/3.10/linux-phc-0.3.2.patch
+++ phc-intel-pack-rev11/inc/3.10/linux-phc-0.3.2.patch
@@ -120,7 +120,7 @@
@@ -1123,159 +1021,6 @@ Signed-off-by: Michael Weber <xmw@gentoo.org>
+ count += sprintf(&buf[count], "\n");
+
+ return count;
---- phc-intel-pack-rev11/inc/3.2/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.2/linux-phc-0.3.2.patch
-@@ -71,7 +71,7 @@
- }
-
- return 0;
--@@ -714,12 +726,474 @@
-+@@ -714,12 +726,479 @@
- data->resume = 1;
-
- return 0;
-@@ -152,6 +152,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -181,6 +182,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -207,6 +209,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", fid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -235,6 +238,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -266,6 +270,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
---- phc-intel-pack-rev11/inc/3.3/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.3/linux-phc-0.3.2.patch
-@@ -71,7 +71,7 @@
- }
-
- return 0;
--@@ -714,12 +726,474 @@
-+@@ -714,12 +726,479 @@
- data->resume = 1;
-
- return 0;
-@@ -152,6 +152,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -181,6 +182,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -207,6 +209,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", fid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -235,6 +238,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -266,6 +270,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
---- phc-intel-pack-rev11/inc/3.4/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.4/linux-phc-0.3.2.patch
-@@ -71,7 +71,7 @@
- }
-
- return 0;
--@@ -714,12 +726,474 @@
-+@@ -714,12 +726,479 @@
- data->resume = 1;
-
- return 0;
-@@ -152,6 +152,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -181,6 +182,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -207,6 +209,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u ", fid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -235,6 +238,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -266,6 +270,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
--- phc-intel-pack-rev11/inc/3.5/linux-phc-0.3.2.patch
+++ phc-intel-pack-rev11/inc/3.5/linux-phc-0.3.2.patch
@@ -71,7 +71,7 @@
@@ -1327,8 +1072,8 @@ Signed-off-by: Michael Weber <xmw@gentoo.org>
+ count += sprintf(&buf[count], "\n");
+
+ return count;
---- phc-intel-pack-rev11/inc/3.7/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.7/linux-phc-0.3.2.patch
+--- phc-intel-pack-rev11/inc/3.7.5/linux-phc-0.3.2.patch
++++ phc-intel-pack-rev11/inc/3.7.5/linux-phc-0.3.2.patch
@@ -120,7 +120,7 @@
if (boot_cpu_has(X86_FEATURE_CPB) || boot_cpu_has(X86_FEATURE_IDA)) {
msrs = msrs_alloc();
@@ -1378,14 +1123,14 @@ Signed-off-by: Michael Weber <xmw@gentoo.org>
+ count += sprintf(&buf[count], "\n");
+
+ return count;
---- phc-intel-pack-rev11/inc/3.7.5/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.7.5/linux-phc-0.3.2.patch
+--- phc-intel-pack-rev11/inc/3.9/linux-phc-0.3.2.patch
++++ phc-intel-pack-rev11/inc/3.9/linux-phc-0.3.2.patch
@@ -120,7 +120,7 @@
if (boot_cpu_has(X86_FEATURE_CPB) || boot_cpu_has(X86_FEATURE_IDA)) {
msrs = msrs_alloc();
--@@ -966,10 +968,484 @@
-+@@ -966,10 +968,489 @@
+-@@ -970,10 +972,484 @@
++@@ -970,10 +972,489 @@
msrs_free(msrs);
msrs = NULL;
}
@@ -1429,51 +1174,54 @@ Signed-off-by: Michael Weber <xmw@gentoo.org>
+ count += sprintf(&buf[count], "\n");
+
+ return count;
---- phc-intel-pack-rev11/inc/3.9/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev11/inc/3.9/linux-phc-0.3.2.patch
-@@ -120,7 +120,7 @@
+Remove trailing white spaces from /proc output.
+
+Signed-off-by: Michael Weber <xmw@gentoo.org>
+--- phc-intel-pack-rev12/inc/3.12/linux-phc-0.3.2.patch
++++ phc-intel-pack-rev12/inc/3.12/linux-phc-0.3.2.patch
+@@ -97,7 +97,7 @@
+ static void __init acpi_cpufreq_boost_init(void)
+ {
if (boot_cpu_has(X86_FEATURE_CPB) || boot_cpu_has(X86_FEATURE_IDA)) {
- msrs = msrs_alloc();
-
--@@ -970,10 +972,484 @@
-+@@ -970,10 +972,489 @@
- msrs_free(msrs);
- msrs = NULL;
+-@@ -982,6 +983,480 @@
++@@ -982,6 +983,485 @@
}
-@@ -198,6 +198,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
+ }
+
+@@ -173,6 +173,7 @@
+ + vid = extract_vid_from_control(acpi_data->states[freq_table[i].driver_data].control);
+ count += sprintf(&buf[count], "%u ", vid);
+ }
++ if (count) count--;
+ count += sprintf(&buf[count], "\n");
+
+ return count;
-@@ -227,6 +228,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
+@@ -202,6 +203,7 @@
+ + vid = extract_vid_from_control(data->original_controls[freq_table[i].driver_data]);
+ count += sprintf(&buf[count], "%u ", vid);
+ }
++ if (count) count--;
+ count += sprintf(&buf[count], "\n");
+
+ return count;
-@@ -253,6 +255,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].index].control);
+@@ -228,6 +230,7 @@
+ + fid = extract_fid_from_control(acpi_data->states[freq_table[i].driver_data].control);
+ count += sprintf(&buf[count], "%u ", fid);
+ }
++ if (count) count--;
+ count += sprintf(&buf[count], "\n");
+
+ return count;
-@@ -281,6 +284,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].index].control);
+@@ -256,6 +259,7 @@
+ + vid = extract_vid_from_control(acpi_data->states[freq_table[i].driver_data].control);
+ count += sprintf(&buf[count], "%u:%u ", fid, vid);
+ }
++ if (count) count--;
+ count += sprintf(&buf[count], "\n");
+
+ return count;
-@@ -312,6 +316,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].index]);
+@@ -287,6 +291,7 @@
+ + vid = extract_vid_from_control(data->original_controls[freq_table[i].driver_data]);
+ count += sprintf(&buf[count], "%u:%u ", fid, vid);
+ }
++ if (count) count--;
diff --git a/sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space.patch b/sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space.patch
deleted file mode 100644
index 79d60a19e9fa..000000000000
--- a/sys-power/phc-intel/files/phc-intel-pack-rev12-trailing-space.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-Remove trailing white spaces from /proc output.
-
-Signed-off-by: Michael Weber <xmw@gentoo.org>
---- phc-intel-pack-rev12/inc/3.12/linux-phc-0.3.2.patch
-+++ phc-intel-pack-rev12/inc/3.12/linux-phc-0.3.2.patch
-@@ -97,7 +97,7 @@
- static void __init acpi_cpufreq_boost_init(void)
- {
- if (boot_cpu_has(X86_FEATURE_CPB) || boot_cpu_has(X86_FEATURE_IDA)) {
--@@ -982,6 +983,480 @@
-+@@ -982,6 +983,485 @@
- }
- }
-
-@@ -173,6 +173,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].driver_data].control);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -202,6 +203,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].driver_data]);
- + count += sprintf(&buf[count], "%u ", vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -228,6 +230,7 @@
- + fid = extract_fid_from_control(acpi_data->states[freq_table[i].driver_data].control);
- + count += sprintf(&buf[count], "%u ", fid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -256,6 +259,7 @@
- + vid = extract_vid_from_control(acpi_data->states[freq_table[i].driver_data].control);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
-@@ -287,6 +291,7 @@
- + vid = extract_vid_from_control(data->original_controls[freq_table[i].driver_data]);
- + count += sprintf(&buf[count], "%u:%u ", fid, vid);
- + }
-++ if (count) count--;
- + count += sprintf(&buf[count], "\n");
- +
- + return count;
diff --git a/sys-power/phc-intel/phc-intel-0.3.2.12.11.ebuild b/sys-power/phc-intel/phc-intel-0.3.2.12.11.ebuild
deleted file mode 100644
index 7197f522195f..000000000000
--- a/sys-power/phc-intel/phc-intel-0.3.2.12.11.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/phc-intel-0.3.2.12.11.ebuild,v 1.2 2013/09/05 22:38:45 xmw Exp $
-
-EAPI=5
-
-inherit linux-info linux-mod eutils
-
-DESCRIPTION="Processor Hardware Control for Intel CPUs"
-HOMEPAGE="http://www.linux-phc.org/
- http://www.linux-phc.org/forum/viewtopic.php?f=7&t=267"
-#no automatic filenames here, sorry
-SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=147 -> phc-intel-pack-rev11.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-CONFIG_CHECK="~!X86_ACPI_CPUFREQ"
-ERROR_X86_ACPI_CPUFREQ="CONFIG_X86_ACPI_CPUFREQ has to be configured to Module to enable the replacement of acpi-cpufreq with phc-intel."
-
-MODULE_NAMES="phc-intel(misc:)"
-BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
-BUILD_TARGETS="all"
-
-S=${WORKDIR}/${A/.tar.bz2}
-
-pkg_setup() {
- if kernel_is lt 2 6 27 ; then
- eerror "Your kernel version is no longer supported by this version of ${PN}."
- eerror "Please use a previous version of ${PN} or a newer kernel."
- die
- fi
- if kernel_is gt 3 11 ; then
- eerror "Your kernel version is not yet supported by this version of ${PN}."
- eerror "Please use a newer version of ${PN} or an older kernel."
- die
- fi
- linux-mod_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/phc-intel-pack-rev11-trailing-space.patch
-
- sed -e '/^all:/s:prepare::' \
- -i Makefile || die
-
- local my_sub=arch/x86/kernel/cpu
- if kernel_is gt 2 6 39 ; then
- my_sub=drivers
- fi
- cp -v "${KERNEL_DIR}"/${my_sub}/cpufreq/{acpi-cpufreq.c,mperf.h} . || die
-
- if kernel_is lt 3 0 ; then
- epatch inc/${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}/linux-phc-0.3.2.patch
- else
- epatch inc/${KV_MAJOR}.${KV_MINOR}/linux-phc-0.3.2.patch
- fi
-
- mv acpi-cpufreq.c phc-intel.c || die
-}
diff --git a/sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild b/sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild
index 1ae9cf9c8496..8f5c37758749 100644
--- a/sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild
+++ b/sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild,v 1.1 2013/12/02 10:21:10 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-intel/phc-intel-0.3.2.12.12.ebuild,v 1.2 2014/03/20 22:58:28 xmw Exp $
EAPI=5
@@ -41,8 +41,7 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/phc-intel-pack-rev11-trailing-space.patch
- epatch "${FILESDIR}"/phc-intel-pack-rev12-trailing-space.patch
+ epatch "${FILESDIR}"/phc-intel-pack-rev12-trailing-space-r1.patch
sed -e '/^all:/s:prepare::' \
-i Makefile || die