summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-15 19:15:53 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-15 19:15:53 +0000
commit04ba108a1f9b69901812f19aa5c1ab035c22c75a (patch)
tree6da36ceeac54ba8d25a6caacba25b4a76ca2ea80 /sys-power/acpid/acpid-1.0.2-r2.ebuild
parentKeywording for ~sparc - makes manifest signing so much nicer. Bug 85376 (diff)
downloadgentoo-2-04ba108a1f9b69901812f19aa5c1ab035c22c75a.tar.gz
gentoo-2-04ba108a1f9b69901812f19aa5c1ab035c22c75a.tar.bz2
gentoo-2-04ba108a1f9b69901812f19aa5c1ab035c22c75a.zip
Moved from sys-apps/acpid to sys-power/acpid.
Diffstat (limited to 'sys-power/acpid/acpid-1.0.2-r2.ebuild')
-rw-r--r--sys-power/acpid/acpid-1.0.2-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-power/acpid/acpid-1.0.2-r2.ebuild b/sys-power/acpid/acpid-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..81c45885a003
--- /dev/null
+++ b/sys-power/acpid/acpid-1.0.2-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.2-r2.ebuild,v 1.1 2005/03/15 19:15:53 ciaranm Exp $
+
+inherit eutils
+
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://acpid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc alpha amd64 ia64"
+IUSE=""
+
+# We need the patched kernel with latest ACPI code, or else it will
+# be broken. Hopefully it will be merge into release kernel soon.
+DEPEND="virtual/libc
+ virtual/linux-sources"
+
+src_compile() {
+ # Fix bug # 22238 (default.sh broken)
+ cd debian && epatch ${FILESDIR}/default.sh-gentoo.patch && cd ..
+
+ # DO NOT COMPILE WITH OPTIMISATIONS.
+ # That is a note to the devs. IF you are a user, go ahead and optimise
+ # if you want, but we won't support bugs associated with that"
+ make INSTPREFIX=${D} || die
+}
+
+src_install() {
+ make INSTPREFIX=${D} install || die
+
+ dodir /etc/acpi/events
+ exeinto /etc/acpi
+ doexe debian/default.sh
+ insinto /etc/acpi/events
+ doins debian/default
+
+ dodoc README Changelog
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/acpid.rc6 acpid
+}
+
+pkg_postinst() {
+ echo
+ einfo "You may wish to read the Gentoo Linux Power Management Guide,"
+ einfo "which can be found online at:"
+ einfo " http://www.gentoo.org/doc/en/power-management-guide.xml"
+ echo
+}