summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-03 16:12:52 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-03 16:12:52 +0000
commitfe4fb429cc5fce90dff8056fe3677e1de94d427b (patch)
tree6292208974c3a16b89264915f07feb9eaaddda3b /sys-libs
parentClean up. (diff)
downloadgentoo-2-fe4fb429cc5fce90dff8056fe3677e1de94d427b.tar.gz
gentoo-2-fe4fb429cc5fce90dff8056fe3677e1de94d427b.tar.bz2
gentoo-2-fe4fb429cc5fce90dff8056fe3677e1de94d427b.zip
Version bump #414453 by Samuli Suominen.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib/ChangeLog7
-rw-r--r--sys-libs/zlib/zlib-1.2.7.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index a86b6a0a8251..254a40e85cb9 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.100 2012/05/01 19:24:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.101 2012/05/03 16:12:52 vapier Exp $
+
+*zlib-1.2.7 (03 May 2012)
+
+ 03 May 2012; Mike Frysinger <vapier@gentoo.org> +zlib-1.2.7.ebuild:
+ Version bump #414453 by Samuli Suominen.
01 May 2012; Jeroen Roovers <jer@gentoo.org> zlib-1.2.5.1-r2.ebuild:
Stable for HPPA (bug #384483).
diff --git a/sys-libs/zlib/zlib-1.2.7.ebuild b/sys-libs/zlib/zlib-1.2.7.ebuild
new file mode 100644
index 000000000000..e9f39c47b120
--- /dev/null
+++ b/sys-libs/zlib/zlib-1.2.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.7.ebuild,v 1.1 2012/05/03 16:12:52 vapier Exp $
+
+AUTOTOOLS_AUTO_DEPEND="no"
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Standard (de)compression library"
+HOMEPAGE="http://www.zlib.net/"
+SRC_URI="http://zlib.net/${P}.tar.gz
+ http://www.gzip.org/zlib/${P}.tar.gz
+ http://www.zlib.net/current/beta/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="minizip static-libs"
+
+DEPEND="minizip? ( ${AUTOTOOLS_DEPEND} )"
+RDEPEND="!<dev-libs/libxml2-2.7.7" #309623
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use minizip ; then
+ cd contrib/minizip
+ eautoreconf
+ fi
+}
+
+echoit() { echo "$@"; "$@"; }
+src_compile() {
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ emake -f win32/Makefile.gcc STRIP=true PREFIX=${CHOST}- || die
+ sed \
+ -e 's|@prefix@|/usr|g' \
+ -e 's|@exec_prefix@|${prefix}|g' \
+ -e 's|@libdir@|${exec_prefix}/'$(get_libdir)'|g' \
+ -e 's|@sharedlibdir@|${exec_prefix}/'$(get_libdir)'|g' \
+ -e 's|@includedir@|${prefix}/include|g' \
+ -e 's|@VERSION@|'${PV}'|g' \
+ zlib.pc.in > zlib.pc || die
+ ;;
+ *) # not an autoconf script, so can't use econf
+ echoit ./configure --shared --prefix=/usr --libdir=/usr/$(get_libdir) || die
+ emake || die
+ ;;
+ esac
+ if use minizip ; then
+ cd contrib/minizip
+ econf $(use_enable static-libs static)
+ emake || die
+ fi
+}
+
+sed_macros() {
+ # clean up namespace a little #383179
+ # we do it here so we only have to tweak 2 files
+ sed -i -r 's:\<(O[FN])\>:_Z_\1:g' "$@" || die
+}
+src_install() {
+ case ${CHOST} in
+ *-mingw*|mingw*)
+ emake -f win32/Makefile.gcc install \
+ BINARY_PATH="${D}/usr/bin" \
+ LIBRARY_PATH="${D}/usr/$(get_libdir)" \
+ INCLUDE_PATH="${D}/usr/include" \
+ SHARED_MODE=1 \
+ || die
+ insinto /usr/share/pkgconfig
+ doins zlib.pc || die
+ ;;
+
+ *)
+ emake install DESTDIR="${D}" LDCONFIG=: || die
+ gen_usr_ldscript -a z
+ sed_macros "${D}"/usr/include/*.h
+ ;;
+ esac
+
+ dodoc FAQ README ChangeLog doc/*.txt
+
+ if use minizip ; then
+ cd contrib/minizip
+ emake install DESTDIR="${D}" || die
+ sed_macros "${D}"/usr/include/minizip/*.h
+ dodoc *.txt
+ fi
+
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/*.{a,la}
+}