summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-27 22:14:18 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-27 22:14:18 +0000
commitf9bcee8ebb10e148e186334e908c422001806dbe (patch)
tree066dd4cb4ad5ed04da5a39fc1288def1e1bb048f /sys-libs
parentold (diff)
downloadgentoo-2-f9bcee8ebb10e148e186334e908c422001806dbe.tar.gz
gentoo-2-f9bcee8ebb10e148e186334e908c422001806dbe.tar.bz2
gentoo-2-f9bcee8ebb10e148e186334e908c422001806dbe.zip
old
(Portage version: 2.2_pre5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ss/ss-1.40.3.ebuild73
-rw-r--r--sys-libs/ss/ss-1.40.5.ebuild72
2 files changed, 0 insertions, 145 deletions
diff --git a/sys-libs/ss/ss-1.40.3.ebuild b/sys-libs/ss/ss-1.40.3.ebuild
deleted file mode 100644
index 3b8911442125..000000000000
--- a/sys-libs/ss/ss-1.40.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.3.ebuild,v 1.10 2008/01/01 12:36:10 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Subsystem command parsing library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="~sys-libs/com_err-${PV}"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-env_setup() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
- epatch "${FILESDIR}"/${PN}-1.40.3-check.patch #201762
-}
-
-src_compile() {
- env_setup
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable nls) \
- || die
- emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
-}
-
-src_test() {
- env_setup
-
- ln -s $(${CC} -print-file-name=libcom_err.so) lib/libcom_err.so
- emake -j1 -C lib/ss check || die "make check failed"
-}
-
-src_install() {
- env_setup
-
- dodir /usr/share/man/man1
- make -C lib/ss DESTDIR="${D}" install || die
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
- dolib.a lib/libss.a || die "dolib.a"
- gen_usr_ldscript libss.so
-}
diff --git a/sys-libs/ss/ss-1.40.5.ebuild b/sys-libs/ss/ss-1.40.5.ebuild
deleted file mode 100644
index 49c0847fbe80..000000000000
--- a/sys-libs/ss/ss-1.40.5.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.5.ebuild,v 1.1 2008/01/28 06:29:23 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="Subsystem command parsing library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="~sys-libs/com_err-${PV}"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-env_setup() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-}
-
-src_compile() {
- env_setup
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable nls) \
- || die
- emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
-}
-
-src_test() {
- env_setup
-
- ln -s $(${CC} -print-file-name=libcom_err.so) lib/libcom_err.so
- emake -j1 -C lib/ss check || die "make check failed"
-}
-
-src_install() {
- env_setup
-
- dodir /usr/share/man/man1
- make -C lib/ss DESTDIR="${D}" install || die
-
- # Move shared libraries to /lib/, install static libraries to /usr/lib/,
- # and install linker scripts to /usr/lib/.
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
- dolib.a lib/libss.a || die "dolib.a"
- gen_usr_ldscript libss.so
-}