summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-23 00:55:03 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-23 00:55:03 +0000
commitb6482de8d2d4bfc143ef95ecace47addff1452e0 (patch)
tree1fa0db3935cc94fb900632572343b98eb2157a07 /sys-libs
parentSparc stable, Bug #259919. (diff)
downloadgentoo-2-b6482de8d2d4bfc143ef95ecace47addff1452e0.tar.gz
gentoo-2-b6482de8d2d4bfc143ef95ecace47addff1452e0.tar.bz2
gentoo-2-b6482de8d2d4bfc143ef95ecace47addff1452e0.zip
old
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/readline-4.3-r5.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/sys-libs/readline/readline-4.3-r5.ebuild b/sys-libs/readline/readline-4.3-r5.ebuild
deleted file mode 100644
index 54dc3a8e8d11..000000000000
--- a/sys-libs/readline/readline-4.3-r5.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.3-r5.ebuild,v 1.30 2008/11/23 18:27:39 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-# Official patches
-PLEVEL="x001 x002 x003 x004 x005"
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/readline/${P}.tar.gz
- ${PLEVEL//x/mirror://gnu/${PN}/${PN}-${PV}-patches/${PN}${PV/\.}-}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-DEPEND=">=app-shells/bash-2.05b-r2
- >=sys-libs/ncurses-5.2-r2"
-
-src_unpack() {
- unpack ${P}.tar.gz
-
- cd "${S}"
- for x in ${PLEVEL//x} ; do
- epatch "${DISTDIR}"/${PN}${PV/\.}-${x}
- done
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-}
-
-src_compile() {
- # the --libdir= is needed because if lib64 is a directory, it will default
- # to using that... even if CONF_LIBDIR isnt set or we're using a version
- # of portage without CONF_LIBDIR support.
- econf --with-curses --libdir=/usr/$(get_libdir) || die
-
- emake || die
- cd shlib
- emake || die
-}
-
-src_install() {
- # portage 2.0.50's einstall causes sandbox violations if lib64 is a
- # directory, since readline's configure automatically sets libdir for you.
- make DESTDIR="${D}" install || die
- cd "${S}"/shlib
- make DESTDIR="${D}" install || die
-
- cd "${S}"
-
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- rm -f "${D}"/$(get_libdir)/*.old
- # bug #4411
- gen_usr_ldscript libreadline.so
- gen_usr_ldscript libhistory.so
- # end bug #4411
- dosym libhistory.so.${PV/a/} /$(get_libdir)/libhistory.so
- dosym libreadline.so.${PV/a/} /$(get_libdir)/libreadline.so
- # Needed because make install uses ${D} for the link
- dosym libhistory.so.${PV/a/} /$(get_libdir)/libhistory.so.4
- dosym libreadline.so.${PV/a/} /$(get_libdir)/libreadline.so.4
- chmod 755 "${D}"/$(get_libdir)/*.${PV/a/}
-
- dodoc CHANGELOG CHANGES README USAGE
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.4 #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.4
-}