summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-29 10:14:55 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-29 10:14:55 +0000
commita87bacbf5c8b42754d829d4ebba92a21b648023b (patch)
treece378906c50eb0c36f2635fdd7f2ae73b22c8fe1 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-a87bacbf5c8b42754d829d4ebba92a21b648023b.tar.gz
gentoo-2-a87bacbf5c8b42754d829d4ebba92a21b648023b.tar.bz2
gentoo-2-a87bacbf5c8b42754d829d4ebba92a21b648023b.zip
Add missing patch and add a new one from upstream, thanks to 'galtgendo' in bug #141990.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/slang/ChangeLog8
-rw-r--r--sys-libs/slang/files/slang-2.0.6-foreground.patch36
-rw-r--r--sys-libs/slang/files/slang-2.0.6-slsh-libs.patch11
-rw-r--r--sys-libs/slang/slang-2.0.6.ebuild7
4 files changed, 58 insertions, 4 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 637553f41998..315efbb572a4 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.53 2006/07/28 00:05:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.54 2006/07/29 10:14:55 flameeyes Exp $
+
+ 29 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/slang-2.0.6-foreground.patch, +files/slang-2.0.6-slsh-libs.patch,
+ slang-2.0.6.ebuild:
+ Add missing patch and add a new one from upstream, thanks to 'galtgendo' in
+ bug #141990.
*slang-2.0.6 (28 Jul 2006)
diff --git a/sys-libs/slang/files/slang-2.0.6-foreground.patch b/sys-libs/slang/files/slang-2.0.6-foreground.patch
new file mode 100644
index 000000000000..c9c5bbb0c95b
--- /dev/null
+++ b/sys-libs/slang/files/slang-2.0.6-foreground.patch
@@ -0,0 +1,36 @@
+--- src/sldisply.c.old 2006-02-05 21:47:31.000000000 +0100
++++ src/sldisply.c 2006-07-28 09:41:34.000000000 +0200
+@@ -158,7 +158,7 @@
+ static Brush_Info_Type Brush_Table[JMAX_COLORS];
+
+ /* 0 if least significant bit is blue, not red */
+-/* static int Is_Fg_BGR = 0; */
++static int Is_Fg_BGR = 0;
+ static int Is_Bg_BGR = 0;
+ #define COLOR_ARG(color, is_bgr) ((is_bgr) ? RGB_to_BGR[(color)&0x7] : (color))
+ static SLCONST int RGB_to_BGR[] =
+@@ -1394,7 +1394,7 @@
+ if (fg0 == SLSMG_COLOR_DEFAULT)
+ tt_write_string (Default_Color_Fg_Str);
+ else
+- tt_printf (Color_Fg_Str, COLOR_ARG(fg0, Is_Bg_BGR), 0);
++ tt_printf (Color_Fg_Str, COLOR_ARG(fg0, Is_Fg_BGR), 0);
+ }
+
+ if (unknown_attributes
+@@ -2554,13 +2554,13 @@
+ if (Color_Fg_Str == NULL)
+ {
+ Color_Fg_Str = SLtt_tgetstr ("Sf"); /* setf */
+- /* Is_Fg_BGR = (Color_Fg_Str != NULL); */
++ Is_Fg_BGR = (Color_Fg_Str != NULL);
+ }
+ Color_Bg_Str = SLtt_tgetstr ("AB"); /* ANSI setbf */
+ if (Color_Bg_Str == NULL)
+ {
+ Color_Bg_Str = SLtt_tgetstr ("Sb"); /* setb */
+- /* Is_Fg_BGR = (Color_Bg_Str != NULL); */
++ Is_Bg_BGR = (Color_Bg_Str != NULL);
+ }
+
+ if ((Max_Terminfo_Colors = SLtt_tgetnum ("Co")) < 0)
diff --git a/sys-libs/slang/files/slang-2.0.6-slsh-libs.patch b/sys-libs/slang/files/slang-2.0.6-slsh-libs.patch
new file mode 100644
index 000000000000..676cf46ee46b
--- /dev/null
+++ b/sys-libs/slang/files/slang-2.0.6-slsh-libs.patch
@@ -0,0 +1,11 @@
+--- ./slsh/Makefile.in.old 2006-07-15 22:02:01.000000000 -0700
++++ ./slsh/Makefile.in 2006-07-15 22:02:21.000000000 -0700
+@@ -69,7 +69,7 @@
+ slsh_exe: slsh.o readline.o
+ $(CC) slsh.o readline.o -o slsh_exe $(LDFLAGS) $(SRC_LIBS)
+ slsh: slsh.o readline.o
+- $(CC) slsh.o readline.o -o slsh $(LDFLAGS) $(INST_LIBS)
++ $(CC) slsh.o readline.o -o slsh $(LDFLAGS) $(SRC_LIBS)
+ slsh.o: slsh.c slsh.h config.h
+ $(CC) -c $(CFLAGS) $(SLANG_SRCINC) $(DEFS) slsh.c
+ readline.o: readline.c slsh.h config.h
diff --git a/sys-libs/slang/slang-2.0.6.ebuild b/sys-libs/slang/slang-2.0.6.ebuild
index bb7eb548f5ea..3a4778982bc3 100644
--- a/sys-libs/slang/slang-2.0.6.ebuild
+++ b/sys-libs/slang/slang-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.0.6.ebuild,v 1.1 2006/07/28 00:05:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.0.6.ebuild,v 1.2 2006/07/29 10:14:55 flameeyes Exp $
inherit eutils
@@ -26,7 +26,8 @@ src_unpack() {
-e '/^SLANG_INST_LIB/s/-L@libdir@/-L@OBJDIR@ -L@ELFDIR@ -L@libdir@/' \
slsh/Makefile.in || die
- epatch "${FILESDIR}"/${PN}-2.0.6-slsh-libs.patch
+ epatch "${FILESDIR}/${PN}-2.0.6-slsh-libs.patch"
+ epatch "${FILESDIR}/${PN}-2.0.6-foreground.patch"
grep -rlZ -- '-lslang\>' "${S}" | xargs -0 sed -i -e 's:-lslang:-lslang-2:g'
}
@@ -42,7 +43,7 @@ src_compile() {
}
src_install() {
- emake THIS_LIB="slang-2" DESTDIR="${D}" install install-elf || die "make install failed"
+ emake -j1 THIS_LIB="slang-2" DESTDIR="${D}" install install-elf || die "make install failed"
# Move headers around
dodir /usr/include/slang-2