summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-03 08:37:23 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-03 08:37:23 +0000
commita7b0cdcc7856d70a2be1af6f9befc26b8f271105 (patch)
tree4bb6349dfca35ffceedc4231b3c8cadb56c7ea54 /sys-libs
parentVersion Bump. (diff)
downloadgentoo-2-a7b0cdcc7856d70a2be1af6f9befc26b8f271105.tar.gz
gentoo-2-a7b0cdcc7856d70a2be1af6f9befc26b8f271105.tar.bz2
gentoo-2-a7b0cdcc7856d70a2be1af6f9befc26b8f271105.zip
old
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch19
-rw-r--r--sys-libs/timezone-data/timezone-data-2009j.ebuild106
-rw-r--r--sys-libs/timezone-data/timezone-data-2009k.ebuild106
-rw-r--r--sys-libs/timezone-data/timezone-data-2009l.ebuild106
-rw-r--r--sys-libs/timezone-data/timezone-data-2009n-r1.ebuild107
-rw-r--r--sys-libs/timezone-data/timezone-data-2009n.ebuild106
-rw-r--r--sys-libs/timezone-data/timezone-data-2009o.ebuild107
7 files changed, 0 insertions, 657 deletions
diff --git a/sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch b/sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch
deleted file mode 100644
index 60065d82a4a1..000000000000
--- a/sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch
+++ /dev/null
@@ -1,19 +0,0 @@
---- tzdata/southamerica
-+++ tzdata/southamerica
-@@ -215,9 +215,14 @@
- # http://www.jujuy.gov.ar/index2/partes_prensa/18_10_08/235-181008.doc
- # </a>
-
-+# Margarita Manterola:
-+# Same as always, Argentina's government just decided to change its mind
-+# regarding DST, 2 days in advance.
-+# http://www.lanacion.com.ar/nota.asp?nota_id=1186963&pid=7542694&toi=6275
-+
- Rule Arg 2007 only - Dec 30 0:00 1:00 S
--Rule Arg 2008 max - Mar Sun>=15 0:00 0 -
--Rule Arg 2008 max - Oct Sun>=15 0:00 1:00 S
-+Rule Arg 2008 2009 - Mar Sun>=15 0:00 0 -
-+Rule Arg 2008 only - Oct Sun>=15 0:00 1:00 S
-
- # From Mariano Absatz (2004-05-21):
- # Today it was officially published that the Province of Mendoza is changing
diff --git a/sys-libs/timezone-data/timezone-data-2009j.ebuild b/sys-libs/timezone-data/timezone-data-2009j.ebuild
deleted file mode 100644
index c1075b98ef1f..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009j.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009j.ebuild,v 1.5 2009/07/24 16:39:15 josejx Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV/j/i}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-RDEPEND="!<sys-libs/glibc-2.3.5"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}
diff --git a/sys-libs/timezone-data/timezone-data-2009k.ebuild b/sys-libs/timezone-data/timezone-data-2009k.ebuild
deleted file mode 100644
index d7fa495899fe..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009k.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009k.ebuild,v 1.2 2009/08/17 20:28:09 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-RDEPEND="!<sys-libs/glibc-2.3.5"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}
diff --git a/sys-libs/timezone-data/timezone-data-2009l.ebuild b/sys-libs/timezone-data/timezone-data-2009l.ebuild
deleted file mode 100644
index f1cc1c37d5dd..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009l.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009l.ebuild,v 1.1 2009/08/17 20:29:13 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV/l/k}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-RDEPEND="!<sys-libs/glibc-2.3.5"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}
diff --git a/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild b/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild
deleted file mode 100644
index a9934b671e5b..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild,v 1.1 2009/10/19 07:31:28 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV/n/k}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-RDEPEND="!<sys-libs/glibc-2.3.5"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- epatch "${FILESDIR}"/${P}-argentina.patch #289345
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}
diff --git a/sys-libs/timezone-data/timezone-data-2009n.ebuild b/sys-libs/timezone-data/timezone-data-2009n.ebuild
deleted file mode 100644
index f517dcafad43..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009n.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009n.ebuild,v 1.1 2009/09/30 03:34:50 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV/n/k}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-RDEPEND="!<sys-libs/glibc-2.3.5"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}
diff --git a/sys-libs/timezone-data/timezone-data-2009o.ebuild b/sys-libs/timezone-data/timezone-data-2009o.ebuild
deleted file mode 100644
index 7123882a0192..000000000000
--- a/sys-libs/timezone-data/timezone-data-2009o.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009o.ebuild,v 1.1 2009/10/20 16:46:34 vapier Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-code_ver=${PV/o/k}
-data_ver=${PV}
-DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
-HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
-SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
- ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
- mirror://gentoo/tzdata${data_ver}.tar.gz
- mirror://gentoo/tzcode${code_ver}.tar.gz"
-
-LICENSE="BSD public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="nls elibc_FreeBSD elibc_glibc"
-
-RDEPEND="!<sys-libs/glibc-2.3.5"
-
-S=${WORKDIR}
-
-src_unpack() {
- unpack ${A}
- epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
- epatch "${FILESDIR}"/${PN}-2009n-argentina.patch #289345
- tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
-}
-
-src_compile() {
- local LDLIBS
- tc-export CC
- use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
- if use nls ; then
- use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
- export NLS=1
- else
- export NLS=0
- fi
- # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
- # But it also uses LFLAGS where it expects the real LDFLAGS
- emake \
- LDLIBS="${LDLIBS}" \
- || die "emake failed"
- if tc-is-cross-compiler ; then
- emake -C "${S}"-native \
- CC=$(tc-getBUILD_CC) \
- CFLAGS="${BUILD_CFLAGS}" \
- LDFLAGS="${BUILD_LDFLAGS}" \
- LDLIBS="${LDLIBS}" \
- zic || die
- fi
-}
-
-src_install() {
- local zic=""
- tc-is-cross-compiler && zic="zic=${S}-native/zic"
- emake install ${zic} DESTDIR="${D}" || die
- rm -rf "${D}"/usr/share/zoneinfo-leaps
- dodoc README Theory
- dohtml *.htm *.jpg
-}
-
-pkg_config() {
- # make sure the /etc/localtime file does not get stale #127899
- local tz src
-
- if has_version '<sys-apps/baselayout-2' ; then
- src="/etc/conf.d/clock"
- tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
- else
- src="/etc/timezone"
- if [[ -e ${ROOT}/etc/timezone ]] ; then
- tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
- else
- tz="FOOKABLOIE"
- fi
- fi
- [[ -z ${tz} ]] && return 0
-
- if [[ ${tz} == "FOOKABLOIE" ]] ; then
- elog "You do not have TIMEZONE set in ${src}."
-
- if [[ ! -e ${ROOT}/etc/localtime ]] ; then
- cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
- elog "Setting /etc/localtime to Factory."
- else
- elog "Skipping auto-update of /etc/localtime."
- fi
- return 0
- fi
-
- if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
- elog "You have an invalid TIMEZONE setting in ${src}"
- elog "Your /etc/localtime has been reset to Factory; enjoy!"
- tz="Factory"
- fi
- einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
- cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
-}
-
-pkg_postinst() {
- pkg_config
-}