summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-08-16 23:27:23 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-08-16 23:27:23 +0000
commit977f7425cc0821ced48ece8d6f3a36f108676eec (patch)
tree3d9695d7097cd5d1352e3e98e6a14d2de3d69ad4 /sys-libs
parentAdd o_direct support per bug #208967, not used by default. (diff)
downloadgentoo-2-977f7425cc0821ced48ece8d6f3a36f108676eec.tar.gz
gentoo-2-977f7425cc0821ced48ece8d6f3a36f108676eec.tar.bz2
gentoo-2-977f7425cc0821ced48ece8d6f3a36f108676eec.zip
Bug #218469, fix compilation with GCC4.3.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-3.2.9_p2.ebuild4
-rw-r--r--sys-libs/db/files/db-3.2.9-gcc43.patch16
3 files changed, 24 insertions, 2 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index ca42b3a92ff8..10d9fbbb3f4f 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.261 2008/08/16 22:46:49 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.262 2008/08/16 23:27:22 robbat2 Exp $
+
+ 16 Aug 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/db-3.2.9-gcc43.patch, db-3.2.9_p2.ebuild:
+ Bug #218469, fix compilation with GCC4.3.
16 Aug 2008; Robin H. Johnson <robbat2@gentoo.org> db-4.3.29_p1-r1.ebuild,
db-4.4.20_p4-r1.ebuild, db-4.5.20_p2-r1.ebuild, db-4.6.21_p3-r1.ebuild,
diff --git a/sys-libs/db/db-3.2.9_p2.ebuild b/sys-libs/db/db-3.2.9_p2.ebuild
index cb1ee993ac3b..2db18892134a 100644
--- a/sys-libs/db/db-3.2.9_p2.ebuild
+++ b/sys-libs/db/db-3.2.9_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9_p2.ebuild,v 1.3 2008/08/16 05:23:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9_p2.ebuild,v 1.4 2008/08/16 23:27:22 robbat2 Exp $
inherit eutils db
@@ -62,6 +62,8 @@ src_unpack() {
-e 's:DB185LIB=:DB185LIB= -ldb1:' \
"${S}"/dist/Makefile.in.orig > "${S}"/dist/Makefile.in || die "Failed to sed"
+ epatch "${FILESDIR}"/${MY_P}-gcc43.patch
+
# Fix invalid .la files
cd "${WORKDIR}"/${MY_P}/dist
rm -f ltversion.sh
diff --git a/sys-libs/db/files/db-3.2.9-gcc43.patch b/sys-libs/db/files/db-3.2.9-gcc43.patch
new file mode 100644
index 000000000000..f032da85296a
--- /dev/null
+++ b/sys-libs/db/files/db-3.2.9-gcc43.patch
@@ -0,0 +1,16 @@
+diff -Nuar db-3.2.9.orig/include/db_cxx.h db-3.2.9/include/db_cxx.h
+--- db-3.2.9.orig/include/db_cxx.h 2001-01-11 10:28:55.000000000 -0800
++++ db-3.2.9/include/db_cxx.h 2008-08-16 16:10:48.474699646 -0700
+@@ -49,7 +49,12 @@
+ // Forward declarations
+ //
+
++#if defined(__GNUC__) && (__GNUC__ == 4 && __GNUC_MINOR__ >= 2)
++using namespace std;
++#include <iostream>
++#else
+ #include <iostream.h>
++#endif
+ #include <stdarg.h>
+ #include "db.h"
+