summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-29 17:49:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-04-29 17:49:03 +0000
commit817f1531f9d67f3d1d5468b8485ac8d2f470b798 (patch)
treedc2e9f059c072cedc5eb24983881043b406a6d96 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-817f1531f9d67f3d1d5468b8485ac8d2f470b798.tar.gz
gentoo-2-817f1531f9d67f3d1d5468b8485ac8d2f470b798.tar.bz2
gentoo-2-817f1531f9d67f3d1d5468b8485ac8d2f470b798.zip
Try two at guessing what zlib wanted to do, assume a mistake between .4 and .5 where a condition was reversed, this one makes more sense in light of 1.2.4, the definitions _and_ the comments.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/zlib/ChangeLog11
-rw-r--r--sys-libs/zlib/files/zlib-1.2.5-lfs-decls.patch38
-rw-r--r--sys-libs/zlib/zlib-1.2.5-r2.ebuild (renamed from sys-libs/zlib/zlib-1.2.5-r1.ebuild)2
3 files changed, 20 insertions, 31 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index 1fe6b5820f2a..e39e92e9e8d3 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.79 2010/04/25 22:41:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.80 2010/04/29 17:49:03 flameeyes Exp $
+
+*zlib-1.2.5-r2 (29 Apr 2010)
+
+ 29 Apr 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -zlib-1.2.5-r1.ebuild, +zlib-1.2.5-r2.ebuild,
+ files/zlib-1.2.5-lfs-decls.patch:
+ Try two at guessing what zlib wanted to do, assume a mistake between .4
+ and .5 where a condition was reversed, this one makes more sense in light
+ of 1.2.4, the definitions _and_ the comments.
*zlib-1.2.5-r1 (25 Apr 2010)
diff --git a/sys-libs/zlib/files/zlib-1.2.5-lfs-decls.patch b/sys-libs/zlib/files/zlib-1.2.5-lfs-decls.patch
index 8e0e1bc2748d..36e26af035a6 100644
--- a/sys-libs/zlib/files/zlib-1.2.5-lfs-decls.patch
+++ b/sys-libs/zlib/files/zlib-1.2.5-lfs-decls.patch
@@ -1,33 +1,13 @@
-diff -urNp zlib-1.2.5/zlib.h zlib-1.2.5-new/zlib.h
---- zlib-1.2.5/zlib.h 2010-04-20 09:42:48.000000000 +0530
-+++ zlib-1.2.5-new/zlib.h 2010-04-21 13:44:40.105742649 +0530
-@@ -1571,21 +1571,20 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
- ZEXTERN uLong ZEXPORT crc32_combine64 OF((uLong, uLong, z_off64_t));
- #endif
-
--#if !defined(ZLIB_INTERNAL) && _FILE_OFFSET_BITS-0 == 64 && _LFS64_LARGEFILE-0
-+#if !defined(ZLIB_INTERNAL) && _FILE_OFFSET_BITS-0 == 64 && \
-+ _LFS64_LARGEFILE-0 && _LARGEFILE64_SOURCE
- # define gzopen gzopen64
- # define gzseek gzseek64
- # define gztell gztell64
+Index: zlib-1.2.5/zlib.h
+===================================================================
+--- zlib-1.2.5.orig/zlib.h
++++ zlib-1.2.5/zlib.h
+@@ -1578,7 +1578,7 @@ ZEXTERN int ZEXPORT inflateBackInit_ OF(
# define gzoffset gzoffset64
# define adler32_combine adler32_combine64
# define crc32_combine crc32_combine64
-# ifdef _LARGEFILE64_SOURCE
-- ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
-- ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
-- ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));
-- ZEXTERN z_off_t ZEXPORT gzoffset64 OF((gzFile));
-- ZEXTERN uLong ZEXPORT adler32_combine64 OF((uLong, uLong, z_off_t));
-- ZEXTERN uLong ZEXPORT crc32_combine64 OF((uLong, uLong, z_off_t));
--# endif
-+ ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
-+ ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
-+ ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));
-+ ZEXTERN z_off_t ZEXPORT gzoffset64 OF((gzFile));
-+ ZEXTERN uLong ZEXPORT adler32_combine64 OF((uLong, uLong, z_off_t));
-+ ZEXTERN uLong ZEXPORT crc32_combine64 OF((uLong, uLong, z_off_t));
- #else
- ZEXTERN gzFile ZEXPORT gzopen OF((const char *, const char *));
- ZEXTERN z_off_t ZEXPORT gzseek OF((gzFile, z_off_t, int));
++# ifndef _LARGEFILE64_SOURCE
+ ZEXTERN gzFile ZEXPORT gzopen64 OF((const char *, const char *));
+ ZEXTERN z_off_t ZEXPORT gzseek64 OF((gzFile, z_off_t, int));
+ ZEXTERN z_off_t ZEXPORT gztell64 OF((gzFile));
diff --git a/sys-libs/zlib/zlib-1.2.5-r1.ebuild b/sys-libs/zlib/zlib-1.2.5-r2.ebuild
index 44ecd869245f..f42f8cb7a903 100644
--- a/sys-libs/zlib/zlib-1.2.5-r1.ebuild
+++ b/sys-libs/zlib/zlib-1.2.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5-r1.ebuild,v 1.1 2010/04/25 22:41:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.5-r2.ebuild,v 1.1 2010/04/29 17:49:03 flameeyes Exp $
inherit eutils toolchain-funcs