summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-25 08:50:30 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-25 08:50:30 +0000
commit67ae642ddda63efb9ee2642636ebbfe9602f8cd8 (patch)
tree01dfed322519da2aae5a4078dd866a4259336fd2 /sys-libs
parentWeird tabbing. (diff)
downloadgentoo-2-67ae642ddda63efb9ee2642636ebbfe9602f8cd8.tar.gz
gentoo-2-67ae642ddda63efb9ee2642636ebbfe9602f8cd8.tar.bz2
gentoo-2-67ae642ddda63efb9ee2642636ebbfe9602f8cd8.zip
Install a simple fenv.h for newer gcc versions #266298 by Antonio Pezo.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/uclibc/ChangeLog5
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild13
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-libs/uclibc/ChangeLog b/sys-libs/uclibc/ChangeLog
index 7275b11af206..a38581d83df0 100644
--- a/sys-libs/uclibc/ChangeLog
+++ b/sys-libs/uclibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/uclibc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/ChangeLog,v 1.50 2009/08/25 08:28:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/ChangeLog,v 1.51 2009/08/25 08:50:30 vapier Exp $
+
+ 25 Aug 2009; Mike Frysinger <vapier@gentoo.org> uclibc-0.9.28.3-r8.ebuild:
+ Install a simple fenv.h for newer gcc versions #266298 by Antonio Pezo.
*uclibc-0.9.28.3-r8 (25 Aug 2009)
diff --git a/sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild b/sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild
index c84ba4911d07..960f1761bd94 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild,v 1.1 2009/08/25 08:28:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3-r8.ebuild,v 1.2 2009/08/25 08:50:30 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -419,6 +419,17 @@ src_install() {
# remove files coming from kernel-headers
rm -rf "${sysroot}"/usr/include/{linux,asm*}
+ if [[ -e ${D}/usr/include/bits/fenv.h && ! -e ${D}/usr/include/fenv.h ]] ; then
+ # install fenv.h for newer gcc versions #266298
+ cat <<-EOF > "${D}"/usr/include/fenv.h
+ #ifndef _FENV_H
+ #define _FENV_H
+ #include <features.h>
+ #include <bits/fenv.h>
+ #endif
+ EOF
+ fi
+
# Make sure we install the sys-include symlink so that when
# we build a 2nd stage cross-compiler, gcc finds the target
# system headers correctly. See gcc/doc/gccinstall.info