summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-07-05 01:24:31 +0000
committerMarius Mauch <genone@gentoo.org>2004-07-05 01:24:31 +0000
commit5e36313617fb729096e9c18c15902af4dc1316fe (patch)
tree15cef55ef75eefc50af9c7031c0b1bf67c1c892e /sys-libs
parentStable on x86. (Manifest recommit) (diff)
downloadgentoo-2-5e36313617fb729096e9c18c15902af4dc1316fe.tar.gz
gentoo-2-5e36313617fb729096e9c18c15902af4dc1316fe.tar.bz2
gentoo-2-5e36313617fb729096e9c18c15902af4dc1316fe.zip
added a downgrade check for bug 25230 (you have been warned)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog12
-rw-r--r--sys-libs/glibc/glibc-2.2.5-r9.ebuild27
-rw-r--r--sys-libs/glibc/glibc-2.3.1-r5.ebuild25
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r10.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r2.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r9.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3.20040420.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040605.ebuild23
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619.ebuild23
16 files changed, 346 insertions, 17 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 643f309ff3a5..16b29d97f392 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.198 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.199 2004/07/05 01:24:31 genone Exp $
+
+ 05 Jul 2004; Marius Mauch <genone@gentoo.org> glibc-2.2.5-r9.ebuild,
+ glibc-2.3.1-r5.ebuild, glibc-2.3.2-r10.ebuild, glibc-2.3.2-r2.ebuild,
+ glibc-2.3.2-r9.ebuild, glibc-2.3.3.20040420.ebuild,
+ glibc-2.3.3_pre20031210.ebuild, glibc-2.3.3_pre20040117-r1.ebuild,
+ glibc-2.3.3_pre20040117.ebuild, glibc-2.3.3_pre20040207.ebuild,
+ glibc-2.3.3_pre20040420.ebuild, glibc-2.3.3_pre20040529.ebuild,
+ glibc-2.3.4.20040605-r1.ebuild, glibc-2.3.4.20040605.ebuild,
+ glibc-2.3.4.20040619.ebuild:
+ added a downgrade check to pkg_setup for bug #25230.
27 Jun 2004; Aron Griffis <agriffis@gentoo.org> glibc-2.3.1-r5.ebuild,
glibc-2.3.2-r10.ebuild, glibc-2.3.2-r2.ebuild, glibc-2.3.2-r9.ebuild,
diff --git a/sys-libs/glibc/glibc-2.2.5-r9.ebuild b/sys-libs/glibc/glibc-2.2.5-r9.ebuild
index de63ba83b602..385c741f9e6f 100644
--- a/sys-libs/glibc/glibc-2.2.5-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.2.5-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r9.ebuild,v 1.6 2004/06/25 15:27:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.2.5-r9.ebuild,v 1.7 2004/07/05 01:24:31 genone Exp $
inherit flag-o-matic gcc eutils
@@ -58,6 +58,31 @@ RDEPEND="virtual/os-headers
build? ( >=sys-apps/portage-1.9.0 )"
PROVIDE="virtual/glibc virtual/libc"
+pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
+ return 0
+}
+
src_unpack() {
unpack glibc-${PV}.tar.bz2 || die
cd ${S}
diff --git a/sys-libs/glibc/glibc-2.3.1-r5.ebuild b/sys-libs/glibc/glibc-2.3.1-r5.ebuild
index 7e68917b1593..c3ffbbbec084 100644
--- a/sys-libs/glibc/glibc-2.3.1-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r5.ebuild,v 1.10 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.1-r5.ebuild,v 1.11 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build debug"
@@ -62,7 +62,28 @@ RDEPEND="virtual/os-headers
PROVIDE="virtual/glibc virtual/libc"
-pkg_config() {
+pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
eerror "As of glibc-2.3, gcc-3.2 or later is needed"
diff --git a/sys-libs/glibc/glibc-2.3.2-r10.ebuild b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
index 77fca16eab01..88e6d46ba6fb 100644
--- a/sys-libs/glibc/glibc-2.3.2-r10.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.15 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r10.ebuild,v 1.16 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -162,6 +162,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.2-r2.ebuild b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
index 050f4d7b9924..8f39f4eb175b 100644
--- a/sys-libs/glibc/glibc-2.3.2-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.22 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r2.ebuild,v 1.23 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -192,6 +192,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.2-r9.ebuild b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
index b74b1ef3f008..9d334ad08229 100644
--- a/sys-libs/glibc/glibc-2.3.2-r9.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.28 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r9.ebuild,v 1.29 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -163,6 +163,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
index 68bb2e9bf11e..9ef8254087d9 100644
--- a/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3.20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.8 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3.20040420.ebuild,v 1.9 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl erandom debug"
@@ -164,6 +164,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild
index 0e7c2e4824c3..a51941d0d458 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild,v 1.11 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20031210.ebuild,v 1.12 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -164,6 +164,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild
index 75d10e7d7555..7c16d15b2f93 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild,v 1.9 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117-r1.ebuild,v 1.10 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -162,6 +162,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild
index cced9ac24f3d..f433e924db41 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild,v 1.10 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040117.ebuild,v 1.11 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -161,6 +161,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
index 800bf2f7e122..4857128da05d 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild,v 1.13 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040207.ebuild,v 1.14 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -162,6 +162,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
index 61ada1eeb118..7e9a258ae175 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.10 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040420.ebuild,v 1.11 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl debug"
@@ -162,6 +162,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild b/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild
index 9552366c231c..428cc6de5b70 100644
--- a/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild
+++ b/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild,v 1.18 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.3_pre20040529.ebuild,v 1.19 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl erandom hardened multilib debug"
@@ -165,6 +165,27 @@ use_nptl() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
index d12fcdeed750..d55b3918618c 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild,v 1.10 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605-r1.ebuild,v 1.11 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -202,6 +202,27 @@ setup_locales() {
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]; then
echo
diff --git a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
index a20dd9cc44a9..eb2d9d09440a 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040605.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.18 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040605.ebuild,v 1.19 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -187,6 +187,27 @@ setup_locales() {
}
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]
then
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
index f5c96f7580b4..bbed4f583750 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.6 2004/06/28 02:03:43 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619.ebuild,v 1.7 2004/07/05 01:24:31 genone Exp $
IUSE="nls pic build nptl erandom hardened makecheck multilib debug"
@@ -281,6 +281,27 @@ setup_locales() {
pkg_setup() {
+ # Check if we are going to downgrade, we don't like that
+ local old_version
+
+ old_version="`best_version glibc`"
+ old_version="${old_version/sys-libs\/glibc-/}"
+
+ if [ `python -c "import portage; print int(portage.vercmp(\"${PV}\",\"$old_version\"))"` -lt 0 ]; then
+ if [ "${FORCE_DOWNGRADE}" ]; then
+ ewarn "downgrading glibc, still not recommended, but we'll do as you wish"
+ return 0
+ else
+ eerror "Dowgrading glibc is not supported and we strongly recommend that"
+ eerror "you don't do it as it WILL break all applications compiled against"
+ eerror "the new version (most likely including python and portage)."
+ eerror "If you are REALLY sure that you want to do it set "
+ eerror " FORCE_DOWNGRADE=1"
+ eerror "when you try it again."
+ die "glibc downgrade"
+ fi
+ fi
+
# We need gcc 3.2 or later ...
if [ "`gcc-major-version`" -ne "3" -o "`gcc-minor-version`" -lt "2" ]; then
echo