summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-30 01:36:43 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-30 01:36:43 +0000
commit5c6e901dcb663fdda5d40d4fa12014cc6b4520c3 (patch)
tree8e1daa71ea412bd5e0089f4de3da62ebda11e2d1 /sys-libs
parentremoved un_ifdef handling breaks vdr-setup compile, readdded un_ifdef handling (diff)
downloadgentoo-2-5c6e901dcb663fdda5d40d4fa12014cc6b4520c3.tar.gz
gentoo-2-5c6e901dcb663fdda5d40d4fa12014cc6b4520c3.tar.bz2
gentoo-2-5c6e901dcb663fdda5d40d4fa12014cc6b4520c3.zip
Create a config.cache with first configure and re-use it with the rlfe subdir for a slight speedup.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog6
-rw-r--r--sys-libs/readline/readline-6.2_p1-r1.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 58660b071700..3c4110c8c519 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.180 2012/04/26 13:12:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.181 2012/04/30 01:36:43 vapier Exp $
+
+ 30 Apr 2012; Mike Frysinger <vapier@gentoo.org> readline-6.2_p1-r1.ebuild:
+ Create a config.cache with first configure and re-use it with the rlfe subdir
+ for a slight speedup.
26 Apr 2012; Alexis Ballier <aballier@gentoo.org> readline-6.2_p1-r1.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-libs/readline/readline-6.2_p1-r1.ebuild b/sys-libs/readline/readline-6.2_p1-r1.ebuild
index 471de4bdcb8f..ac7bf623e715 100644
--- a/sys-libs/readline/readline-6.2_p1-r1.ebuild
+++ b/sys-libs/readline/readline-6.2_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.2_p1-r1.ebuild,v 1.3 2012/04/26 13:12:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.2_p1-r1.ebuild,v 1.4 2012/04/30 01:36:43 vapier Exp $
inherit eutils multilib toolchain-funcs flag-o-matic
@@ -64,7 +64,11 @@ src_compile() {
# http://lists.gnu.org/archive/html/bug-readline/2010-07/msg00013.html
append-cppflags -Dxrealloc=_rl_realloc -Dxmalloc=_rl_malloc -Dxfree=_rl_free
+ # This is for rlfe, but we need to make sure LDFLAGS doesn't change
+ # so we can re-use the config cache file between the two.
+ append-ldflags -L.
econf \
+ --cache-file="${S}"/config.cache \
--with-curses \
$(use_enable static-libs static)
emake || die
@@ -72,13 +76,12 @@ src_compile() {
if ! tc-is-cross-compiler ; then
# code is full of AC_TRY_RUN()
cd examples/rlfe
- append-ldflags -L.
local l
for l in readline history ; do
ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
ln -sf ../../lib${l}.a lib${l}.a
done
- econf
+ econf --cache-file="${S}"/config.cache
emake || die
fi
}