summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-26 16:26:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-26 16:26:33 +0000
commit5b95b646c3f6569cbdfbd9395ddb0f6c316697eb (patch)
tree3ec0888e38ccf2aaf0d130d43f6722bbb2fe9f74 /sys-libs
parentRevert my revert (its official, I suck) (diff)
downloadgentoo-2-5b95b646c3f6569cbdfbd9395ddb0f6c316697eb.tar.gz
gentoo-2-5b95b646c3f6569cbdfbd9395ddb0f6c316697eb.tar.bz2
gentoo-2-5b95b646c3f6569cbdfbd9395ddb0f6c316697eb.zip
use -fno-strict-aliasing #155906
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.4-r4.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.5.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index 7b2c6eade901..384e9ec40388 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.17 2006/11/25 15:41:29 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.18 2006/11/26 16:26:33 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -697,9 +697,9 @@ setup_flags() {
filter-ldflags -Wl,-hashvals
# Lock glibc at -O2 -- linuxthreads needs it and we want to be
- # conservative here
+ # conservative here. -fno-strict-aliasing is to work around #155906
filter-flags -O?
- append-flags -O2
+ append-flags -O2 -fno-strict-aliasing
}
check_kheader_version() {
diff --git a/sys-libs/glibc/glibc-2.4-r4.ebuild b/sys-libs/glibc/glibc-2.4-r4.ebuild
index 4f486bd675ba..68950261e0df 100644
--- a/sys-libs/glibc/glibc-2.4-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.13 2006/11/25 15:41:29 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.14 2006/11/26 16:26:33 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -705,9 +705,9 @@ setup_flags() {
filter-ldflags -pie
# Lock glibc at -O2 -- linuxthreads needs it and we want to be
- # conservative here
+ # conservative here. -fno-strict-aliasing is to work around #155906
filter-flags -O?
- append-flags -O2
+ append-flags -O2 -fno-strict-aliasing
}
check_kheader_version() {
diff --git a/sys-libs/glibc/glibc-2.5.ebuild b/sys-libs/glibc/glibc-2.5.ebuild
index 9f62bdf7d10a..a3bf43fa22b3 100644
--- a/sys-libs/glibc/glibc-2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.15 2006/11/10 23:56:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.16 2006/11/26 16:26:33 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -686,9 +686,9 @@ setup_flags() {
filter-ldflags -pie
# Lock glibc at -O2 -- linuxthreads needs it and we want to be
- # conservative here
+ # conservative here. -fno-strict-aliasing is to work around #155906
filter-flags -O?
- append-flags -O2
+ append-flags -O2 -fno-strict-aliasing
}
check_kheader_version() {