summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-14 02:51:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-14 02:51:58 +0000
commit2999398ebae4107e98e6debe6b738a32f5967813 (patch)
treebecf677beb0e3c26ee6e1447a2ca9ecc72d7d395 /sys-libs
parentClean up USE=uclibc and USE=nocxx usage. (Manifest recommit) (diff)
downloadgentoo-2-2999398ebae4107e98e6debe6b738a32f5967813.tar.gz
gentoo-2-2999398ebae4107e98e6debe6b738a32f5967813.tar.bz2
gentoo-2-2999398ebae4107e98e6debe6b738a32f5967813.zip
change last of USE=makecheck to USE=test and fix cross-compile stripping
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild16
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild8
4 files changed, 20 insertions, 20 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index 7f06574ccf50..8aaa67fb13c9 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.5 2005/01/05 01:53:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.6 2005/01/14 02:51:58 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -17,10 +17,10 @@ export MIN_KV="2.4.1"
export MIN_NPTL_KV="2.6.0"
# (very) Theoretical cross-compiler support
-export CTARGET="${CTARGET:-${CHOST}}"
+export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} = ${CHOST} ]] ; then
if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET="${CATEGORY/cross-}"
+ export CTARGET=${CATEGORY/cross-}
fi
fi
@@ -607,7 +607,7 @@ src_install() {
# now, strip everything but the thread libs #46186
mkdir ${T}/thread-backup
mv ${D}/lib/lib{pthread,thread_db}* ${T}/thread-backup/
- env -uRESTRICT prepallstrip
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
mv ${T}/thread-backup/* ${D}/lib/
# If librt.so is a symlink, change it into linker script (Redhat)
diff --git a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
index 7728f497d93b..fd1cc1689924 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.6 2005/01/12 05:17:16 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040619-r2.ebuild,v 1.7 2005/01/14 02:51:58 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -45,7 +45,7 @@ fi
LICENSE="LGPL-2"
SLOT="2.2"
KEYWORDS="-* ~x86 mips amd64 ~hppa ~ppc ~ia64"
-IUSE="userlocales pic build nptl erandom hardened makecheck multilib debug n32 n64"
+IUSE="userlocales pic build nptl erandom hardened test multilib debug n32 n64"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
# We need new cleanup attribute support from gcc for NPTL among things ...
@@ -221,7 +221,7 @@ want_tls() {
}
-do_makecheck() {
+do_test() {
ATIME=`mount | awk '{ print $3,$6 }' | grep ^\/\ | grep noatime`
if [ "$ATIME" = "" ]; then
cd ${WORKDIR}/build
@@ -249,8 +249,8 @@ install_locales() {
setup_locales() {
- if use !userlocales || use makecheck; then
- einfo "makecheck in USE or userlocales not enabled, installing -ALL- locales..."
+ if use !userlocales || use test; then
+ einfo "test in USE or userlocales not enabled, installing -ALL- locales..."
install_locales || die
elif [ -e /etc/locales.build ]; then
einfo "Installing locales in /etc/locales.build..."
@@ -306,7 +306,7 @@ glibc_setup() {
fi
echo
- hasq sandbox $FEATURES && use makecheck && die "sandbox breaks make check. either take makecheck out of USE or set FEATURES=-sandbox"
+ hasq sandbox $FEATURES && use test && die "sandbox breaks make check. either take test out of USE or set FEATURES=-sandbox"
}
@@ -711,12 +711,12 @@ EOF
insinto /etc
doins ${FILESDIR}/locales.build
- if use makecheck; then
+ if use test; then
local OLD_SANDBOX_ON="${SANDBOX_ON}"
# make check will fail if sandbox is enabled. Do not do it
# globally though, else we might fail to find sandbox violations ...
SANDBOX_ON="0"
- do_makecheck
+ do_test
SANDBOX_ON="${OLD_SANDBOX_ON}"
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index d1083396acf6..f01ef491e05c 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.32 2005/01/12 12:24:10 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.33 2005/01/14 02:51:58 vapier Exp $
inherit eutils multilib flag-o-matic gcc versionator
@@ -15,10 +15,10 @@ BRANCH_UPDATE="20040808"
MIN_KERNEL_VERSION="2.6.5"
# (very) Theoretical cross-compiler support
-export CTARGET="${CTARGET:-${CHOST}}"
+export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} = ${CHOST} ]] ; then
if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET="${CATEGORY/cross-}"
+ export CTARGET=${CATEGORY/cross-}
fi
fi
@@ -747,7 +747,7 @@ src_install() {
# now, strip everything but the thread libs #46186
mkdir -p ${T}/thread-backup
mv ${D}/$(alt_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
- env -uRESTRICT prepallstrip
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
# this directory can be empty in certain cases so || die is wrong
ls ${T}/thread-backup/* 1>/dev/null 2>&1 && mv -f ${T}/thread-backup/* ${D}/$(alt_libdir)/
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index 6451888ad816..bea3c0d47c43 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.27 2005/01/12 12:25:14 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.28 2005/01/14 02:51:58 vapier Exp $
inherit eutils multilib flag-o-matic gcc versionator
@@ -15,10 +15,10 @@ BRANCH_UPDATE="20041102"
MIN_KERNEL_VERSION="2.6.5"
# (very) Theoretical cross-compiler support
-export CTARGET="${CTARGET:-${CHOST}}"
+export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} = ${CHOST} ]] ; then
if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET="${CATEGORY/cross-}"
+ export CTARGET=${CATEGORY/cross-}
fi
fi
@@ -870,7 +870,7 @@ src_install() {
mkdir -p ${T}/thread-backup/tls
mv ${D}/$(alt_libdir)/tls/lib{pthread,thread_db}* ${T}/thread-backup/tls
fi
- env -uRESTRICT prepallstrip
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
cp -R -- ${T}/thread-backup/* ${D}/$(alt_libdir)/ || die
# If librt.so is a symlink, change it into linker script (Redhat)