summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-03 05:12:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-03 05:12:54 +0000
commit17add79c28243d4f891a12fbc925d82e2dfa0b17 (patch)
treef106d9ff4ea9dd2ec0e89b2af7573ea8be0865e8 /sys-libs
parentm68k love (diff)
downloadgentoo-2-17add79c28243d4f891a12fbc925d82e2dfa0b17.tar.gz
gentoo-2-17add79c28243d4f891a12fbc925d82e2dfa0b17.tar.bz2
gentoo-2-17add79c28243d4f891a12fbc925d82e2dfa0b17.zip
Dont try the ld.so test on static binaries #90836 by Vasilii Alferov.
(Portage version: 2.0.51.21)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog9
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.3.5.20050421.ebuild8
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild8
5 files changed, 31 insertions, 10 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 892d1274cb57..51350bc7bf2e 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.343 2005/04/29 16:20:01 corsair Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.344 2005/05/03 05:12:54 vapier Exp $
+
+ 03 May 2005; Mike Frysinger <vapier@gentoo.org>
+ glibc-2.3.4.20041102-r1.ebuild, glibc-2.3.4.20050125-r1.ebuild,
+ glibc-2.3.5.ebuild, glibc-2.3.5.20050421.ebuild:
+ Dont try the ld.so test on static binaries #90836 by Vasilii Alferov.
29 Apr 2005; Markus Rothe <corsair@gentoo.org>
glibc-2.3.4.20050125.ebuild, glibc-2.3.4.20050125-r1.ebuild,
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
index ca3c72a9f773..8fdb2a2299f9 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.8 2005/04/22 23:04:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102-r1.ebuild,v 1.9 2005/05/03 05:12:54 vapier Exp $
inherit eutils multilib flag-o-matic toolchain-funcs versionator
@@ -1008,11 +1008,15 @@ EOF
doins ${FILESDIR}/2.3.4/host.conf
# simple test to make sure our new glibc isnt completely broken.
- # for now, skip the multilib scenario.
+ # for now, skip the multilib scenario. also make sure we don't
+ # test with statically built binaries since they will fail.
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
[[ -z ${x} ]] && continue
+ striptest=$(file -L ${x} 2>/dev/null)
+ [[ -z ${striptest} ]] && continue
+ [[ ${striptest/statically linked} != "${striptest}" ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 67a6876e9864..e004ac15acd4 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.43 2005/04/29 16:20:01 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.44 2005/05/03 05:12:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -488,11 +488,15 @@ toolchain-glibc_src_install() {
doins ${FILESDIR}/2.3.4/host.conf
# simple test to make sure our new glibc isnt completely broken.
- # for now, skip the multilib scenario.
+ # for now, skip the multilib scenario. also make sure we don't
+ # test with statically built binaries since they will fail.
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
[[ -z ${x} ]] && continue
+ striptest=$(file -L ${x} 2>/dev/null)
+ [[ -z ${striptest} ]] && continue
+ [[ ${striptest/statically linked} != "${striptest}" ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \
diff --git a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
index 596a4de55115..3b142962e46a 100644
--- a/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.20050421.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.5 2005/04/29 16:20:01 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.20050421.ebuild,v 1.6 2005/05/03 05:12:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -500,11 +500,15 @@ toolchain-glibc_src_install() {
doins ${FILESDIR}/2.3.4/host.conf
# simple test to make sure our new glibc isnt completely broken.
- # for now, skip the multilib scenario.
+ # for now, skip the multilib scenario. also make sure we don't
+ # test with statically built binaries since they will fail.
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
[[ -z ${x} ]] && continue
+ striptest=$(file ${x} 2>/dev/null)
+ [[ -z ${striptest} ]] && continue
+ [[ ${striptest/statically linked} != "${striptest}" ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index adfbe5c0e091..4e3d5be1de14 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.12 2005/04/29 16:20:01 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.13 2005/05/03 05:12:54 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -492,11 +492,15 @@ toolchain-glibc_src_install() {
doins ${FILESDIR}/2.3.4/host.conf
# simple test to make sure our new glibc isnt completely broken.
- # for now, skip the multilib scenario.
+ # for now, skip the multilib scenario. also make sure we don't
+ # test with statically built binaries since they will fail.
[[ $(get_libdir) != "lib" ]] && return 0
for x in date env ls true uname ; do
x=$(type -p ${x})
[[ -z ${x} ]] && continue
+ striptest=$(file -L ${x} 2>/dev/null)
+ [[ -z ${striptest} ]] && continue
+ [[ ${striptest/statically linked} != "${striptest}" ]] && continue
"${D}"/$(get_libdir)/ld-*.so \
--library-path "${D}"/$(get_libdir) \
${x} > /dev/null \