summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-19 07:31:28 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-19 07:31:28 +0000
commit0344ecb5e772eccf22139a713e3baac7a09d7927 (patch)
tree31dc169da2880e60399998eca9f7a752d7d3ea9e /sys-libs
parentgentoo-newsitem-mode wasn't autoloaded. (diff)
downloadgentoo-2-0344ecb5e772eccf22139a713e3baac7a09d7927.tar.gz
gentoo-2-0344ecb5e772eccf22139a713e3baac7a09d7927.tar.bz2
gentoo-2-0344ecb5e772eccf22139a713e3baac7a09d7927.zip
Apply change from Debian for Argentina changes #289345 by Rodrigo Campos.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/ChangeLog9
-rw-r--r--sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch19
-rw-r--r--sys-libs/timezone-data/timezone-data-2009n-r1.ebuild107
3 files changed, 134 insertions, 1 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index b01e567d8d5c..5abbb903e57e 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.204 2009/10/05 15:33:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.205 2009/10/19 07:31:28 vapier Exp $
+
+*timezone-data-2009n-r1 (19 Oct 2009)
+
+ 19 Oct 2009; Mike Frysinger <vapier@gentoo.org>
+ +timezone-data-2009n-r1.ebuild,
+ +files/timezone-data-2009n-argentina.patch:
+ Apply change from Debian for Argentina changes #289345 by Rodrigo Campos.
05 Oct 2009; Raúl Porcel <armin76@gentoo.org> timezone-data-2009m.ebuild:
ia64/m68k/s390/sh/sparc stable wrt #287016
diff --git a/sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch b/sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch
new file mode 100644
index 000000000000..60065d82a4a1
--- /dev/null
+++ b/sys-libs/timezone-data/files/timezone-data-2009n-argentina.patch
@@ -0,0 +1,19 @@
+--- tzdata/southamerica
++++ tzdata/southamerica
+@@ -215,9 +215,14 @@
+ # http://www.jujuy.gov.ar/index2/partes_prensa/18_10_08/235-181008.doc
+ # </a>
+
++# Margarita Manterola:
++# Same as always, Argentina's government just decided to change its mind
++# regarding DST, 2 days in advance.
++# http://www.lanacion.com.ar/nota.asp?nota_id=1186963&pid=7542694&toi=6275
++
+ Rule Arg 2007 only - Dec 30 0:00 1:00 S
+-Rule Arg 2008 max - Mar Sun>=15 0:00 0 -
+-Rule Arg 2008 max - Oct Sun>=15 0:00 1:00 S
++Rule Arg 2008 2009 - Mar Sun>=15 0:00 0 -
++Rule Arg 2008 only - Oct Sun>=15 0:00 1:00 S
+
+ # From Mariano Absatz (2004-05-21):
+ # Today it was officially published that the Province of Mendoza is changing
diff --git a/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild b/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild
new file mode 100644
index 000000000000..a9934b671e5b
--- /dev/null
+++ b/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2009n-r1.ebuild,v 1.1 2009/10/19 07:31:28 vapier Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+code_ver=${PV/n/k}
+data_ver=${PV}
+DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
+HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
+SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${data_ver}.tar.gz
+ ftp://elsie.nci.nih.gov/pub/tzcode${code_ver}.tar.gz
+ mirror://gentoo/tzdata${data_ver}.tar.gz
+ mirror://gentoo/tzcode${code_ver}.tar.gz"
+
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls elibc_FreeBSD elibc_glibc"
+
+RDEPEND="!<sys-libs/glibc-2.3.5"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-2008h-makefile.patch
+ epatch "${FILESDIR}"/${P}-argentina.patch #289345
+ tc-is-cross-compiler && cp -pR "${S}" "${S}"-native
+}
+
+src_compile() {
+ local LDLIBS
+ tc-export CC
+ use elibc_FreeBSD && append-flags -DSTD_INSPIRED #138251
+ if use nls ; then
+ use elibc_glibc || LDLIBS="${LDLIBS} -lintl" #154181
+ export NLS=1
+ else
+ export NLS=0
+ fi
+ # Makefile uses LBLIBS for the libs (which defaults to LDFLAGS)
+ # But it also uses LFLAGS where it expects the real LDFLAGS
+ emake \
+ LDLIBS="${LDLIBS}" \
+ || die "emake failed"
+ if tc-is-cross-compiler ; then
+ emake -C "${S}"-native \
+ CC=$(tc-getBUILD_CC) \
+ CFLAGS="${BUILD_CFLAGS}" \
+ LDFLAGS="${BUILD_LDFLAGS}" \
+ LDLIBS="${LDLIBS}" \
+ zic || die
+ fi
+}
+
+src_install() {
+ local zic=""
+ tc-is-cross-compiler && zic="zic=${S}-native/zic"
+ emake install ${zic} DESTDIR="${D}" || die
+ rm -rf "${D}"/usr/share/zoneinfo-leaps
+ dodoc README Theory
+ dohtml *.htm *.jpg
+}
+
+pkg_config() {
+ # make sure the /etc/localtime file does not get stale #127899
+ local tz src
+
+ if has_version '<sys-apps/baselayout-2' ; then
+ src="/etc/conf.d/clock"
+ tz=$(unset TIMEZONE ; source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE-FOOKABLOIE})
+ else
+ src="/etc/timezone"
+ if [[ -e ${ROOT}/etc/timezone ]] ; then
+ tz=$(sed -e 's:#.*::' -e 's:[[:space:]]*::g' -e '/^$/d' "${ROOT}"/etc/timezone)
+ else
+ tz="FOOKABLOIE"
+ fi
+ fi
+ [[ -z ${tz} ]] && return 0
+
+ if [[ ${tz} == "FOOKABLOIE" ]] ; then
+ elog "You do not have TIMEZONE set in ${src}."
+
+ if [[ ! -e ${ROOT}/etc/localtime ]] ; then
+ cp -f "${ROOT}"/usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ elog "Setting /etc/localtime to Factory."
+ else
+ elog "Skipping auto-update of /etc/localtime."
+ fi
+ return 0
+ fi
+
+ if [[ ! -e ${ROOT}/usr/share/zoneinfo/${tz} ]] ; then
+ elog "You have an invalid TIMEZONE setting in ${src}"
+ elog "Your /etc/localtime has been reset to Factory; enjoy!"
+ tz="Factory"
+ fi
+ einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
+ [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
+ cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
+}
+
+pkg_postinst() {
+ pkg_config
+}